Free space problem

Hello i had 49% free space after installing speedtest package i lost space. To 1% i manged to delete that package but the free space still showing 1% didnt return to 49% why? I deleted the package but space didnt recover to pervious one

There were probably a number of dependencies that were installed alongside the speedtest package.

You probably need to run one or both of these commands (via the CLI):
--autoremove Remove packages that were installed automatically to satisfy dependencies
--force-removal-of-dependent-packages Remove package and all dependencies

Also, see:


Maybe also check for any big files inside /tmp in case there's any stuff there? What is this speedtest package anyway?

My problem is i tried to remove python3-speedtest but its stuck I can't remove it. I tried many times but i still see it in installed packages any command to force this package to unistall

did you try the command line options that I referenced?

Speedtest-netpref and python3-speedtest

I tried opkg remove " package". But it didnt remove it its stuck in root

did you try using the autoremove or or force-removal-of-dependent-packages options from the command line when doing opkg remove??

Yes i did tried this commands but it says no package. i still see it in installed list

can you show the commands and the output/errors?

'foo' is not a package.... of course you are getting errors.

But you've also run out of space to the point where your partition is read only.

You probably need to reset to defaults using failsafe mode.

1 Like

But reset to default will make me lose all my configuration isnt or i can do a backup?

Run a backup first. You can restore your backup after you reset.

1 Like

But after reset i will be able to solve the space issuee?

the reset will solve it directly by erasing all user-installed packages.

1 Like

But once i restore my settings by using the " backup file" it will not restore all packages and errors again?

Unless you have done anything unusual, the backup file only stores the configuration files. These are very small. It will not restore any packages.


If jffs has converted to read only you can't remove anything separately you'll need to backup your configuration then erase the whole jffs (everything that you've installed or configured) and start over.

No, the backup file only contains configuration files. You will need to reinstall necessary packages separately before they will work, but they will already be configured from restoring the backup.

python-speedtest necessarily also installs Python, which is very large. So don't try that again on a 16 MB model.


.... save yourself some headache, and run speedtest on a client next time.