For sale: MQmaker WiTi and Archer C7 v2


Selling these as I have new hardware to play with. They still work well though.

A few notes:

Both have 16MB flash, the archer has 128MB RAM and 256MB RAM on the WiTi.

Both have serial headers for all that fun stuff.

WiTi has RTC, 2 SATA ports (asmedia controller. forgot which model), expansion port (i have not used), USB 3 port, microsd port, and an extra WAN port. For fun I guess.

The WiTi was purchased as part of the initial IndieGoGo campaign. The currently out of stock one on the website has double the flash and RAM.

The WiTi has been upgraded with 2 extra antenna slots, heatsinks and an RTC battery (very hard to find LIR1220).

The SD Card driver is in a pretty bad state. It works but does throw out errors. Needs some developer love. mt76 being a relatively new driver also needs some as well. I'm happy I was able to find the bugs that I did.

SATA connectors came with the device. I think I threw the data ones away though. Was having issues with them. Will send the two pictured. The black one says 6G on it. The actual sata controller is a 6G one connected through a pcie 1.1 link (2.5gbps). Better than USB but still.

Also threw away the USB serial cable. Worked poorly .under both Windows and Linux.

Archer C7 has a mini pcie slot for the wireless card. Meaning it can be replaced with something else if needed.

Not pictured are the power bricks (do I need to?).

Feel free to ask questions.

Asking price : $69 for WiTi, $59 for Archer.

Will ship to continental US. Preferred payment is Paypal. Google Wallet works too.

1 Like

Do you maybe still have firmware that works with your Witi board? Can you please post it here?

I have MQMaker Witi board, not sure which revision it is... on the board it says "MQ-V2.0-20150706" and it has 256MB of ram.

I tried (by mistake) flashing it with 512MB firmware version and that of course didn't work.

Wi-Fi works only with LEDE 17.01 firmware but with OpenWrt 18.06.4 it boots but doesn't show any wifi radios detected.

Also both versions fail to setup /overlay partition so I see 0 free space and no way to make uci / luci changes permanent or to install any package.

Also it doesn't help that MQMaker website has gone down, AFAIK MQMaker company has shutdown.

@valentt Please do not multi-post.
Discussion continues in Working OpenWrt image for MQMaker Witi board