Follow on conversation for TP-Link Archer A6 v2 5GHz improvements, including user support

see https://github.com/openwrt/openwrt/pull/2470

Historical Summary as of 04-Dec-2020

3 Likes

Can you summarize in short words what this topic is about?
What exactly do you want to discuss here?

Defining what a topic is about helps others finding relevant information easier.

2 Likes

Builds are building - https://www.pdinc.us/public/ci/job/openwrt-fedora-build/

Hi pdinc-oss,

I have the TP-Link AC1200 (Archer A6), and I just tried your latest stable variant 2 openwrt-ath79-generic-tplink_archer-c6-v2-us-squashfs-sysupgrade.bin (build #18).

For some reason, when I try to connect via 5G on my iPhone, I get the error "Unable to join the network. If your network security is managed by Wi-Fi address (also known as "MAC Address"), you may need to turn off Private Wi-Fi Address or modify your network settings." In OpenWrt -> Network -> Wireless, the Host always shows as "?" for 5G. I have had this issue with the latest developmental snapshots and variants. I remember that 5G used to work in older stable builds, albeit with weak signal. I have no issues with 2G though.

Do you know how I would resolve the 5G issue (I am a total newbie at OpenWrt)? Thank you!

Does the 5GHz behave as old on the snapshot version?

Do you have a rough idea of when or the commit id from the "used to work in older stable builds"?

Note: I am assuming that "stable" is not referring to the OpenWRT stable release, as this router's support has not yet merged to stable release branch.

I believe I first tried OpenWrt on 11/11/2020 with the following firmwares, and 5G worked at the time, but with weak signal:
http://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-tplink_archer-c6-v2-us-squashfs-factory.bin
http://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-tplink_archer-c6-v2-us-squashfs-sysupgrade.bin

I believe I also tried "openwrt-ath79-generic-tplink_archer-c6-v2-us-squashfs-sysupgrade.bin" within the following link (julianocss's builds), and 5G also worked and also had better signal (except I couldn't get SQM Cake to work with that kernel):
https://u.pcloud.link/publink/show?code=kZh6A2kZKOQ5tzg4BsjPW2GMfIcIFHw6Osey#folder=7495769514

1 Like

i have get internet led problems in latest snapshot build and julianocss's build. My connection type is pppoe. after ppoe interface connected successfully, the internet led remains red.. i need to change led effect from luci-led-configuration.

please let me know if the 11-nov-2020 version is similar, better, or worse than the snapshot of 8eeb57a build: https://www.pdinc.us/public/ci/job/openwrt-fedora-build/19/artifact/bin.snapshot/targets/ath79/generic/openwrt-ath79-generic-tplink_archer-c6-v2-us-squashfs-sysupgrade.bin

1 Like

ok, found a build mistake tar tzf vs tar xzf :relieved: check again in 30 minutes for build 22

No idea where to start on testing that - if you have testing steps, let me know. Since it is not a 5GHz issue, can you open a new thread - happy to build the patches.

1 Like

I just installed the build 22 bin.snapshot, but I still have the issue where my iPhone can't connect via 5G.

I remember I could connect via 5G with the 11/11/2020 version. I had no problems with that version except that 5G signal was pretty weak. Unfortunately, I can't find that version anymore :expressionless:

I will have a build of the last commit from 10-Nov-2020 (a47279154e), stand by

1 Like

we need to test with latest board files from stock 1.1.7 firmware

i flashed variant 2 us version. when i try flash non-us firmware from ur build.. it have bricked my router.. whats the differences in your build? now its time to tftp recovery. Is your non-us version for archer c6 v2 (eu).

If someone wants to describe the process of extracting the board files, I will be happy to automate it.

I actually do not know the difference in the build versions beyond what was previously discussed. The build script is found on https://www.pdinc.us/public/ci/job/openwrt-fedora-build/configure in the build section. These builds are automation based on what gmtandi, fgsilveira, and julianocss have done. The user must exercise all due caution! These builds are automated, from master branch, with some variants having unsupported patches.

I installed the latest build and everything seems to be in working order except for 5g radio, my phone and laptop refuses to connect to it.

Snapshot, variant 1, or variant 2?

It has been suggested that there is a regression, you may want to try:

#pci bus errors.

Sat Dec  5 20:28:14 2020 kern.info kernel: [    1.756031] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
Sat Dec  5 20:28:14 2020 kern.info kernel: [    1.764247] pci 0000:00:00.0: [168c:0056] type 00 class 0x028000
Sat Dec  5 20:28:14 2020 kern.info kernel: [    1.770508] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
Sat Dec  5 20:28:14 2020 kern.info kernel: [    1.777650] pci 0000:00:00.0: PME# supported from D0 D3hot
Sat Dec  5 20:28:14 2020 kern.info kernel: [    1.784287] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
Sat Dec  5 20:28:14 2020 kern.info kernel: [    1.791149] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
Sat Dec  5 20:28:14 2020 kern.err kernel: [    1.801367] squashfs: SQUASHFS error: Xattrs in filesystem, these will be ignored
Sat Dec  5 20:28:14 2020 kern.err kernel: [    1.809155] unable to read xattr id index table

Which build and variant?

in variant 2 builds