Flint 2 router configuration and FritzBox as a telephone server

A beginner asks the professionals for help. Unfortunately my English isn't the best either so I use Google.
My question to the professionals...
I have fiber in the house and an ONT on the wall. From there it goes to my FritzBox 7590. The internet connection is entered as a router in the Fritzbox. There are no login details. I only have to enter VLAN 132 in the connection settings. For telephony I have to enter VLAN 232. That all works too.
Now I have bought the Flint 2 router. Internet connection set up as a router with VLAN 132 works. I can't find a configuration for telephony. If I now add the FritzBox as a client, the FritzBox gets internet but telephony doesn't work. Error message: Phones not registered
Unfortunately, my wife insists on the DECT telephones, otherwise I would have simply done without the FritzBox. How can I simply use the FritzBox as a telephone server. The FritzBox doesn't have to do anything more.
Does anyone have a tip for me?

I hope I explained everything well. I have attached pictures. If you have any questions, I'm of course available.

Thank you


![Screenshot 2024-01-09 151544|690x363]

Set up VLAN 232 so it hardware switches through the Flint. That way the Fritzbox can register directly with the ONT and ISP. For the phone VLAN, it will be as if the Fritzbox is still plugged directly into the ONT. OpenWrt won't interact with the phone packets at all.

To set this up on a DSA device (which I assume the Flint is), put the wan port into the same bridge (by default br-lan) as all the other ports then add bridge-vlans inside that bridge. LAN is by convention 1, wan will be 132, and phone 232. Each network uses br-lan.N as its device. Add a dummy network interface of proto Unmanaged (or None) for phone to be sure that the hardware is configured properly.

Wow, such a quick answer. Thank you mk24
I'll try it and if it works I'll report back. First of all, thank you for the quick response and support

Hello great master,

Unfortunately I only got around to configuring it yesterday.
I created 2 vlans. vlan132 for the internet connection and a vlan232 for internet telephony.
Unfortunately the internet doesn't work but telephony doesn't work.
I tried to follow your instructions, unfortunately the internet connection was immediately lost when I tried.
Would you please be so kind as to describe your journey to me in more detail? I've been sitting on the settings for hours and will soon go crazy. It would be very kind of you. Thanks in advance

Let’s see the configuration as it is now:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thank you Sherman for your support.

I've changed the settings so many times now and thought I'd managed it with my last solution. It was 4 a.m. this morning and I was about to wake up my wife. Unfortunately the joy was short-lived. Strangely enough, after about 15 minutes the phone call stopped again. That's why I started again and the attached data is still almost in clock condition.

Thank you again for your support


OpenWrt Data

ubus call system board

{
        "kernel": "5.15.139",
        "hostname": "GL-MT6000",
        "system": "ARMv8 Processor rev 4",
        "model": "GL.iNet GL-MT6000",
        "board_name": "glinet,gl-mt6000",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05-SNAPSHOT",
                "revision": "r23001+719-38c150612c",
                "target": "mediatek/filogic",
                "description": "OpenWrt 23.05-SNAPSHOT r23001+719-38c150612c"
        }
}

------------


/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd51:946b:8bfa::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        option macaddr '94:83:c4:a7:08:a1'
        option igmp_snooping '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config device
        option name 'lan1'
        option macaddr '94:83:c4:a7:08:a1'

config device
        option name 'lan2'
        option macaddr '94:83:c4:a7:08:a1'

config device
        option name 'lan3'
        option macaddr '94:83:c4:a7:08:a1'
        option multicast_router '1'

config device
        option name 'lan4'
        option macaddr '94:83:c4:a7:08:a1'

config device
        option name 'lan5'
        option macaddr '94:83:c4:a7:08:a1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.8.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option isolate '0'

config device
        option name 'eth1'
        option macaddr '94:83:c4:a7:08:9f'

config interface 'wan'
        option device 'eth1.132'
        option proto 'dhcp'
        option ipv6 '0'
        option metric '10'
        option vlanid '132'

config interface 'wan6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@wan'

config interface 'tethering6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@tethering'

config interface 'wwan6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@wwan'

config interface 'guest'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option multicast_querier '1'
        option igmp_snooping '1'
        option isolate '0'
        option bridge_empty '1'
        option disabled '1'

config interface 'wwan'
        option proto 'dhcp'
        option metric '20'

config interface 'secondwan'
        option ipv6 '0'
        option proto 'dhcp'
        option metric '15'
        option force_link '0'

config interface 'secondwan6'
        option proto 'dhcpv6'
        option disabled '1'
        option metric '15'
        option device '@secondwan'

config interface 'modem_1_1_2_6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@modem_1_1_2'

config rule 'policy_direct_rt'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule 'policy_default_rt_vpn'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config rule6 'policy_direct_rt6'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule6 'policy_default_rt_vpn6'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config device
        option name 'eth0'

config device
        option name 'eth1.132'
        option type '8021q'
        option ifname 'eth1'
        option vid '132'
----------------

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel 'auto'
        option band '2g'
        option htmode 'HE40'
        option disabled '0'
        option country 'DE'
        option legacy_rates '0'
        option hwmode '11g'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'GL6000-24'
        option encryption 'psk2'
        option key 'xxxx'
        option wds '1'
        option isolate '0'
        option ifname 'wlan0'
        option hidden '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel 'auto'
        option band '5g'
        option htmode 'HE80'
        option disabled '0'
        option channels '36,40,44,48'
        option country 'DE'
        option legacy_rates '0'
        option hwmode '11a'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'GL6000'
        option encryption 'psk2'
        option key 'xxxxxxxxx'
        option wds '1'
        option isolate '0'
        option ifname 'wlan1'
        option hidden '0'

config wifi-iface 'guest2g'
        option device 'radio0'
        option network 'guest'
        option mode 'ap'
        option ifname 'wlan0-1'
        option encryption 'psk2'
        option key 'xxxxxx'
        option ssid 'GL6000-24-Guest'
        option guest '1'
        option disabled '1'
        option wds '1'
        option isolate '1'
        option hidden '0'

config wifi-iface 'guest5g'
        option device 'radio1'
        option network 'guest'
        option mode 'ap'
        option ifname 'wlan1-1'
        option encryption 'psk2'
        option key 'xxxxxxx'
        option ssid 'GL6000-Guest'
        option guest '1'
        option disabled '1'
        option wds '1'
        option isolate '1'
        option hidden '0'

------------------

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '0'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'disabled'
        option ra 'disabled'
        option ra_slaac '1'
        option force '1'
        option ignore '0'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option name 'console.gl-inet.com'
        option ip '192.168.8.1'

config domain
        option name 'console.gl-inet.com'
        option ip '::ffff:192.168.8.1'

config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'disabled'
        option ra 'disabled'
        option ignore '0'

config dhcp 'secondwan'
        option interface 'secondwan'
        option ignore '1'

config host
        option mac 'D8:5E:D3:0E:B1:D7'
        option ip '192.168.8.138'
        option tag 'BUERO-PC'

config host
        option mac 'xxxx'
        option ip '192.168.8.123'
        option tag 'fritz'

---------------------------

 /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'DROP'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'
        list network 'secondwan'

config forwarding
        option src 'lan'
        option dest 'wan'
        option enabled '1'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include 'nat6'
        option path '/etc/firewall.nat6'
        option reload '1'

config rule 'block_dns'
        option name 'block_dns'
        option src '*'
        option device 'br-*'
        option dest_port '53'
        option target 'REJECT'
        option enabled '0'

config include 'gls2s'
        option type 'script'
        option path '/var/etc/gls2s.include'
        option reload '1'

config include 'glblock'
        option type 'script'
        option path '/usr/bin/gl_block.sh'
        option reload '1'

config zone
        option name 'guest'
        option forward 'REJECT'
        option output 'ACCEPT'
        option input 'REJECT'
        list network 'guest'

config forwarding
        option src 'guest'
        option dest 'wan'
        option enabled '1'

config rule
        option name 'Allow-DHCP'
        option src 'guest'
        option target 'ACCEPT'
        option proto 'udp'
        option dest_port '67-68'

config rule
        option name 'Allow-DNS'
        option src 'guest'
        option target 'ACCEPT'
        option proto 'tcp udp'
        option dest_port '53'

config include 'vpn_server_policy'
        option type 'script'
        option path '/etc/firewall.vpn_server_policy.sh'
        option reload '1'
        option enabled '1'

config rule 'sambasharewan'
        option src 'wan'
        option dest_port '137 138 139 445'
        option dest_proto 'tcpudp'
        option target 'DROP'

config rule 'sambasharelan'
        option src 'lan'
        option dest_port '137 138 139 445'
        option dest_proto 'tcpudp'
        option target 'ACCEPT'

config rule 'glnas_ser'
        option src 'wan'
        option dest_port '6000-6002'
        option dest_proto 'tcp'
        option target 'DROP'

config rule 'webdav_wan'
        option src 'wan'
        option dest_port '6008'
        option dest_proto 'tcp'
        option target 'DROP'

config redirect
        option enabled '1'
        option proto 'tcp udp'
        option src_dport '5060'
        option dest_ip '192.168.8.123'
        option dest_port '5060'
        option src 'wan'
        option name 'GL-sip'
        option dest 'lan'

config rule
        option dest_port '5060'
        option proto 'tcp udp'
        option name 'GL-5060'
        option target 'ACCEPT'
        option src 'wan'
        list dest_ip '192.168.8.123'

--------------- End

At the moment I'm following this guide.
https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like