Ffmpeg-custom package is not compiled in multimedia


When I enable the feature of ffmpeg-custome in multimedia and compile this package, I always get some compiling error:
Makefile:790: recipe for target '/home/zhh/mydev/openwrt-64/bin/targets/malta/le64r6/packages/ffmpeg-custom_3.4.5-1_mips64el_mips64r6.ipk' failed
In fact, I have checked directories and it has not been compiled at all, so the ipk file can't be found.

I have checked targets in the link https://downloads.openwrt.org/releases/18.06.2/packages/. In packages of these all targets, there is no package of ffmpeg-custom. Is this package not compiled now?


See, for example

It is probably that it was failing at the time.

http://downloads.openwrt.org/releases/faillogs/mips64el_mips64/packages/ffmpeg/full/compile.txt and similar may provide clues

Hi Jeff,

The version of ffmpeg in my project is 3.4.5. So it is not the same problem or issue. I have checked the directory "build_dir/target-mips64el_mips64r6_64_musl". There are four directories related to ffmpeg.

The same directory ffmpeg-3.4.5 is the child directory of these four directories. But the code in ffmpeg-custome is not compiled, but code in others are compiled when I enable the feature ffmpeg-custom in multimedia. I want to know the reason and how to get code in ffmpeg-custom to be compiled.



make V=s package/ffmpeg-custom/compile

should give you some better diagnostics

Hi Jeff,
It seems that we can't compile single package of ffmpeg-custom. It should be ffmpeg.

make V=s package/ffmpeg-custom/{clean,prepare,compile} 2>&1 | tee ffmpeg-custom.log
make[1]: Entering directory '/home/zhh/mydev/openwrt-64'
make[1]: *** No rule to make target 'package/ffmpeg-custom/clean'. Stop.
make[1]: Leaving directory '/home/zhh/mydev/openwrt-64'
/home/zhh/mydev/openwrt-64/include/toplevel.mk:216: recipe for target 'package/ffmpeg-custom/clean' failed
make: *** [package/ffmpeg-custom/clean] Error 2


I've only tested this on octeon (mips64) and it compiles just fine using master from a few weeks back using GCC 8.3.0 and Binutils 2.32

It's a sledgehammer approach but it works for me(tm) :slight_smile:

...also, custom might fail because of patented flag if you haven't selected it. This package wont appear unless you have that enabled.

HI Diizzy,

It works now. Thank you very much.