*** Failed to download the package list

Hello, I want to update the list, but I get an error

I looked at all the related topics, but my problem was not solved
my modem model is Tp link TL-WA701ND

Downloading http://downloads.openwrt.org/releases/18.06.9/targets/ar71xx/tiny/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.9/targets/ar71xx/tiny/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/base/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/base/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/luci/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/luci/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/routing/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/routing/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/telephony/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.9/packages/mips_24kc/telephony/Packages.gz```

Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Collected errors:

This version is long since EOL'd and is unsupported. It should not be used on the internet anymore due to numerous security vulnerabilities.

That said, usually this is a connectivity issue. How is this device connected to the network? Is it your main router or a dumb AP or something else?

This kind of gives it away ....

1 Like

That means I can no longer use this

What does AP mean?

All settings and connections are correct, should I use VPN?

if they were, you wouldn't have this error ...

why would you ?

1 Like

It doesn't mean you can't, it means you shouldn't. Think of it like using a 40-year old car seat for a child -- safety standards have changed and that would not be considered safe (might even be illegal), but you could still use it, sure.... you just shouldn't.

"Access Point" -- in other words, used purely to provide wifi, not routing.

Clearly they're not... maybe you can give us some additional information:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Why do you think this would solve the problem?


Because if it wasn't true, I wouldn't be able to talk to you now and I was watching TV!

Well, depending on how this device is being used, that could be expected behavior, but a misconfiguration could still prevent the device itself from being able to access the internet.

Please provide the requested info.

1 Like

How can I open the previous settings of my modem and stop using Openwrt?

I don't understand... how is that related to the requests I've made for information, and how is it related to your original issue?

1 Like

When you say that this way is unsafe and it may not work and I have to suffer a lot for it, it is better not to use it, is this not reasonable?

oh... yes, now I understand.

Well, the TP-Link firmware will be even older and likely have more vulnerabilities. So rolling back to the vendor firmware won't really help you.

What you should be considering is new hardware that can support the latest OpenWrt versions.


Wow, I did a great stupidity, now I have no way back and no way to continue
Those of you who are aware of these issues should inform and remove the model of these devices from the site
Now I am left with an unusable device!!!!!!

What is my assignment?

Legacy software is kept for legacy purposes. But because the device is resource limited, it cannot run the latest versions of OpenWrt. It is, therefore, no longer available on current versions.

That said, it is your responsibility (the user) to keep up with security and feature updates. You cannot blame others for your inactivity or lack of knowledge about the fact that you are using a 7 year old firmware on your device that is 13 years old. That's ancient in computing terms.

No, it is still the same as it was yesterday. Today, you just learned that you shouldn't be using it anymore. It will still function until it either breaks for hardware reasons or is compromised due to the security vulnerabilities. Just like anything else, really.

Go buy a newer device. If you want to run OpenWrt, do research on the models available in your area and price point and reference against the OpenWrt Table of Hardware and/or the firmware selector

1 Like

Your problem looks typical and thus should be possible to solve even using old firmware as long as you cooperate and collect the proper diagnostics including persistent and runtime configs.


If only the OP would respond to the questions...


Is there a way to fix my problem or not?

Yes, your original problem can be solved... if you provide the requested information.

This won't solve the security issues, but it will allow you to update the package lists and install new packages.


I am not a professional like you, you should tell me what things you want me to give them
I don't care about security problems anymore