ExtRoot trouble with 21.02


I have a wndr4700 that I use as a VLAN switch with Samba4 in the rev 19 era.
I upgraded to 21.02 using tftp to load factory image. Then
I loaded the sysupgrade and configured 802.1Q with eth0.1 (lan), eth0.3 (guest), and eth0.4 (iot) and disabled firewall.

Then I used to install the extroot on USB and using a USB3 diver.
Then I rebooted, and it worked fine. I saw my software space around 8GB.

I then attached a 2.5 in drive and loaded mqtt, and samba4
and it still worked fine.

I then took it to its designated location and restarted. And even though it says USB is attached to /overlay, the space in software has reverted back to 9MB (meaning its not mounting correctly)
Also the luci-app-samba as well as mqtt server is missing.

I booted again and it went back to normal with samba and mqtt present and expanded rootfs.

What gives this erratic behavior? And what file should I save to share with the guru here so that a root cause can be applied?

Please let me know.


What gives?

So, I have a SWAO (Scientific wild ass observation)!!
The extroot fails to boot from the USB flash drive when booted cold.
But, if I ssh and issue a reboot command and then it boots properly from the usb flash overlay partition.
Even in the cold boot, the swap partition is identified and mounted correctly.


Checkout option delay_root -> https://openwrt.org/docs/guide-user/additional-software/extroot_configuration#troubleshooting


Thank you so much sir. This looks like what will do the trick. Every day I learn something new and cool!
Thanks again.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

the usb wasn't seated properly and yes the 15 second delay has worked

Thank you so much.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.