Error when attempting to setup a separate subnet on physical port4 under 18.06.1

Under 17.01.5, I was able to have the physical #4 port on my R7800 connect a wired device to my guest network. I updated to 18.06.1 today and am trying to setup it the same way but when I when to Network>Switch and added a VLAN and attempted to configure it identically, I received this warning:

I was reluctant to apply the unchecked option.
@lleachii helped me setup this configured initially in this thread.

Not sure what I'm doing incorrectly under 18.06.1.

Screenshot of default 18.06.1 Network>Switch state:

Screenshot of my attempted configuration that give that error Network>Switch state:

From the configuration in your screenshots, I would expect these effects:

  1. Disconnect the external WAN port.
  2. Change the CPU connection of VLAN 2 to untagged. This has no useful effect because of point 1.
  3. Disconnect the external LAN 1 port from VLAN 1 and connect it to VLAN 3, which I assume is going to be your guest network. This network's Physical interface as seen from the CPU will be eth1.3.

Is that what you want to achieve?

How did you connect to the router for changing its configuration?
You could manage it over WLAN to be independent of the current switch set-up.

@mpa - Thanks for the reply. I used LUCI to setup.

My goal is to have the a single wired device (port #4 only) be part of my "guest" interface that is separated from the "LAN" interface. Most devices (trusted devices) are part of the "LAN" interface whereas guests can use the "guest" interface. Does that make sense?

I noticed that 18.06.1 uses different settings for the "physical interface" than 17.06.5 did which might be part of the confusion on my part.

For example, under 18.06.1, the physical settings are:

WAN = switch vlan eth0.2
WAN6 = switch vlan eth0.2
LAN = switch vlan eth1.1 and wireless network "myssid"
GUEST = wireless network "myguestssid"

Under 17.01.5:

WAN = ethernet switch "eth0"
WAN6 = ethernet switch "eth0"
LAN = switch vlan "eth1.1" and wireless network "myssid"
GUEST= switch vlan "eth1.3" and ethernet adapter "guest" and wireless network "myguestssid

Yes, understood. I just wanted to be sure about the difference between the screenshots and your stated goal. I suggest the following:

  • Temporarily connect over WLAN to manage the device, if possible.
  • Restore the default switch configuration.
  • Create VLAN 3 and set CPU(eth1) to tagged on VLAN 3 like before.
  • On the external port labelled LAN 4, plug/unplug a network cable that is connected to a switch or another computer, different from the one you are working on. Check in the web interface which port status toggles. It should be LAN 4, but in your previous config you used LAN 1. Some devices have the numbering mixed up, that's why the extra check. Set that port to untagged for VLAN 3 (third line), and to off for VLAN 1.
  • Do not change VLAN 2, keep its default configuration.
  • Save & Apply

Further steps are needed elsewhere:

  • Under Network > Interface, create the guest interface and set its physical port to eth1.3.
  • Set up firewall forwardings and rules for guest with your desired policy. The wiki has documentation about this.
  • Set up a wireless SSID which connects to this guest network, if desired.
1 Like

Thank you very much for the reply. You advice worked perfectly. I am now setup as expected.

I am really impressed with out easy the update from 17.01.5 --> 18.06.1 was and how robust everything is. Great job to all the developers and other contributors.

For reference after setting the physical port to eth1.3:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.