Error using sysupgrade in console


I'm not sure this post is for this section, but I don't know exactly where to share.

When I try to use sysupgrade in the console I get the following error:
sysupgrade -b / tmp / backup - $ {HOSTNAME} - $ (date +% F) .tar.gz
sha256sum: invalid option - 's'
Try 'sha256sum --help' for more information.
in the sysupgrade file I found where sha256sum is
Used with parameters -s and -c.
I searched for the parameter -s but did not find it.

The routers I use are x86_64 images
DISTRIB_RELEASE = '19 .07.4 '
DISTRIB_REVISION = 'r11208-ce6496d796'

DISTRIB_RELEASE = '19 .07.7 '
DISTRIB_REVISION = 'r11306-c4a6851c72'

I apologize, if this is not the correct section, please direct me where I should refer the topic.


upgraded packages at any time?

1 Like
opkg remove coreutils-sha256sum
1 Like


by removing the coreutils-sha256sum package everything works.



1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.