Error: no address range available for DHCP request


#1

Hello all,

I am having an issue where I am unable to connect to the wireless on one of my connetions (RGMedia). I have been using this post as a reference:

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&ved=2ahUKEwj3hZ6e3K7fAhUEP60KHdNwDV8QFjACegQIAxAB&url=https%3A%2F%2Fforum.openwrt.org%2Ft%2Fcant-get-dhcp-lease%2F4885&usg=AOvVaw2miteB31oYpeIn2n8I0L8n

However, I believe that my case is not the same. Any ways, here is my configuration and logs for the DHCP

# Change the following lines if you want dnsmasq to serve SRV
# records.
# You may add multiple srv-host lines.
# The fields are <name>,<target>,<port>,<priority>,<weight>

# A SRV record sending LDAP for the example.com domain to
# ldapserver.example.com port 289
#srv-host=_ldap._tcp.example.com,ldapserver.example.com,389

# Two SRV records for LDAP, each with different priorities
#srv-host=_ldap._tcp.example.com,ldapserver.example.com,389,1
#srv-host=_ldap._tcp.example.com,ldapserver.example.com,389,2

# A SRV record indicating that there is no LDAP server for the domain
# example.com
#srv-host=_ldap._tcp.example.com

# The following line shows how to make dnsmasq serve an arbitrary PTR
# record. This is useful for DNS-SD.
# The fields are <name>,<target>
#ptr-record=_http._tcp.dns-sd-services,"New Employee Page._http._tcp.dns-sd-services"

# Change the following lines to enable dnsmasq to serve TXT records.
# These are used for things like SPF and zeroconf.
# The fields are <name>,<text>,<text>...

#Example SPF.
#txt-record=example.com,"v=spf1 a -all"

#Example zeroconf
#txt-record=_http._tcp.example.com,name=value,paper=A4

# Provide an alias for a "local" DNS name. Note that this _only_ works
# for targets which are names from DHCP or /etc/hosts. Give host
# "bert" another name, bertrand
# The fields are <cname>,<target>
#cname=bertand,bert

Logs:


Thu Dec 20 09:53:10 2018 kern.debug kernel: [72460.565567] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:10 2018 kern.debug kernel: [72460.785625] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:11 2018 kern.debug kernel: [72461.205748] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:11 2018 kern.debug kernel: [72461.425796] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:12 2018 kern.debug kernel: [72461.845914] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:12 2018 kern.debug kernel: [72462.065969] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:12 2018 kern.debug kernel: [72462.486087] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:12 2018 kern.debug kernel: [72462.706140] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:13 2018 kern.debug kernel: [72463.126258] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:13 2018 kern.debug kernel: [72463.346316] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:13 2018 kern.debug kernel: [72463.766431] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:14 2018 kern.debug kernel: [72463.976484] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:14 2018 kern.debug kernel: [72464.406607] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:14 2018 kern.debug kernel: [72464.576646] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:15 2018 kern.debug kernel: [72464.996813] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:15 2018 kern.debug kernel: [72465.196929] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:15 2018 kern.debug kernel: [72465.626935] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:16 2018 kern.debug kernel: [72465.806979] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:16 2018 kern.debug kernel: [72466.237101] ieee80211 phy0: change: 0x40
Thu Dec 20 09:53:16 2018 kern.debug kernel: [72466.417182] ieee80211 phy0: change: 0x42
Thu Dec 20 09:53:18 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:31 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 IEEE 802.11: authenticated
Thu Dec 20 09:53:32 2018 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 18:74:2e:44:63:d5
Thu Dec 20 09:53:32 2018 kern.debug kernel: [72481.860280] ieee80211 phy1: staid 1 deleted
Thu Dec 20 09:53:33 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 IEEE 802.11: associated (aid 1)
Thu Dec 20 09:53:33 2018 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 18:74:2e:44:63:d5
Thu Dec 20 09:53:33 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 RADIUS: starting accounting session E9337419449F45AD
Thu Dec 20 09:53:33 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 WPA: pairwise key handshake completed (RSN)
Thu Dec 20 09:53:33 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:38 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:40 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:41 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:44 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:46 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:48 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:48 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 IEEE 802.11: authenticated
Thu Dec 20 09:53:57 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:53:59 2018 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 18:74:2e:44:63:d5
Thu Dec 20 09:53:59 2018 kern.debug kernel: [72508.977220] ieee80211 phy1: staid 1 deleted
Thu Dec 20 09:54:00 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 IEEE 802.11: associated (aid 1)
Thu Dec 20 09:54:01 2018 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 18:74:2e:44:63:d5
Thu Dec 20 09:54:01 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 RADIUS: starting accounting session C71A90D45FB2206E
Thu Dec 20 09:54:01 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 WPA: pairwise key handshake completed (RSN)
Thu Dec 20 09:54:01 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:54:05 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:54:05 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:54:11 2018 daemon.info hostapd: wlan1: STA d4:6e:0e:19:6b:17 IEEE 802.11: associated (aid 3)
Thu Dec 20 09:54:11 2018 daemon.notice hostapd: wlan1: AP-STA-CONNECTED d4:6e:0e:19:6b:17
Thu Dec 20 09:54:11 2018 daemon.info hostapd: wlan1: STA d4:6e:0e:19:6b:17 RADIUS: starting accounting session 26E592142B4C7B85
Thu Dec 20 09:54:11 2018 daemon.info hostapd: wlan1: STA d4:6e:0e:19:6b:17 WPA: pairwise key handshake completed (RSN)
Thu Dec 20 09:54:12 2018 daemon.info hostapd: wlan1: STA 18:74:2e:44:63:d5 IEEE 802.11: authenticated
Thu Dec 20 09:54:12 2018 daemon.info hostapd: wlan1: STA d4:6e:0e:19:6b:17 IEEE 802.11: authenticated
Thu Dec 20 09:54:13 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:54:13 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:54:14 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:54:15 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:54:19 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia
Thu Dec 20 09:54:21 2018 user.info travelmate-1.2.2[1767]: uplink 'eduroam/84:D4:7E:04:D2:33' is out of range (0/35), uplink disconnected (Linksys WRT3200ACM, OpenWrt 18.06.1 r7258-5eb055306f)
Thu Dec 20 09:54:22 2018 kern.debug kernel: [72531.979152] ieee80211 phy0: change: 0x40
Thu Dec 20 09:54:22 2018 kern.debug kernel: [72532.157185] ieee80211 phy0: change: 0x40
Thu Dec 20 09:54:22 2018 daemon.warn dnsmasq-dhcp[3387]: no address range available for DHCP request via br-RGMedia

When I run ifconfig:

br-RGMedia Link encap:Ethernet  HWaddr 60:38:E0:C1:64:91
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6238:e0ff:fec1:6491/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26720 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3658 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4598250 (4.3 MiB)  TX bytes:1566485 (1.4 MiB)

Any thoughts on the matter would be greatly appreciated. Thank you


#2

Also, here is my /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option local '/local.resonancegroupusa.com/'
        option domain 'local.resonancegroupusa.com'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        list dhcp_option '6,10.0.0.15'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'RGMedia'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'RGMedia'

config domain
        option name 'dc1.local.resonancegroupusa.com'
        option ip '10.0.0.15'

config domain
        option name 'rg-nas.local.resonancegroupusa.com'
        option ip '10.0.0.10'

config domain
        option name 'local.resonancegroupusa.com'
        option ip '10.0.0.15'

config domain
        option name 'wiki.local.resonancegroupusa.com'
        option ip '10.0.0.16'

config domain
        option name 'KM86A12A.local.resonancegroupusa.com'
        option ip '10.0.0.21'

Here is my /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option disassoc_low_ack '0'
        option max_inactivity '1000'
        option channel '36'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'US'
        option legacy_rates '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option channel 'auto'
        option country 'US'
        option legacy_rates '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'RGMedia'
        option network 'RGMedia'
        option encryption 'psk2'
        option key 'password1'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option country 'US'
        option legacy_rates '1'
        option channel 'auto'
        option hwmode '11g'
        option htmode 'HT20'

config wifi-iface
        option ssid 'eduroam'
        option device 'radio0'
        option mode 'sta'
        option bssid '84:D4:7E:04:D2:33'
        option encryption 'wpa2+tkip+ccmp'
        option eap_type 'peap'
        option auth 'EAP-MSCHAPV2'
        option identity 'username'
        option password 'password2'
        option macaddr '9C:EF:D5:D8:42:0A'
        option network 'eduroam trm_wwan RGMedia'

config wifi-iface
        option device 'radio2'
        option mode 'ap'
        option encryption 'psk2'
        option ssid 'RGWireless'
        option network 'lan'
        option key 'password3'

config wifi-iface
        option network 'trm_wwan'
        option device 'radio0'
        option mode 'sta'
        option ssid 'eduroam'
        option encryption 'wpa2'
        option eap_type 'peap'
        option auth 'EAP-MSCHAPV2'
        option identity 'username'
        option password 'password5'
        option disabled '1'


And here is my /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb4:8f56:eee3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ip6assign '60'
        option ipaddr '10.0.0.1'
        option netmask '255.0.0.0'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'eduroam'
        option proto 'dhcp'

config interface 'RGMedia'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'trm_wwan'
        option proto 'dhcp'
        option type 'bridge'

Note: Usernames and passwords have been replaced with something generic


#3

Hello all,

here is another data point. When I reset the radio on RGMedia, the DHCP server is able to function properly and I now have internet connectivity.


#4

I am still having this issue. Would someone be able to provide some feedback?


#5

I see quite a bit of issues with your config.

I think it's because you have the Interface RGMedia on 2 APs:

But...since your DHCP now works...you haven't actually explained YOUR problem.


#6

TBH, I am not sure if the issues are related but my AP drops out every 8 hours or so. When this happens, I also see this error. So, I strongly believe that the issues are related.

Also, every once n a while, devices have a hard time connecting to RGMedia.


#7

What issues do you see with the configuration of the interfaces?


#8
config interface 'RGMedia'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

Don't see any ifname attached.


#9

@leeandy

Hello, thank you for your feedback. From the GUI, how would I add an ifname?


#10

Choose edit on RGMedia interface, physical settings - interface


#11

@leeandy

So I associated the interface and then it killed my whole network


#12

Can you explain what do you want to do?
Do you want to have LAN and RGMedia bridged or separated?
You have enabled the bridge on both, but you are using different IP addresses and both run dhcp server.


#13

What interface you attached ?
See your wireless config above, have 3 radio, RGMedia is assign on radio1 (wlan1 ?). You need attach RGMedia to wlan1.


#14

Please confirm this is not a cross post of your Master AP issue here:

You have already been told and shown multiple threads - that your master AP will drop if the client association drops. You were also offered the Travelmate package as a possible solution to your issue.


#15

@lleachii

Yes, TravelMate was a possible solution. Which I installed and setup and I was still getting the same result