ERROR MESSAGE lua/luci/dispatcher.lua:426:

I am getting error below, router still working, not made any changes.

/usr/lib/lua/luci/dispatcher.lua:426: /etc/config/luci seems to be corrupt, unable to find section 'main'

Will it die completely if I reboot?

Any idea why?

I tried this

rm /overlay/upper/etc/config/luci

But wary of rebooting as want to know what caused this

Will what die?

Well, then we might have to wait...

(Might I suggesting just re-flashing the same version over via sysupgrade before rebooting then?)

1 Like

That would scare me more than rebooting.

I took the plunge and powered off device,

Restarted and Luci is back again.

Hopefully not been hacked!

Flashing would likely assure that this wasn't the case...also, if one does not edit their WAN firewall rules, the router should be pretty safe from outside attacks on current versions.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

It is marked solved but I would like to know what causes the problem.

Searching the forum for "unable to find section 'main'" yields >30 findings. However, I haven't found a clear answer what the real rootcause is.
The issue seems to be connected to rpcd, and oftentimes a simple reboot is enough to solve it.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.