EAP245 V3 bricked

Hello guys! I tried the last snapshot on my EAP245 V3, but the firmware is bugged with slow 5GHz speeds, so I tried to revert to original firmware from Tplink using uploading via Luci GUI with -f option.

Now my EAP245 are bricked but I get the green light, but I can't get acess. I don't have a computer for now, only my S9+ with a hub and using a RJ45 cable.

Any ideas on how to reverse this without using a serial port? Thanks in advance! :wink:

Is this a trick question?

Your device page says no:

...and TFTP information (if any) is missing.

So to be clear, this means you only have a mobile device...with wired Ethernet?

Actually, I assume it's because you think it's difficult or because you don't have a serial cable; but be advised, the serial port is semi-disabled from the factory anyway:

I would advice booting the device while holding the reset button and running software such as Wireshark. This is to see if the device is making some kind of TFTP request.

1 Like


I don't have a serial cable

Many thanks! I'll try to get a laptop to try this. :wink:

1 Like

If you flashed TP-Link's firmware image as is, you've got a soft-brick now. Their firmware image uses a custom format, and cannot be written directly to flash (which is what sysupgrade does). You would need to build tplink-safeloader from the OpenWrt sources to convert a TP-Link firmware file into a valid OpenWrt firmware file.

I'm not entirely sure anymore, but I think this device will launch a failsafe web server at the default address ( if it fails to boot. This failsafe page should accept TP-Link images.


Ok. Tried with TFTP but no luck. I don't get any signal from EAP.

Wireshark only gives me a 169.XXX.XXX.XXX IP from EAP. I think the way will be to contact TP-Link and explain the situation.

I contacted Tp Link support, but it doesn't help at all. So, what serial cable you guys recommend? I think this is the only option now.

https://www.amazon.com/gp/product/B07WX2DSVB/ worked well for me.

1 Like

Thanks! I'll see if a get this on Aliexpress on here in Brazil.

Good news, my friends! Finally I was able to send the original Tplink firmware via tftp by configuring the network card with IP

Now I waiting to the led change from light green to dark green. For now, no wireless network from EAP.

EDIT: ok, ping for works and now I get the page for send the firmware via browser on

EDIT2: ok, send two times the firmware via failsafe web server but for some reason the device doesn't reboot and still in failsafe mode, even with "firmware upgrade success".

I'll try again with tftp method.

EDIT3: well, the problem persist with the tftp method. Any advices?

Did you use the correct regional firmware version ?

Of course :wink:

Also, I can't flash the openwrt factory using the tplink failsafe page.


mean identical symptoms:


It seems likely the failsafe page also does signature verification on the firmware image. The OpenWrt factory image doesn't actually have a valid signature, so this would always fail.

When accessing the Tp Link recovery page to flash the factory firmware, after flash nothing happens. Upon restart, the device remains in recovery mode. Still giving me a 169.xx IP.

I tried telnet to to disable this, but I can't get into device.

Telnet isn't normally available on this device, unless you find a way to start it as root (I haven't)

If the IP address of your computer/smartphone is 169.254.x.y address, then this is a link-local address, and is assigned by the operating system itself because there is no DHCP server available. Like you noted earlier, you need to assign yourself another address in the subnet to be able to access the failsafe page.

That being said, it is still odd that even the failsafe page fails to restore the device to a working state. :confused:

The device is an access point with no DHCP server normally. It would not normally be the case that you could connect a laptop and get a dhcp response. After reflashing factory firmware, @bkdwt should follow instructions from factory installation manual to configure the device... Which I think means connecting via wireless! Or at a minimum, setting a static IP and connecting on an appropriate default IP network.

Wireless is still unavailable, so that means the device is still in recovery mode. When it was working, I got access to it through IP

To get access you will need to static assign your laptop to something like the EAP running tp-link firmware won't provide an ip via DHCP.

This doesn't work. I already tried.

The problem is that the device remains inoperative.

1 Like