EA6700 No bin file, only trx -- how to install?

The router in question is Linksys EA6700, which is hardware-wise identical to EA6500v2. I want to flash EA6500v2 firmware to EA6700 router.
Firmware for EA6500v2 is available here, but is a squashfs.trx file. I understand that squashfs.trx file is meant for flashing from within OpenWrt as stated here. There is no other image format available.

In this case how to flash OpenWrt for the first time in this router. Should I convert squashfs.trx to squashfs.bin file and then flash using tftp? Any ideas?

At least one person has reported success with installing EA6500v2 OpenWrt image on this router, but perhaps not available to tell how.

Reading other questions related to this router, I found that OpenWrt is strongly discouraged and comes with limited support for this router, however I would still want to try it out.


On the device page https://openwrt.org/toh/hwdata/linksys/linksys_ea6500_v2 there are two links on trx files, so try to use them.

The two links to the trx files are snapshot and previous stable builds, but there are no instructions on how to flash the image. I had found the firmware and have linked it in the question as well.

The device page for EA6500v2 lists installation method as unknown. The question is how to flash squashfs.trx files to the router?

In description there is explanation, that .bin file is 'title+.trx file' So if you have only .trx file, you can not produce .bin file. Try to change extension, and flash it via stock web-interface.

Ok. If title is not available elsewhere, the .bin option is out.

I tried flashing the .trx directly, iirc, from dd-wrt, it failed. I managed to recover the router though. It thankfully stores 2 copies of firmware, flash updates one and if it fails you can revert to the second/backup one. I will also try flashing from stock-firmware and see how it goes.

I haven't tried flashing through tftp though. You think it could work. Is different image required for UI & tftp flashing?

How have you tried from dd-wrt?

In dd-wrt:
Administration > Firmware Upgrade > Please select a file to upgrade (Browse)
After flashing, reset to > Default Settings

then click "Upgrade". I had flashed the latest 21.02.0-rc1 from here

Sorry, I do not understand, successfully?

No, not successfully. It failed.

OK, try to perform 'mtd write' to special partition, in case dd-wrt it is:
write {firmware} linux &

I will try this, probably this long weekend.

it worked! yay!
However, in the 'Wireless' page, I see no radio, so I can't setup wi-fi, only wired LAN is working for now


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.