Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

Is it worth testing over 23.05.0-rc2 or is the new fw incompatible?
23.05.0-rc2 is running
There are two known flaws:

  • Hangs every once in a while with:

    qcom-q6v5-wcss-pil cd00000.q6v5_wcss: fatal error received:
    Image Variant : IMAGE_VARIANT_STRING=8074.wlanfw.eval_v2Q
    wal_peer_control.c:2870 Assertion is_graceful_to_handle failedparam0 :zero, param1 :zero, param2 :zero.
    Thread ID      : 0x00000069  Thread name    : WLAN RT0  Process ID     : 0
    SP : 0x4bfb9230
    FP : 0x4bfb9238
    PC : 0x4b1080c4
    SSR : 0x00000008
    BADVA : 0x00020000
    LR : 0x4b107860
    Stack Dump
    from : 0x4bfb9230
    to   : 0x4bfb9aa8
    remoteproc remoteproc0: crash detected in cd00000.q6v5_wcss: type fatal error
    remoteproc remoteproc0: handling crash #1 in cd00000.q6v5_wcss
    remoteproc remoteproc0: recovering cd00000.q6v5_wcss
    remoteproc remoteproc0: stopped remote processor cd00000.q6v5_wcss

    At this point, WiFi is completely wedged and a reboot is needed (wifi restart fails, removing the ath11k module hangs).
    (I have a service that listens to logd and issues a reboot whenever this situation occurs, ask me for it).

  • Sending a WoL (Wake-on-LAN) packet hangs the device for a couple of minutes (ether-wake <mac-address> issued from a Linux box connected to the device) but it eventually recovers. The radio over which the WoL was sent seems stuck.

I think so, from their text descriptions, it looks like the last is the release and the others were engineering drops.
Only testing it will tell if it works well.

Here I had no crashes with the previous, neither with the latest
No issues so far, but I didn't had any before.

I'll try WoL from wifi to LAN, WoL works well here.

Which files or directories do I need to replace to enjoy

Wifi FW is inside /lib/firmware/IPQ8074, but take care, if you mess the wrong files or if the changed files makes the router restart into a boot loop, crash or lose eth connection, you'll need serial access to recover.
If you prefer wait until the devs. decide if it's worth releasing.

Anything you change/ replace in the filesystem (such as under /lib/firmware/) can be fixed by a factory reset (in other words, invoking firstboot or keeping the reset button pressed for >5s on the fully booted device), none of that will brick the device (serial access should not be required).


How does it recover the previous files if they aren't there anymore?

The original files are inside the read-only squashfs, replacing them at runtime will only modify the overlay (which gets removed during the reset) - the overlay only shadows them.


Has anyone already replaced the files from the new version?

Yes, it's working well here, it's in my previous post.

The advise is generic, I had situations in the past where replacing files made a fatal error and somehow disabled eth, so I always rename the original files or folder, so I can use serial console and rename them back if things go wrong.

1 Like

This router can easily be recovered if you have used hnymans instructions to set the bootcmd:

In that case just plug in the USB stick with the initramfs, my notes how I do that:

  1. Power down
  2. Insert USB stick with the fat/fat32 partition with the initramfs on it
    IMPORTANT: older initramfs was named:
    Newer builds can be found in the qualcommax directory and are renamed to:
    Make sure to rename the qualcommax initramfs file otherwise it will not be found by the old bootcmd.
  3. Power Up and wait about two minutes
  4. After the initramfs is loaded the router has an IP address of
  5. There is no LuCi, SSH into the router. The default OpenWRT log in name is root and there is no password
  6. In the next step you really need the factory image for ubi format, so the file with the .ubi extension from:
    Newer builds are in the qualcommax directory:
  7. Copy the factory image to /tmp so the commands are then for the old generic builds:
  8. ubiformat /dev/mtd18 -y -f /tmp/openwrt-ipq807x-generic-dynalink_dl-wrx36-squashfs-factory.ubi
  9. ubiformat /dev/mtd20 -y -f /tmp/openwrt-ipq807x-generic-dynalink_dl-wrx36-squashfs-factory.ubi
    For new qualcommax builds:
  10. ubiformat /dev/mtd18 -y -f /tmp/openwrt-qualcommax-ipq807x-dynalink_dl-wrx36-squashfs-factory.ubi
  11. ubiformat /dev/mtd20 -y -f /tmp/openwrt-qualcommax-ipq807x-dynalink_dl-wrx36-squashfs-factory.ubi

If it crashes during a test I'm doing, I also want to see what went wrong.
I have put an outside of the box serial connector in some of my routers for this.


Hi all, does the current OpenWRT snapshot firmware for the WRX36 support 802.11s mesh?

hello, im looking for the settings for irqbalance to our wrx 36, can you guide me?

There's a script posted a bit up in the thread, AFAIK the official irqbalance still doesn't work.

thanks, I just need to put the script on the start up, right? no need to install and enable irqbalance?

Depends on how you'd like it to run, there's a service you can enable, if you'd like.

what service?

You can run it as a service instead.

i tried to put the script but after that the internet goes down

It only goes up if i remove the script