Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

there's no link to it, no, it's still documented though.
if you would like to know why it's not there, fell free to scroll back a cpl 100 posts.

1 Like

Since its been a month I tried it again with the latest build and can confirm 80Mhz works and 160Mhz doesn't when in STA mode. Connection was rock solid and I saw a stable 1.2 Gbps running iperf on the wrx36 in the rt-ax86u -> wrx36 direction with two intervening walls and around 10m between the two. Impressive. Other direction was ~800Mbps, not too shabby.

Early days for ath11k support and this router but wifi appear to be improving. Even some informal tests around the house with an iphone are looking qualitatively better with the latest build.

Do i'm special or 160MHz channells dosen't work as it should ? Better works on 80MHz than 160.

Works fine here using 23.05.0-rc1, with the devices in dumb AP mode.
Region: US
Channel witdh: 160 MHz
Channel: 100, 36. (there does not seem to be any other channels where 160 MHz works for the US region, even though Wikipedia says 149 could work in the US).

I can get raw 1.3 Gbps switching speed (measured at the interface traffic with no routing involved, it's a configured as a dumb AP) between the 160 GHz channel and the 2.5 Gbit interface in the download direction (AP->STA). That translates to ~ 1.1 Gbps sustained TCP stream as reported by iperf.
Upload speed (STA->AP) is much lower, at ~800 Gbps raw.

Config for 5 GHz on channel 36:
(you'll have to adjust at least network, ifname, ssid and key parameters)

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option country 'US'
	option cell_density '0'
	option band '5g'
	option he_bss_color '33'
	option channel '36'
	option htmode 'HE160'
	option disabled '0'

config wifi-iface 'wifinet0'
	option ifname 'wl_wlan_5'
	option network 'br_vlan_12'
	option device 'radio0'
	option mode 'ap'
	option ssid 'XXXXX'
	option encryption 'psk2+ccmp'
	option key 'YYYYYYY'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option max_inactivity '900'
	option disabled '0'

Just to say thank you.
@Robimarko, @hnyman, @luaraneda and @borgqueenx for the last mile instructions.
Thank you very much letting everybody convert a less than desirable firmware in a much more than decent router.


How are folks finding wifi performance?

With my MacbookPro16 (2021) as the only wifi client, openwrt shows a 1200Mbps connection, iperf3 reports ~800Mbps from the Dynalink to MBP and ~300Mbps from MBP to Dynalink. In practice however copying a large file from the MBP via wifi to a server on the local network the speed averages ~100Mbps.. I updated to 23.05.0-rc2 yesterday and found the same results. For now I have returned to my previous router, which is old tech but gives consistent ~400Mbps transfers both directions.

1 Like

I've noticed the same on a 2021 MBP16 with AX3600 and AX9000, close to the router upload and download are fine (can't remember the numbers but iperf maybe 500 Mbps+ in each direction to a wired PC). Go to the next room and download decreases a little as to be expected on 5G (3-400 Mbps), but upload struggles to get beyond 10 Mbps. With the AX9000 on stock firmware at the same location, upload is similar to download. Tried setting the router to AC instead of AX but it's the same awful upload speed.

Galaxy S8 at the same location in the next room shows upload > 100 Mbps so it seems to be some combination of (at least) M1 Macbooks and the open source ip807x driver as that's 3 different devices it looks to be happening on, all ipq807x based.


Are any of you getting errors when using Attended Sysupgrade to download the latest Snapshot? I am on qualcommax target.


Didn't got errors, but I stopped receiving updates with Attended Sysupgrade 1 or 2 days ago.

In firmware-selector.openwrt.org if we add a package and build it gives an error:

So looks like some kind of temporary error in the build server.

EDIT 2023/07/08: It's fixed now.

1 Like

I have the same error message. Multiple people reported the same issue.

@aparcar :point_up: please... and thanks in advance!

UPDATE: 15:38 (UTC) FIXED! thanks!!!

@robimarko any chance you'd maybe be able to submit that patch upstream in the near future? Been using it since one month ago and it's rock solid.

Yeah, its probably time for it

1 Like

Sounds similar to 802.11ax worse than 802.11ac with mt76 driver?

Have you tried 160MHz just for fun? Seemed to be a band aid for MT76 devices.

I just posted this.

Anyone have any recent luck installing on a new DL-WRX36? I used the factory image here and it looks like it bricked my router. (The [dynalink_dl-wrx36-squashfs-factory.ubi](https://downloads.openwrt.org/snapshots/targets/ipq807x/generic/openwrt-ipq807x-generic-dynalink_dl-wrx36-squashfs-factory.ubi file).

Wondering if I used the wrong factory image?

Solidy red/magenta LED. LED on Ethernet stayed solid. Machine plugged into ethernet does not receive an IP address. I have a serial cable coming from Amazon, but at this point it's moot if there's no solution, I'll simply return for a refund.

Likely you just missed an essential step. From your own thread:

The solution is likely just entering the u-boot cconsole via serial, and issuing that missing command to modify the u-boot variable. Note that fw_setenv is for Linux ssh console, and for u-boot you need setenv (and possibly saveenv).

1 Like

That sounds like it's it! Thank you. I made the mistake with formatting USB exFAT and wondering why ubiformat continued to fail (was booting from device vs USB), once I finally formatted a 1gb partition to FAT, looks like I rushed through the thread. Thanks again.

Is there any situation where your usb boot tweak should not be the primary method for new users flashing the firmware?

Not really. But it adds complexity to the installation process, so keeping the official first advice rather simple may be wise.

Additional complexity comes from the rename of ipq807x/generic to qualcommax/ipq807x in master (but not in 23.05), so the filenames in the boot command may be confusing. (I started discussion about that in Wiki and ipq807x rename to qualcommax )

1 Like

Wifi FW version is out of the testing folder:

Release notes:

 IPQ8074 hw2.0: add WLAN.HK.

 Bug fixes, stability improvements from previous releases
  are present. There are no backward comatibility issues
  with this release.