Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

Anyone have experience running using a thumb drive to increase drive space on this router? I was thinking of running Home Assistant and other packages.

I remember someone up thread said this cable is read-only. Cannot send keystrokes to the router.

1 Like

Yup that's odd because I read several debricking success stories about this product.

It won't last last long because it's not designed for 24X7 operation. I use a cheap 250GB SATA II HDD from an old pc and a usb 2.0 to SATA adaptor. I get 30mb/s speeds which I think is the max in real life for usb 2.0. Total cost 10 euros.

The port leds aren't exposed in this way, the only one in LED configuration is the one on the front of the unit, which isn't the one I'm asking about.

1 Like

Now that you mention it, I agree that the port was probably designed for occasional use.

They just look similar - not sure if the chips are the same or not in the USB cable.

I believe Spyros meant a thumb drive is not meant for 24x7 use, not the USB port.

A hard disk drive connected to the DL-WRX36 USB3 port 24x7 if properly configured should not be an issue, though I find a dedicated 2 bay NAS to be a better storage server solution.

It looks like its the same chip, anyway i'l get another one. The problem is that there are no pins on the board.

Yes, thumb drive is what i meant.

you don't really need the pins, if you've got enough extra hands, but they definitely help.
unless you're looking into some kind of permanent setup.

1 Like

I have a USB stick that has been running for over 1.5 years. First on my FritzBox 4040 and now on the WRX36 as extroot.

This post was flagged by the community and is temporarily hidden.

this is not a device specific question, create a new thread, or even better, search the forum for docker.

1 Like

Add the drive and configure as EXTROOT

The important thing is to understand the pinout for this adapter. The pinout for WRX36 is documented on the Wiki at


Just make sure that the Tx pin on the device, goes to Rx your USB TTL, and the other way around for the Rx pin. Gnd connects to Gnd.
That should be all.

1 Like

FYI the usb worked, just tested it and debranded a Zyxel VMG8623-T50B.

i think its identical with the one from amazon

Keystrokes were working, only set baud rate to 115200

1 Like

This post was flagged by the community and is temporarily hidden.

Still not device specific, create a new thread.

I've put this in my /etc/rc.local :

# fix sysupgrade
grep -q "service wpad stop 2>/dev/null; sleep" "/lib/upgrade/stage2" || sed -i "\~^killall -9 telnetd~i service wpad stop 2>/dev/null; sleep 6\n" "/lib/upgrade/stage2"

Is there an offical fix on the way so it gets changed in master/snapshot accordingly?