DuckDNS OpenWrt on WireGuard

Hi friends, I registered a DNS on, once I configured my wireguard network with the LUCI interface I can't enter my DNS duckdns.

If I try to insert my duckdns into the client at the endpoint item, the network becomes congested and I am forced to remove it.

How can I make sure I don't have to change my IP every 2-3 days?

I tried following the steps to configure openwrt from SSH:

edit the config at /etc/config/ddns

config service "duckdns"
        option enabled          "1"
        option domain           ""
        option username         "exampledomain"
        option password         "a7c4d0ad-114e-40ef-ba1d-d217904a50f2"
        option ip_source        "network"
        option ip_network       "wan"
        option force_interval   "72"
        option force_unit       "hours"
        option check_interval   "10"
        option check_unit       "minutes"
        #option ip_source       "interface"
        #option ip_interface    "eth0.1"
        #option ip_source       "web"
        #option ip_url          ""
        option update_url       "[USERNAME]&token=[PASSWORD]&ip=[IP]"
        #option use_https       "1"
        #option cacert          "/etc/ssl/certs/cacert.pem"

I saved the configuration after editing the DDNS script with VIM but I didn't get any results.

I ask you, how can I make my DUCKDNS work by using the wireguard network?

Are you trying to use DuckDNS to detect your dynamic wan address so that you may connect to your own Wireguard server from outside (that's the normal case) or for some reason you want the update to DuckDNS to be sent over wireguard? I'm not sure I understand what your use case is.

Also, to update DuckDNS or any other similar service you may use ddns-scripts

Be sure to toggle a manual update after that, for example by restarting the wan interface with "ifup wan".

Normal I guess. It is the first thing to think about even if you do not explicitly explain what you need.

True but it's written in such a way that I had to ask: "work by using the wireguard network"

I get it. Here is my DDNS configuration with the DuckDNS service:

config service 'DuckDNS'
	option enabled '1'
	option lookup_host ''
	option use_ipv6 '0'
	option service_name ''
	option domain 'domain'
	option username 'domain'
	option password 'password'
	option use_https '1'
	option cacert '/etc/ssl/certs/ca-bundle.pem'
	option ip_source 'network'
	option ip_network 'wan'
	option interface 'wan'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'

To clarify, I use Snapshots.

So, I'm trying to insert in the GUI WIREGUARD interface on Win7 x64 the DNS name that I created on duckdns so that the encryption doesn't stop when the ip changes.

I am attaching the screenshot of configuring the DNS script on my gl-inet router AR750S.

in the wireguard interface the ip address "endpoint" every three days changes numbering causing congestion of the network. To avoid all this I create a DNs on duckdns but unfortunately this is not accepted because in the interface it is possible to insert only numbers and not letters.

You definitely can add letters to the endpoint because that's how I have my windows wireguard client set up. You should just be able to click edit and type in whatever you want as the endpoint. If it doesn't work then I'd try downloading the client again to make sure you have the most up to date version.

You're wrong. Yes you can enter text since the editor is a simple text editor (I think so). Then when connecting to the server, the general panel shows the IP instead of the DuckDNS domain.

Yes I entered the dns in letters but it does not work, after 3 or 7 days it goes into congestion and cannot take the IP that changes. The interface I use is the latest 0.1.0 x64

If the IP of the endpoint changes then I'm pretty sure you have to restart the tunnel. It won't automatically transfer over to the new IP, even if you are using a domain name as the endpoint.

Does this mean that I will ALWAYS have to manually update the changing IP address? I saw from the duckdns website that the IP address does not change automatically, at this point what am I doing wrong because this IP is not transmitted to the DNS?

What version of OpenWrt are you using? Because in Snapshots, ddns immediately sends DuckDNS the new IP when it changes.

I am attaching the version of my OpenWRT Firmware. Is the snapshot the most stable distro?

In OpenWrt you run the watchdog to update a dynamic endpoint. This is usually done in cron.

I reset the firmware of my Ar750s device and installed the firmware suggested by you "snapshots:" openwrt-ar750s-3.104-0324.tar13830KLast modified: Tue Mar 24 2020 06:41:01 "

The result is the same, nothing changes, once the DNS name is entered in the wireguard client, it cannot connect.

I really don't understand why this wireguard network has all these problems.

Help me understand, what could I do to make sure that there is a DNS domain that automatically updates the changing IP address?

For example, I'm trying to test if the "" script is running.

from the pictures someone can tell me why the script does not start? I believe that the DDNS script does not transmit the update of the IP address and this is the reason for the congestion.