DSL is UP but no internet


I just installed Openwrt 19.07.2 on my Experia Box. I was running LEDE in the past, but this time i can't get it working. My DSL line is up and can find the dns server, see picture

But my vdsl interface don't get the data packets

This are my firewall zones settings

My IPTV is working :slight_smile: But I can't get my internet working... I hope you guys can help me out....

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd54:2f50:231a::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ifname 'eth0.34'

config interface 'iptv'
	option type 'bridge'
	option ifname 'dsl0.4 eth0.4'
	option proto 'dhcp'
	option hostname 'Iptv'

config interface 'vdsl'
	option proto 'dhcp'
	option service 'Telfort'
	option mtu '1480'
	option macaddr '88:03:55:4a:98:0e'
	option ifname 'dsl0.34'

config atm-bridge 'atm'
	option unit '0'
	option atmdev '0'
	option vpi '0'
	option vci '34'
	option encaps 'llc'
	option payload 'bridged'

config dsl 'dsl'
	option tone 'bv'
	option line_mode 'vdsl'
	option xfer_mode 'ptm'
	option firmware '/lib/firmware/vdsl.bin'
	option annex 'b'
	option ds_snr_offset '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 4 2 1'
	option vid '34'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '6t 0'

The interface is no longer called ptm*, but rather dsl* - so dsl0.34.

1 Like

Thanks im connected to my isp now, but internet still isnt working. Iptv works :slight_smile:

I edited my OP

1 Like

C:\Users\Administrator>ping www.google.nl

Pinging www.google.nl [] with 32 bytes of data:
Reply from bytes=32 time=54ms TTL=54
Reply from bytes=32 time=39ms TTL=54
Reply from bytes=32 time=40ms TTL=54
Reply from bytes=32 time=41ms TTL=54

So it's something with the firewall settings?

Forward from LAN to VDSL. There is no need to forward from VDSL to LAN. Masquerading must be active on the VDSL zone (the destination of the forward). I'm not sure how LuCI represents that.

It's working now thanks :slight_smile:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.