Downgrade instructions on Xiaomi AX3000t page don't work anymore

Hi, since this router is all in chinese I thought I'd give OpenWRT a try. I followed the instructions but when I try to downgrade the firmware the web interface complains saying the firmware may be corrupted. I change the URL like the instructions tell me to and it still fails. I wonder if they patched it so we can't downgrade anymore?
I searched the web to see if I could find another way to downgrade it but couldn't find any.
If someone knows a way to downgrade it or just use the current firmware and install OpenWRT normally please let me know!
If there really is nothing I can do, maybe the instruction page needs an update?

1 Like

Whitch official version does it have?

the most up to date firmware, 1.0.64

You should try using tftp to downgrade.

How can I do that?

I tried following the instructions at that page and nothing happens.

Disabled the fw on the TFTPd host ?

use MIWIRepairTool (download from xiaomi)
choose file and will work
Try in 2 routers and 1 was almost dead always restart

1 Like

it doesn't work, I already tried that.

I have the same problem, firmware 1.0.64

Try this tutorial, I downgraded to 1.0.47. LAN port worked, next to the power.

1 Like

Thanks, I'll give it a try. Did you manage to install OpenWRT with no issues?

I managed to downgrade the stock firmware and install OpenWRT successfully, but even though I set both wifi radios to AX I can't reach the Wifi6 speeds, it seems to be capped at 230mbps. What could be wrong?