Does not connect to Wwan0 device

The wwan0 device is connected to the br-wan interface.
When I do a ping test in OpenWrt, I get a response.
I can use the Internet by connecting it to another laptop using a LAN cable.
I cannot use the Internet only when connected to Wi-Fi.

The challenge I need to solve is to spread the Internet connected to my current modem via Wi-Fi. That's what I have to do.

Then it is disable or it is, somehow, associated with lan and it is conflicting with the lan radio..
Regardless, OpenWrt does not see it.

Run:
cat /etc/config/wireless
and
cat /etc/config/network

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:14.3'
        option channel '6'
        option band '2g'
        option htmode 'HT20'
        option country 'KR'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wan lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'tspdi@205'
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd54:35ec:f3ba::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wwan0'
        option proto 'dhcp'
        option netmask '255.255.255.0'
        option type 'bridge'
        option dns '8.8.8.8'

What is this and why?

Did you try to set this whole thing up in LuCI?

And for the second time:
Your cellular radio is outside the laptop and on a USB port?

Before that, I tried only WAN and only LAN. I still couldn't use the internet. I added both because I wanted one of them to be connected.

Change it to:

option network 'lan'

and reboot and run the cat calls again.

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:14.3'
        option channel '6'
        option band '2g'
        option htmode 'HT20'
        option country 'KR'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'tspdi@205'
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd54:35ec:f3ba::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wwan0'
        option proto 'dhcp'
        option netmask '255.255.255.0'
        option type 'bridge'
        option dns '8.8.8.8'

What is going on with your config files?

First we saw this:

Now it is this:

And this ^^ is not working at all.

And yet you kept the wrong config??

Put it back to static, reboot and paste the cat calls again.

Ok, I've read this for a third time.

I will not ask again, so you must explain:
Your cellular radio is a USB device that is plugged into USB port?
If not a USB device, what its it and how is it attached?

At this point I need to see the device.
I need you to type everything you know about it and how you managed to configure it.
There is too much grey area and I have made the mistake of not insisting you answer my questions up-thread.

Nothing changed whether I changed it to static or dhcp. Nothing has changed from the beginning to now. The condition is still the same.

I can still use the internet via modem. What I can't do is use the Internet on a device connected to Wi-Fi.

Failed to verify question. sorry.
This modem is still unfinished. It is connected to the laptop body with a cable, not USB. The name of the device is wwan0.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd54:35ec:f3ba::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wwan0'
        option proto 'dhcp'
        option netmask '255.255.255.0'
        option type 'bridge'
        option dns '8.8.8.8'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:14.3'
        option channel '6'
        option band '2g'
        option htmode 'HT20'
        option country 'KR'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'tspdi@205'

What I want is to be able to connect to the Internet using an unfinished modem and use it as Wi-Fi. I have completed connecting to the Internet using a modem. Now I want to use Wi-Fi using this.

Cannot do that if your modem is not getting an ip address from your ISP.

Why are you not using the perfectly good modem that shipped with your laptop/OpenWrt router?

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd54:35ec:f3ba::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wwan0'
        option proto 'static'
        option ipaddr '10.192.79.158'
        option netmask '255.255.255.0'
        option type 'bridge'
        option dns '8.8.8.8'

I copied it incorrectly. The changed code is this.

I wanted to develop a driver that uses Wi-Fi with an unfinished modem using OpenWRT and see if it works well. If it's a modem problem, there doesn't seem to be anything more I can do.

Thank you for your kind answers so far. It didn't solve the problem, but your help was very helpful.

I wish you had lead with that.

Have you verified (on any platform) that the modem actually works? And do you have a driver installed already on OpenWrt that would recognize and operate the modem?

Confirmed that it works on Linux. I thought it would be easy because OpenWRT is a Linux-based OS, but it didn't work out well. :frowning:

So you need to continue to work on the drivers, then. If you need help with the drivers themselves, you can ask for support in the developers section, and hopefully someone will be interested in assisting you on this. Keep in mind that you'll need to do most of the work, but the devs can presumably help you figure out what might be wrong.

If you do ask in the developers section, you'll need to provide quite a bit of detail for anyone to be able to help.

Thank you. If I have trouble working with the driver, I will seek help.
There was no problem with the Internet connection, so I thought it was a problem with the OpenWRT settings.

Remove type bridge, add a reference to a device that corresponds your modem, like /dev/cdc-wdm0 or whatever you have.
If you really have to set IP configuration manually you may need to add a gateway address as well.

Show the output of cat /sys/kernel/debug/usb/devices
that should help to identify your modem.