Try this:
Install luci-proto-mbim
, configure wwan0
to use that as protocol and provide apn & other settings via that.
Try this:
Install luci-proto-mbim
, configure wwan0
to use that as protocol and provide apn & other settings via that.
OpenWrt (laptop) uses OpenWrt OS. The wwan0 device offers no special features and can only connect to the internet via the usim chip. I can use the Internet on OpenWrt OS by connecting to the wwan0 device using a cable.
I want to use this Internet by setting up Wi-Fi in OpenWrt OS. It doesn't matter whether the other devices connected to the wifi are laptops or phones.
5G was referring to IMT 2020. Is there a way to spread the internet via Wi-Fi?
No where are we actually told your laptop has a sim tray and its own cellular modem.
The translator failed us all.
You do not connect to wwan0, it is a device that needs its own interface.
Not until @DIYprojectz mentioned luci-proto-mbim did I look up your laptop.
Maybe but we all need to sit back for a moment and think about this unless your laptop is a supported device and has it own device page.
Edit:
Is IMT 2020 the name of the cellular modem? I need to know what chipset the modem uses.
Basically we need to build firmware for an x86 router and find drivers for all the chipsets.
Look in network/wireless and show me a screenshot, like this, that shows the radio.
We are closer than I thought.
Thank you for answer.
The luci-proto-mbim package is installed. However, if I change the proto of the WAN interface to 'mbim' and set the APN, I will not be able to use the Internet.
I hope the translator translates well.
The laptop does not have a SIM tray or cellular modem. The wwan0 device is doing this. Connect the board to an OpenWrt laptop to use the Internet. I think the explanation is insufficient. sorry.
if I change the proto of the WAN interface to 'mbim' and set the APN, I can't use the Internet.
IMT 2020 is known as the name of 5G, which follows LTE (4G). Am I wrong?
Take a picture with FCC label on modem or, preferably, send me a link of your modem.
Also:
In LuCI screenshot the network/wireless page.
edit:
Okay, what needs to happen is:
Go back to this working:
Then we need to configure the radio in wireless as an AP. When you get to network put it in lan (br-lan).
If you are lucky, you will see your SSID as an AP to connect to when you scan wi-fi with your devices.
I'll be back tomorrow but there are other people that can guide you through that.
This bridges the radio and the working ehternet in same interface.
You may need to find the correct drivers for the radio.
Thank you for your help so far.
You're right. OpenWrt (laptop) is that product.
The modem is not currently a finished product and does not have a label. We created a driver to use this modem and was able to successfully connect to the Internet.
If I set wifi to AP, OpenWrt wifi will be searched. This allows wifi connection to other laptops or mobile phones. However, internet access is not available. When I connect to wifi, the 'No Internet' message appears.
This is a Network-Wireless screenshot. Currently, the mobile phone is connected to WiFi and the mobile phone cannot use the Internet.
That laptop has a 5g cellular modem and you can see the tray in the side shot; it is the thing with the small hole in it.
So this whole thing gets easier if you use the built in cellular modem.
Or, it does not.
Honestly, I don't know.
Edit rdio0 and put it in the lan network, save, save and apply. Then look at the interface page and you should see a radio in the lan (br-lan)
If you have the right drivers (and you should because it is letting you config it) you can try to connect to AP and get internet.
It is way past my bedtime, I must sleep.
I'll check in with you tomorrow.
What I need to do is connect to wifi using that modem.
The LAN has become (no interfaces attached) and there is no change even if you insert the LAN and save it.
Good night, sir. Thank you for your help. I'll be back after the holidays.
This shows a lan interface.
Did you change something?
Changed ipaddr from 192.168.1.1 to 192.168.2.1. Nothing else was modified. You can connect to LuCI using the changed address. Is there a problem?
I don't remember; is it all fixed?
Still the same situation. When connected via wifi, you cannot use the internet.
Give me a while; I need to go over it all again.
wwan is the only device in wan? You have not bridged anything in the wan, right?
Show me a screenshot of Network/Interfaces and Network/Interfaces/Devices. While I read this all again.
you're right. wwan0 is the only device that connects to the Internet.
Still, if I check Network/Interface in LuCI, it looks like this:
/etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd54:35ec:f3ba::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wwan0'
option proto 'dhcp'
option netmask '255.255.255.0'
option type 'bridge'
oprion dns '8.8.8.8'
This is a list of devices.
ifconfig
br-lan Link encap:Ethernet HWaddr 00:E0:4C:68:00:83
inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fd54:35ec:f3ba::1/60 Scope:Global
inet6 addr: fe80::2e0:4cff:fe68:83/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3376 errors:0 dropped:0 overruns:0 frame:0
TX packets:2635 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:662752 (647.2 KiB) TX bytes:1030134 (1005.9 KiB)
eth0 Link encap:Ethernet HWaddr 00:E0:4C:68:00:83
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3388 errors:0 dropped:4 overruns:0 frame:0
TX packets:2849 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:663256 (647.7 KiB) TX bytes:1029482 (1005.3 KiB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:413 errors:0 dropped:0 overruns:0 frame:0
TX packets:413 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:32422 (31.6 KiB) TX bytes:32422 (31.6 KiB)
phy0-ap0 Link encap:Ethernet HWaddr F8:9E:94:5E:A9:B1
inet6 addr: fe80::fa9e:94ff:fe5e:a9b1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:299 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:44296 (43.2 KiB)
wwan0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:10.192.91.194 P-t-P:10.192.91.194 Mask:255.255.255.0
inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:2126 errors:0 dropped:0 overruns:0 frame:0
TX packets:2097 errors:0 dropped:9 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:643710 (628.6 KiB) TX bytes:487483 (476.0 KiB)
Dismiss the error box, set a password and refresh.
If you get the error again, dismiss it and see if it will, then, render the page.
Your cellular modem is outside your laptop and using USB, right?
And this is Network/Interface/device.
mgif_raw is a device for network debugging and is currently not used.
There is no device in the wan (br-wan) interface and it does not look like your cellular modem is working/connected. What makes you think it is connected to the internet?
And tell me again: why are you not using the cellular modem that came with the laptop?