Does not connect to Wwan0 device

I'm using a translator.

I connected to the Internet from the modem using the mbimcli command in openwrt. The IP address starts with 10. The rest is received randomly each time. (ex. 10.210.198.20)
The name of the device is wwan0.
If I specify wwan0 as the default router, the Internet will be connected.
However, when I connect to Wi-Fi, it says that the Internet is not available.
With pathping command, it only connects to 192.168.1.212 > 192.168.1.1 (OpenWrt.lan) and does not reach wwan0.
How do I solve this problem?

move wwan0 to the wan firewall zone ?

1 Like

Make sure the interface is a member of wan firewall zone.

The interface below uses wwan0. The firewall-zone of the interface is set to wan.

is now, or was ?

It's now.
Still can't use internet via wifi.

I can use the Internet using a modem. However, Internet use is not possible on devices connected to Wi-Fi.

restart the network service, or reboot the device.


I tried restarting several times, but the problem was not resolved.
The picture above is the result of the ifconfig command and you can see that ping is working well.

Can you access Internet from devices connected to LAN?

Please do not use pictures when you need to show just text.


This is the result of the pathping command from a laptop connected to Wi-Fi. It disconnects after arriving at br-lan. Internet use is not possible. How do I solve this problem?

sorry. Because it was a different laptop, I couldn't express the results in text. I confirmed that when connecting to the Internet via LAN, the Internet is connected through WiFi as well.

Sorry, I do not understand this. Do you have a problem with Wi-Fi clients only or with both LAN and Wi-Fi?

might be a good idea to ....

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Current

modem(wwan0)-OpenWrt(laptop)-(LAN cable)-PC

This connection will allow me to connect to the Internet.
However,

modem (wwan0) - OpenWrt (laptop) - (WIFI) - PC

this connection, I can't use the Internet on my PC.
In both situations, Internet access is possible on OpenWrt (laptop).
How can I use the Internet on other devices connected to Wi-Fi?

I couldn't think of a way to use ssh. thank you for telling me.

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "OpenWrt",
        "system": "12th Gen Intel(R) Core(TM) i5-1240P",
        "model": "SAMSUNG ELECTRONICS CO., LTD. 955XED",
        "board_name": "samsung-electronics-co-ltd-955xed",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "x86/64",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd54:35ec:f3ba::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wwan0'
        option proto 'static'
        option ipaddr '10.241.130.121'
        option netmask '255.255.255.0'
        option type 'bridge'
        oprion dns '8.8.8.8'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:14.3'
        option channel '6'
        option band '2g'
        option htmode 'HT20'
        option country 'KR'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'tspdi@205'
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option start '100'
        option limit '150'
        option leasetime '12h'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

If this is true:

Cannot do this:

This is wrong:

Should be dhcp client

This is wrong:

Needs to be client not ap.

I do not config in CLI; someone will need to rewrite those mistakes for you.

This whole problem is so close to this I feel like this is homework for some class.

Change the wifi mode from 'ap' to 'client', the wifi 'OpenWrt' is not searched. So it won't connect from my PC with wifi.

I changed wan's proto from 'static' to 'dhcp'. There was no change.

This whole problem is so close to this I feel like this is homework for some class.

I've read it, but it seems different from the problem I need to solve. I am trying to connect 5G internet through usim and spread it through wifi.

Your laptop has one radio. It may do both 2.4 and 5, but one all the same.

So, you need to use it to connect to wwan.
And that is it, all you can do is use the ethernet for lan on the laptop.

You can try a USB dongle and we have a thread looking for a reliable one but nothing is reliable enough to recommend yet.

Assuming

Is what you have to work with.