DNS Forwarding

Hey guys,

Installed my first instance of OpenWrt recently. It's pretty awesome. One thing I'm not happy about though is the DNS forwarding. After install OpenWrt my PiHole log only shows the router IP as the only client, whereas it used to show all the different machines. How do I make OpenWrt imitate the former config?


You likely need to advertise your Pi Hole as the DNS server with your DHCP.

It sounds like you've got your clients using the OpenWrt DNS, and the OpenWrt uses the Pi Hole. You perhaps want the clients to use the Pi Hole. If you want local DHCP data in the reverse DNS, then you likely need to configure the Pi Hole to use the OpenWrt for its DNS, then OpenWrt to use upstream DNS.

See also Openwrt and Pihole for host names

Thanks, but the issue isn't resolving host names, it's that all the DNS requests are coming from the router rather than the machine IPs.

"You perhaps want the clients to use the Pi Hole." Yeah, but how do I do this without configuring each device separately? Previously on factory FW the router would propagate the Pi Hole as a DNS to all devices. Now it doesn't.

You want to use “Option 6”, which tells dnsmasq to advertise an address to clients

1 Like


Or in /etc/config/dhcp

config dhcp 'lan'                                
        option interface 'lan' 
        option start '100'                 
        option limit '150'                       
        option leasetime '12h'             
        option dhcpv6 'server'                   
        option ra 'server'     
        option ra_management '1'
        list dhcp_option '6,,'

Thanks, that did it!

@FinneousPJ If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.