Support request: Pi-hole only show router hostname in query log

Hello

Pretty new to OpenWrt and more advanced network configuration so excuse me it this is to obvious...

I’m having issues similar to this and this but the proposed solution didn’t solve it for me.

So, I'm running owrt 19.07 on a Netgear R7800 and I have a RPi4 running Pi-hole v5.2 + Unbound as recursive DNS resolver for my network.

Obviously, in owrt my pi-hole is set as the “Custom DNS Server” for my lan and after reading the topics above, I’ve used DHCP option 6 6, 192.168.24.2 to advertising the pi-hole as DNS server to the lan.

Pi-hole DNS is configured as this:

  • Never forward non-FQDN’s - Unchecked
  • Never foreward reverse lookups for private IP ranges - Unchecked
  • Use DNSSEC - Unchecked
  • Conditional forwarding – Enabled and configured to forward to the router

I feel pretty sure that the problem is with owrt as there simply isn’t that many other settings to mingle with in pi-hole except the ones I listed above.

Do you have any suggestions to other settings I might check?

Thanks in advance.

Configure both dnsmasq and odhcpd and reconnect the clients to apply changes.

Also remove spaces.

1 Like

@vgaetera thanks, I'll try that. I have only been using LUCI and I guess "Save and Apply" doesn't restart dnsmanq so that's worth trying.

Regarding odhcpd, the values in the example you linked to are gibberish to me. Is it ports or? and what am I supposed to input?

Thanks in advance.

EDIT: Ahh, I think I get it. The values in the odhcpd example is IPv6 addresses right? So do I simply use my IPv4-address for the pi-hole for dhcp.lan.dns?

`

1 Like

Yes, but if the Pihole doesn't have an IPv6, then use the IPv4 there too.

1 Like

That did it. Thanks a lot.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.