DLink DIR-853 A3

The best way is to create a new thread like this one.

The thread you linked is not for the A1 but the R1 which is already supported (don't use that one though).

I don't this it will be hard to add by the way. Again don't use the A3 or R1 as they are all different and you might brick your device.

1 Like

Hi Kar,

I was previously using your Padavan build on my DIR-853 A3, and I wanted to change it to the new OpenWrt build now that I heard the news.

I flashed the Padavan-to-OpenWrt build according to your instructions. However, I made the really silly mistake of repeating the flashing commands, so I accidentally flashed the Padavan-to-OpenWrt build after the OpenWrt flash. Consequently, I am now unable to connect to my router via SSH.

I understand that you're not responsible for me bricking my device, but is there a possibility I can recover from this mistake?

Edit: I spoke too soon. I rebooted my router, and I'm able to connect to the LuCI interface. But just to be sure, did that second flash affect my router in any bad way?

Hi @marwan,

I believe this won't affect your router in any substantial way as flashing openwrt again is just like flashing from one firmware to another, but is just redundant. (The only possible way I can imagine this could affect the router is just wearing out the NAND, but NANDs have quite the endurance so I don't think it'll be an issue.)

Btw just a note, how were you able to flash openwrt twice? since mtd_write command doesn't work for me on openwrt

Hi @marwan,

As @throwaway pointed out if you did it twice it does not matter. It is just writing the same date over it.

You can now use the rc3 if you want by flashing it from the web interface. It should work better than rc2.

@throwaway the mtd_write and mtd command seems to be the same (although the openwrt one has more options) and they are just named differently. I think what @marwan was reffering to is just flashing twice during the same ssh session.

@tmomas Do I need to open a new thread to have all the important info at the top? I feel this thread is not very efficient for the users and they have to scroll quite a bit to get the information needed.

1 Like

Is it the stock firmware? I got the DIR-853ET A3, it seems it has Etisalat firmware I want to flash the stock firmware first. now my dlink wifi app for android is not detecting this router. I just want an stock unlocked dlink stock firmware so ti will be connect to dlink cloud and I can manage through app. @kar200 kindly can you help me with this?
P.S. this file is deleted from wetransfer.

1 Like

Hi @umarbest ,

I am not sure I understand what you installed and what you are trying to achieve.

Stock firmware means the firmware that the router had when it was brand new.

Can you please reply with:
What firmware you have installed (the one that is installed now).
What firmware are you after ? The dir-853-a3 is exclusive to ET so there is no "other" stock firmware.
Did the D-Link app work before and it stopped working ?

I will then be able to help you "if I can" with what you're trying to achieve. Also please refrain from flashing anything at the moment as you risk bricking your devic.

@kar200 Thank you very much for replying,

I bought 853 A3 yesterday and I haven't touched the firmware, it is the default that comes with it.
I wanted to flash Dlink stock/international/unlocked firmware for this device but you said there is no option like this, so I have only one option left and that is OpenWRT, right?
The Dlink app never worked to set up the router, this app says there is no Dlink router found.

Please advise/suggest any other router that has ac1200, MU-MIMO, app controlled and the widest range.

AFAIK There are no app to control an openwrt router from a mobile phone. Maybe there are but I did not come across one before.

And yes the DIR-853 A3 is specific for the ET. It is actually a DIR-1360 clone. The firmware of the DIR-1360 does work on it but I think I did try once to use the dlink app and it still did not work. The DIR-853 does have a dlink number in one of the partitions which I believe is unique but I don't know if that is enough to make it work through a different firmware.

Sorry I don't know which router to recommend I did not try that many and normally I don't use the stock firmware that long.
By the way what do you want to control from the mobile phone? Maybe have a look at the new Xiaomi AX series they might be the best option (price performance)

Hi @umarbest and @kar200 ,

If want to use your phone to control the router you could connect it through home assistant if you have a additional device or install home assistant onto the router itself (which is possible from what I have seen but can be hassle) and you could connect other compatible routers and smart devices to it.

But the only reason I could think of to use the app instead of LuCl through the browser is to connect D-Link extenders/ access points to make a mesh network, which I tried before on stock firmware but it wouldn't work

Hi @throwaway
I want to use the app for parental controls e.g. pause the internet of some device for some time, prioritize device in QoS, etc. I am talking about the "D-link Wi-Fi" app not the "myDlink" the cloud control app.

Please guide, which hardware revision's firmware of 1360 work on this router?

It's not a straight forward process and I remember bricking my router once trying it. The upgrade won't accept the firmware and the boot loader is different.

Also the nvram (where the settings are stored is different). What version of firmware do you have on it? I noticed there was a new version recently that got pushed to the device when I connected it to the internet. Maybe with that one it would work (I have not tested it).

Hi @throwaway how are you?

Can I please ask you to for your mtd2 dump? It is just the factory that contains the wireless calibration + mac addresses of the device. I need to compare between factory and openwrt
You can get it from the web interface (system - backup/flash - save mtd block - factory)


Hi @kar200, I was working on a hackintosh project that didn't work out.

Anyways, sorry for the late response I was busy doing something.

Here is the file btw : https://file.io/VnSnBHkOeQMp

No worries. The file seems to have been deleted (don't know if it was me from my phone)

Download | file.io

Hi @kar200,

On an unrelated note I have been trying to build an image for an old access point I have lying around ( [OpenWrt Wiki] Techdata: TP-Link TL-WA901ND v5) in order to remove unnecessary packages to fit wpad-basic-wolfssl instead of the precompiled one which has wpad-mini, so I am using WSL to bulid the image. but everytime I try to build the image I get this error.

sed -i "s/Installed-Time: .*/Installed-Time: 1625255412/" /home/idk/openwrt/build_dir/target-mips_24kc_musl/root-ath79/usr/lib/opkg/status
rm -rf /home/idk/openwrt/build_dir/target-mips_24kc_musl/root-ath79/boot /home/idk/openwrt/build_dir/target-mips_24kc_musl/root-ath79/tmp/* /home/idk/openwrt/build_dir/target-mips_24kc_musl/root-ath79/usr/lib/opkg/info/*.postinst* /home/idk/openwrt/build_dir/target-mips_24kc_musl/root-ath79/usr/lib/opkg/lists/* /home/idk/openwrt/build_dir/target-mips_24kc_musl/root-ath79/var/lock/*.lock
find /home/idk/openwrt/build_dir/target-mips_24kc_musl/root-ath79/ -mindepth 1 -execdir touch -hcd "@1625255412" "{}" +
find: The relative path 'Files/WindowsApps/TheDebianProject.DebianGNULinux_1.4.0.0_x64__76v4gfsz19hv4' is included in the PATH environment variable, which is insecure in combination with the -execdir action of find.  Please remove that entry from $PATHmake[2]: *** [package/Makefile:73: package/install] Error 1
make[2]: Leaving directory '/home/idk/openwrt'
make[1]: *** [package/Makefile:111: /home/idk/openwrt/staging_dir/target-mips_24kc_musl/stamp/.package_install] Error 2
make[1]: Leaving directory '/home/idk/openwrt'
make: *** [/home/idk/openwrt/include/toplevel.mk:230: world] Error 2

I couldn't find anything on the internet to solve this and I have tried running multiple variation of the command.

If you aren't available to help I completely understand that.

No worries, I found the solution I just had to run the make command in sudo

Never, ever, run make or git commands as root (using sudo or otherwise).

Thank you, I was able to solve the problem using the guide @kar200 sent me. I was wondering, why is it wrong to with running the commands with root privileges? (please forgive my ignorance)