Adding OpenWrt support for DIR-1360

Sorry for reviving this seemingly closed thread, but recently I'm doing some research on DIR-1360 and stumbled upon this thread :grinning:
It seems that DIR-1360 shares a lot of similarity with DIR-3060 (At least in terms of FW). So I'm also curious about if it's possible to port OpenWrt to DIR-1360, or there already exist a usable OpenWrt image for it?

Also, seems like no one have discovered or shared this before, so a little gift for people trying to port OpenWrt to this D-link product line:

Input http://[router IP]/start_telnet in your web browser or wget will start the telnet service even if the web server returns 404 not found.
And you can login with cred mentioned by @kar200 in the 23th reply :slight_smile:

I'm new to OpenWrt porting so please tell me what info I need to provide and I'll see what I can do!

1 Like

Nice, I have been looking for a DIR-1360 for a while now lol.

A couple of questions please, does the recovery works for you? This is by holding the reset button down while booting up the device. If it does can you please send me a copy?

The DIR-853-A3 "which I have" is a clone of the 1360. Thanks to corona I have spent a few months learning and trying to have openwrt working for it. do you have access to the console? I managed to get openwrt, padavan and and a couple openwrt clones working.

If you are proficient enough to build an image I can send you the DTS and it's only a coupld more changes and you'll have a working openwrt. If not let me know if you are interested with the RC or the master image (reminds me I should probably publush it on github).

Hello folks!

@kar200 I'd love to test your build for DIR-1360. I have one here barely unused due to a new Linksys EA8100 v2. Would be great to use it as a dumb AP.

Hi @diegocn

This is not really "my test build". It is the official openwrt for DIR-853 with just the header changed manually and then encrypted to be accepted and flashed by your router.

This might fail but in your case you should be able to recover with the Dlink emergency room (reset button then upload the original firmware).

The router will show DIR-853 A3 after flashing but it's better anyway since you will be able to flash the snapshot images for example and no need to create manually a new image each time.

Let me know how you go, Obviously I have not tested the image since I do not own the hardware.

You should be able to just upload the file from the web interface and then the router will flash and reboot. After that the IP will be


I'm gonna test it! Thank you so much!

Tried it with D-Link's recovery GUI/mode but received a timeout both using Browser upload and curl upload.

Tried again:

  1. Entered recovery mode
  2. Did not access the web page for firmware upload
  3. Tried curl, and the upload did work (as seen on screenshot)
  4. But the router now keeps blinking the orange led, which means some sort of failure (right?)

[editing] I can't post more replies to this thread :cry:

Did try with the second file you've posted @kar200 and the same happens: just the orange led blinking after curl upload.

[edit 2]
Tried with old versions of Firefox (13 and 47), and also, tried with an IE11 VM. The upload seems to timeout and then, I can't access the recovery page again (it kinda 'freezes').
At the upload moment, the blinking orange led stops blinking for a moment and then turns back into 'blinking mode' until I manually reboot.

I can try other methods for flashing the firmware (telnet, TFTP, etc.) if available.
Also, I can run telnet commands for debugging if needed.

Don't use curl with the firmware. It's encrypted. This is for the normal web interface.

If you want to use the CURL interface try this file.

Do you have access to the normal firmware? like the stock Dlink firmware? If yes just upload the encrypted file through the normal update process and it should work (unless I made a mistake in the file I created).

Unfortunately I had troubles with uploading through Curl before and I couldn't get it work all the time for some reason.

If you have access to the console you can use tftp. If that's the case just upload the normal firmware found on openwrt download for the DIR-853 and it should work (as the header does not get checked with this process)

Yes I do!

Iโ€™ve tried uploading openwrt through the stock firmware interface but it shows an error and does not start the install process.

Can you confirm you have the DIR-1360 A1?

Yes, it is this version (showed in the first screenshot).
Also, the second screenshot shows the error message when I try to upload de enc firmware.


Weird. I tried again with changing the version number in the header. enc file to be tested first in the web interface and the other one with CURL if the first one fails.

Tried the web interface and it returned the same 'failed' message as before.
Tried the curl mode and it seems the router did accept the firmware and started the upgrade process, I'll wait for a couple of minutes and see what happens.

[edit 1]
It did not work and I think it bricked the recovery mode, I can't access it anymore after restarting and holding the reset button. But the stock firmware is still working.

I am sorry I am out of Ideas. I don't think you have "bricked" the recovery mode since it is part of u-boot and the router would not boot at all.

If you have access to the console or can get access through the TTL it would be your best bet to see why it is not accepting the firmware. Unfortunately I don't keep a copy of firmwares I share in here (very unorganised) but I will have a look and see if I have a copy somewhere that worked in the past with the DIR-1360

Oh, please, donโ€™t worry. Itโ€™s part of the trial and error game :smile:

By console you mean that one that would require soldering a usb device to plug into a regular pc or you mean telnet?

Telnet is easier for me, as I do not have experience soldering. But Iโ€™ve tried it once in another bricked TP-Link router. Could give a try again but would be the last option hehe.

Hello @kar200!

Hope you're well and thanks for the help so far.

Do you have any other clues about what can I do to test this firmware?

Hi @diegocn sorry for the late reply.

Unfortunately no I don't. The console is through UART is the best tool as there is no file check before writing to the flash and you can basically recover from anything as long at the bootloader is not bricked.

Hello @kar200!

It's me again on the DIR-1360 saga :smiley:

I went all-in trying to install DIR-2660's OpenWRT Image and it 'worked'.

I was able to upload the firmware through the recovery page and the router accepted it.
I can use the internet while wired connected to the router but wifi does not work at all. Also, when I try to access Luci's web interface the router 'crashes' and then reboots automatically.

Can we use that DIR-2660 as a starting point to have the proper DIR-1360 firmware working?
Is that possible to 'port' wifi drivers from 1360 to 2660's firmware?

Disclaimer: I'm not afraid of bricking this router, it's literally my last bet to make OpenWRT work on it.

1 Like

the DIR-853 A3 is image you want to try for the DIR-1360
it's the same PCB & radio config

1 Like