DL-WRX36 can't see IP of EAP265 access point

I have Dynalink DL-WRX36 running openwrt, fully setup and wireless and ethernet is working.

I reserved LAN4 port on the DL-WRX36 for access points.

I connected that port to a TP-Link access point, EAP265 HD (not openwrt).

But I cannot see the IP (supposedly to manage the access point).

Can anyone spot any mistakes on this config please.

Is it because of my VLAN setup?

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd09:b0ce:1b1f::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan.10'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'REDACTED'
        option password 'REDACTED'
        option ipv6 'auto'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'lan1:u*'
        list ports 'lan4:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '20'
        list ports 'lan4:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '30'
        list ports 'lan4:t'

config interface 'guest'
        option proto 'static'
        option device 'br-lan.20'
        option ipaddr '192.168.20.1'
        option netmask '255.255.255.0'

config interface 'iot'
        option proto 'static'
        option device 'br-lan.30'
        option ipaddr '192.168.30.1'
        option netmask '255.255.255.0'

config bridge-vlan
        option device 'br-lan'
        option vlan '40'
        list ports 'lan4:t'

config interface 'work'
        option proto 'static'
        option device 'br-lan.40'
        option ipaddr '192.168.40.1'
        option netmask '255.255.255.0'

Everything looks fine here, as long as there are only expected connections on lan1 (untagged VLAN 10) and lan 4 (tagged all VLANs).

Hmm my PC is on LAN1 port and I can login to LuCi.

It’s just that I can’t manage the access point if I don’t see its IP…

I start seeing the SSID when I plug it in LAN4 port but I can’t seem to join that SSID.

The AP must be configured to expect the VLANs as tagged.

You might try changing this:

... if you make VLAN 10 on port lan4 untagged, maybe the AP will show up (it's entirely based on the configuration of that AP and the VLAN configuration it is expecting):

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'lan1:u*'
        list ports 'lan4:u*'

Let me try that, thanks. Be back in a bit.

Hey thanks for your help @psherman

I left it at

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'lan1:u*'
        list ports 'lan4:t'

I unplugged the AP and connected it to a different router and managed the VLANS from there.
I plugged it back to DL-WRX36, now I can connect to the SSID (with VLAN working this time).

I think I'll stop here, even though I still can't see the IP of the access point.
As long as SSID and VLANs are working, I'm a happy camper.

Thank you!

Your configuration on OpenWrt looks good, so it's probably a question about the configuration of your AP (for example, DHCP or static IP, management network/VLAN, VLAN tagging status).

But since it is working for you now, that's great!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.