DIR-890L Openwrt

Hi guys,

I installed the software of the 885L device on this device and it works. But I couldn't get the wifi to work. I think the drivers are missing. Is there any way I can install these?


that's not an official openwrt image, ask the person who made it.

if it was, wifi performance would be really bad.

1 Like

there has been a developer (snapshot) build available for the 890l for a while now and I also saw the 890l mentioned in the developer mailing list a while ago:

But be careful: check if this matches your 890l at all (maybe there is a HW rel 1 or 2 or similar), use at own risk, note that this is work in progress and you could theoretically also brick your device with snapshot builds, requiring e.g. serial cable recover in unlucky outcomes. There seems to be no wiki page or dedicated forum thread so far, so expect little to no experience feedback of users, which could be used to get an up to date impression of the current dev status. Maybe browse the dev mailing list, to get some insights.

I am not involved in Wifi work or this device work and do not have background status infos.
It might or might not one day become a regular release, just so far there is no public timeline, if and when this could happen and how bad the resulting Broadcom WiFi experience could eventually turn out.


its not working..

the Lord gives, the Lord takes.
Nothing much you can do then, except wait for a few years.

I contacted the developer.. he is so friendly. He made the firmware compatible and it works without any problems. But i have problem. My iss used pppeo + vlanid 35. Even though I did everything right,
it gives an error. error code: USER_REQUEST. I recorded the settings I made as a video. Is there anything I'm missing?

Which one is it ?

Ask the friendly developer ...

I can't connect to the internet because of vlanid..

Delete the default wan6 when using pppoe-- if your ISP does support ipv6, it is done a different way over pppoe.

I'm not going through the video frame by frame but I do see zero bytes received on wan, which usually means the VLAN or physical connection is bad. Make sure the ONT or modem is not configured to add/remove VLAN tags itself. Did you try pppoe direct on wan without a VLAN?

Also there may be more details of the error in the system log, which you can view under the System tab.

I tried disabling ipv6 but it didn't work and I tried disabling vlanid and it didn't work..



anyone help

i have problem. My iss used pppeo + vlanid 35. Even though I did everything right,
it gives an error. error code: USER_REQUEST. I recorded the settings I made as a video. Is there anything I'm missing?


The resolution is fuzzy, can you paste the configs?

cat /etc/config/network

[Firmware Bug]

bridge configuration invalid

Are you sure?

was there something wrong with the help you received in the old thread ?

it's still a 3rd party fw, ask the creator, not us, you did say they were friendly ...

1 Like


Why do you give negative answers instead of helping? I'm just looking for help. If you are not going to help, please do not comment on the topics I opened. The first thing I did was to ask the creator. But he said that I had no idea and that I should write to the forum. I do what he says.

Thank you for trying to help. I'm new to openwrt. These are my settings

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fdc1:1672:5c83::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '00:90:4C:17:f0:19'

config interface 'wan'
        option device 'wan.35'
        option proto 'pppoe'
        option username '12345comnet@comnet'
        option password '1234567'
        option ipv6 'auto'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '35'
        option name 'wan.35'

I didn't see anything negative. It seems to be a valid question since you're not running [official] OpenWrt firmware. Asking the friendly creator of the firmware seems positive, logical and most helpful.

While on the other hand, it seemed unnecessary to open a duplicate topic - knowing that you're not running OpenWrt.

I'm not sure why the creator would say ask the forum. We didn't create the firmware.

But...you're not running OpenWrt. :slightly_frowning_face:

Additionally, I posted errors from your log that you haven't acknowledged yet:

The creator should know why those errors occur.

From the log you posted:

Fri Oct  6 20:36:20 2023 daemon.warn pppd[3267]: Timeout waiting for PADO packets
Fri Oct  6 20:36:20 2023 daemon.err pppd[3267]: Unable to complete PPPoE Discovery

This indicates that the interface has not received an initial negotiation packet from the modem/ISP, and the received byte count of zero confirms that.
Maybe DSA is not working with VLANs on that chip? Broadcom chips get very little use or testing here.

If you have an extra managed switch at hand you could configure it to convert untagged to tagged 35 on two of its ports then install it in line to the modem. Then configure the router to use untagged pppoe and see if that works.


This device is supported on snapshots if you don't like my rogue builds (the result will likely be the same):


The only reason I built it is that OpenWrt snapshots don't contain LuCI and it's not helpful for end users.

NB: this device's WiFi is the brcmfmac driver which is kind of OK, not the infamous b54. However the WiFi has nothing to do with this VLAN problem.

The DSA switch is b53, which is in pretty widespread use.

Sadly I don't know much about VLANs or b53! I would love to help but I can't. Please experiment!

1 Like