DIR-853 Bricked After Installing OpenWRT

Hi guys,

I today installed OpenWRT on the router DIR-853 after that my router is not responding to anything it keeps restarting and Ethernet is not responding it turns on and then turns off therefore I can't even use recovery mode. Please help this is my main router now I can't use wifi anymore I have to type this with my data

I dont have this router but can you try a hard reset or reset to factory?

I tried resetting it but nothing changed

Tell us in steps what you did:

After kernel loads Openwrt blinks at 5Hz for 2s, where you need to press reset to skip overlay.
If you never get there you are likely with soft brick.

and do you have the correct revision ?

Yes it is the correct revision

I installed this one https://github.com/openwrt/openwrt/files/10833430/dir-853-a1-fac-enc.bin.zip

And how to fix the soft brick?

TFTP, as described further down on the wiki page.

Lets assume upgrade is somehow half-way.
Try to press reset button while LED blinks quick, there should be a ssh root without password at, you may need to set IP in subnet to connect it. Then sysupgrade to 23.05.3 without preserving config. There is a generic guide in WIKI, but if you get SSH connection confirm with us if it is current guide.
Soft brick in general means you need to connect serial adapter and then you can use vendor recovery menu to debrick towards vendor firmware or OpenWRT, or in order.
Hard brick (like one or no blinks at all) would mean unsoldering flash chip and programming it fully.

I don't understand a single thing on what ur saying. Can you explain it in a other way. I'm a novice like just a beginner

I did not even open the first time setup screen therefore Wi-Fi is disabled and my Ethernet is connecting then going off. The power led is always orange and then it restarts, the cycle goes on

You need to set up static IP address on your PC mask
gateway -
And connect cable to lowest numbered LAN port (not wan)

Try to enter failsafe mode:

If you succeed you have a chance to do firmware upgrade to complete the installation. Indeed if no led blinks for 2s and no network packet is sent you need serial cable.

which button do i press? reset, WPS or Wi-Fi button?

I can't even connect to the router by LAN because the router is keeps connecting and disconnecting the LAN cable every 5 seconds. What to do now?

what version of the Dir-853 do you have A1-A2 or A3 ?

I have the A1 hardware revision

that's good the rest button will work
so switch off the power find something like a pen or pin
to push in the reset button while switching on the power
for about 30 seconds you will see the leds flash differently
and the Ethernet will stop reconnecting and boot looping

you need to set the pc to a fixed ip of
open a web browser to
you should find a recover page wanting a file to upload

pick one of the files below to upload below openwrt or factory firmware
i use firefox in private mode on windows
but I'm told IE mode in edge works as well

after you get a successful upload set you ip back to dhcp


I tried to hold it for 30 seconds and also 1 minute but nothing changed