DIR-810L RevB not booting properly

Hey there

First of all - I'm quite new to all this linux stuff. My brother introduced me to OpenWRT, and I found that I quite liked that compared to Stock Firmwares.

Yesterday I upgraded from 15.05 Chaos Calmer on my WRT1900ACS and had some issues with it not booting properly. I managed to fix it, and it now quite happily runs LEDE/OpenWRT 17.01.4

Today I'm trying to upgrade my small access points to 17.01.4, and I seem to have issues with them not booting properly either. The light (on/off light) is constantly on, so it doesn't seem to be rebooting.

However, I cannot connect to it after upgrading. It doesn't request an IP from my main router either.

I have tried updating it from LuCI as well as the console (putty on a windows machine). Both times it seemed to do it as it should, but both times I could not connect to it afterwards.

Is there any known issues in regards to booting after upgrading? And anything I could try to do differently for this AP to work?

I have tried installing both *.3 and *.4. Both seem to result in the same behaviour

Thanks in advance!

Additional info:

Pressing the reset button during boot (after the D-Link failsafe) results in neither the power nor internet LED lighting.

  • How long did you wait for the device to reboot?
  • Did you SAVE SETTINGS???

This is because you're likely entering another boot mode by doing so.

On both accounts, I have given it 5-10 mins to do its thing.

And no, I did not save the settings, as I read that that could cause it to fail.

I estimated 5-10 mins was enough, as installing factory -> Chaos Calmer 15.01 took less.

Please describe the current status of the devices.

Are you able to re-flash version 15 and try again?

Current status as viewed by my windows PC:


Forcing as gateway (standard Ip for D-link) doesn't solve it.
Forcing as gateway (standard IP for OpenWRT/LEDE) doesn't solve it.

Pressing and holding reset while booting allows me to enter D-link fail safe, and I am able to re-flash OpenWRT 15.05 CC, which then allows me to connect to it just by acquiring IP automatically.

So yes, I am able to reflash. Is there anything specific I should try while attempting again?

I had a similar issue before while flashing.

In that case

  • I re-flashed the previous firmware
  • No settings were on the device
  • I went to the administration page, and I re-flashed

I'll try that.

Is it better to use latest, or an earlier version?

And I suppose sysupgrade is fine when flashing from 15.05?

I thought you were upgrading to 17.01.4, so that's what you want to flash.

I thought the instructions for your device say to use the LuCI web GUI???

Is there a problem flashing from the web GUI???

For testing purposes. There might be some known bug or something in *.4?

There's not really an issue uploading a firmware through the web GUI. Problem is getting the device to work afterwards.

I did as you suggested earlier and gave it well over two hours to do its thing. It's still stuck at "Identifying"


You never mentioned [that you could see] the flash was stuck somewhere...Is there a compatible DD-WRT image for your device???

Try upgrading from that, IF THERE IS AN AVAILABLE IMAGE. I'll look more into the hanging at "identifying."

I thought I did. I found a DD-WRT image that it quite happily flashed.

DD-WRT V3.0-R27600 (08/11/15) rejected "lede-17.01.4-ramips-mt7620-dir-810l-squashfs-sysupgrade.bin" and rebooted into DD-WRT again.

Have you verified the file's hash?

Yes. Using powershell and get-filehash SHA256, I get a result identical to the one here


Also, in the OpenWRT 15.05 -> LEDE 17.01.4 attempt, I was able to verify the MD5 hash that OpenWRT comes up with when you're about to flash a firmware

For clarity...

Are you're flashing the device to its default settings...and if so, are you accessing it from one of the LAN ports, so you can reconfigure it?

The only port in normal configuration that would receive an upstream IP is the WAN...and under default config, you couldn't access the LEDE from WAN.

Between attempts at flashing LEDE on it, I've entered fail safe mode and uploaded factory -> OpenWRT. I haven't changed any settings in OpenWRT before attempting to flash LEDE.
Yes, I am accessing it from the LAN port.

Testing with a cable from my PC -> Lan port and another cable from my WRT1900ACS -> LAN port, I don't have any internet access.

Testing with a cable from my WRT1900ACS -> WAN port, I can see that the DIR810L doesn't request an IP address.

I haven't attempted to configure it from the WAN port since I doubt that's possible

I understand...but do your reconfigure your test PC for DHCP....and do you get an IP from LAN after flashing???

Reconfigure my test PC for DHCP? What does that involve, other than setting my PC to acquire IP automatically?

I regards to that I have attempted static IPs both in range and (which is the standard IP for the default firmware as well as the recovery module).

No. I don't get an IP. Doing CMD -> ipconfig gives my PC some random IP with no standard gateway.

All three network adapter settings returns: "Identifying" and after some time: "unknown network"

With the "acquire automatically" options, ipconfig /renew just sits there.