Different errors on RPi4


First things first, I am new to OpenWrt and I am loving it. But when I am trying to install OpenWrt on a Raspberry Pi 4B, I got different errors and I don't now how to reproduce them but the following errors are:

  • randomly I/O error's (before the error encounter I could write and read),
  • randomly "(file name) only readable" error.
  • LuCi problems, when I change the router ip then I can't login in to the router. Even when I erase the caches.
  • also after multiple reinstallation, I get a page that shows me the index of LuCi. But it shows me nothing. The only thing I see is the title (Index of) and 2 bars with nothing in between.

And sometimes it shows me the web interface of the router especially in the beginning if I want to login I see the web interface. But after some changes the web interface disappears.

After too many try's I am getting a little frustrated because I don't know where the problems are coming from. Does someone know how I can just install OpenWrt without any problems? You would help me a lot!

And beside that, I am trying to reproduce this video: https://www.youtube.com/watch?v=jlHWnKVpygw&t

Kind regards,

Tried replacing the SD card?

It is a fresh one, but I could try another one.

It doesn't work. And here is a screenshot from one of the problems

this is with another SD card.

What image are you using?

The latest one (21.02.2). But I have tried 3 different images and I still get the same errors. I tried 21.02.1, 21.02.0 and the Snapshot just to try :wink: .

just to be sure... where did you download it from? and which specific images have you tried? What process did you use to install it?

I downloaded it from here: https://firmware-selector.openwrt.org/?version=21.02.2&target=bcm27xx%2Fbcm2711&id=rpi-4 . And I use the raspberry pi imager to put the software on the SD card. The latest image I tried was 21.02.2. And from there I did everything over SSH.

And how are you accessing it? The screengrab looked quite strange in terms of the spacing and such.

I am accessing it from my MacBook Pro (Monterey 12.1) through the terminal with SSH. And the font and everything is customizable in the macOS terminal.

ok... fair enough.

Try following the instructions for commandline usage from this page (instead of using the imager tool)

I will look into this, thanks!

I tried this already :see_no_evil: .

Oh... oh well.

What about if you connect a keyboard and display directly to the Pi and try issuing commands with the local terminal?

Have you by any chance over clocked it?

Yeah that was my back-up plan, but I don't the facility's for that :see_no_evil:. But it is strange that I got these errors.

Nope, the Pi is fresh out of the box.

This also some weird thing.

I removed the SSH fingerprint on my MacBook and the SD card is a fresh install. I think it is in my cache but still I didn't even put a password on it.

on Mac OS:
ssh-keygen -R

Then you will be asked to verify adding the key as is shown in your screenshot. Looks okay to me, though.