Did I just brick my router ? Archer C7 v2

Hi community, need some help... believe I may of made a grave mistake.

I have a Archer C7 v2 router I had not used in a long time, It was running DD-WRT LEDE and in my attempts to update it to latest DD-WRT firmware (last update was 2015) I think I may of bricked it, looking for help on how to recover if possible.

Initially back in 2015, I bought the router new, flashed


then flashed factory-to-ddwrt-US.bin and eventually was able to flash and utilize the Lede firmware version - lede-17.01.4-ar71xx-generic-archer-c7-v2-squashfs-factory.bin.

Everything was great for years, then I moved and had no need for router so it sat and collected dust, now I want to use it again and was attempting to flash it to a more upgraded version using the webGUI, I tried to apply tplink_archer-c7-v2-US.bin and perform a reset to default before and after on router. Now I am stuck the router has lights and boots but when I start it up and plug in a ethernet direct connection the LAN port lights but a PC directly connected only gets APIPA address and even setting the IP configuration on this locally direct connected machine manually as,, the router at IP fails to ping and I can no longer communicate with it?

Anyone have ideas of what I can try next?

I can't reach WebGui, can't connect ssh, trying TFTP via tftpd64.exe but no responses in logging.

I performed a Advanced IP Scanner process from the locally connected machine (the Ethernet jack connected to router lights up when connected). No results returned to identify the router IP Sad

command line "arp -a" returns three IP's,, all of which when attempting to ping requests completely time out.

when the PC connected locally is shut down or sleeps I can see the router port light turn off/on.. even blink at times, but no communication (pings/webgui/ssh/tftp..)

The device is quite failsafe. Tftpd saved me a few times getting back from ddwrt.

Can you share your tftpd setup?

I downloaded the tftpd64.464.zip file from https://bitbucket.org/phjounin/tftpd64/downloads/ extracted the file and am just running the GUI - tftpd64.exe allowing it to communicate through firewall on private networks only (such as my home or work network).

Current Directory: E:\tftpd64.464
Server Interfaces: Software Loopback Interface 1

I haven't changed anything else from the default.

I just noticed that under the "Server Interfaces" I see my local machine connected to router as, perhaps I need to select that?

correct - please review the recovery instructions in the device page. You’ll likely need to set the IP address manually. localhost as listening interface won’t do it.

If the TFTPd keeps reverting back to, you'll have to put a switch between the router, and the TFTPd host.

See Tplink Archer c60 v3.0(us) Bricked

Even with a switch between router and laptop I am unable to ping or, keeps timing out. tftpd and tftp2.exe keep failing and just retrying over and over.

I held the reset button for 30 secs on the router and turned it off and on and I see the power button illuminated, the flash button, wifi 5Ghz, the port the laptop is connected too blinks, and the little up/down arrow (the up down arrows only appeared after holding reset for 30 secs and power off and on the router).

I am trying to follow the recovery steps using sysupgrade for C7 v2 via the link you provided frollic, and I tried the steps at wiki resources provided by fodiator, yet all are failing, I think its due to the fact I am not even able to establish communication from the laptop directly to the router, given that pinging expected router IP fails? also advanced IP scanner doesn't even see the device, it should show it if I scan the range?

? From Installation or restore with TFTP:

Connect one of the yellow (switch) LAN ports to a machine running a TFTP-server. Configure the server machine with IP (subnetmask, 'router' option can be empty) [1]. The router will run as a TFTP client at

I have done that as well, using this link (TFTP de-brick alternative) - https://oldwiki.archive.openwrt.org/toh/tp-link/tl-wdr7500


apologize for the quality. I picked the port based on what ive seen in some other screenshots documented here - https://community.tp-link.com/en/home/forum/topic/81462?page=1

the file I am trying to use flash is from - https://www.tp-link.com/us/support/download/archer-c7/v2/#Firmware

renamed file - Archer C7(US)_V2_160719

From your link:


  • The TFTP server tab is used, not client
  • Ensure your Windows firewall is disabled :wink:

Okay I did check windows firewall and it was on, i turned it off. Appears that now I am officially seeing activity on TFTP server tab when doing the reset/recovery button sequence on my device!

I believe to have completed the following steps from this link:


TFTP de-brick Alternative

  1. Use the Cut file above and rename it ArcherC7v2_tp_recovery.bin

  2. Change your Ethernet adapter to IP, subnet, gateway

  3. Download Tftpd32 by Ph. Jounin at http://tftpd32.jounin.net/tftpd32_download.html

  4. Browse to the directory that hold ArcherC7v2_tp_recovery.bin file.

  5. Choose for your "server interfaces"

  6. Choose Tftp server tap

  7. Activate TFTP Recovery press and hold WPS/Reset Button during powering on

but it was really fast, normally it says takes 3-5 minutes to flash, Should i restart the device now? I still cannot access the web-gui.. it shows it sent bytes but does this just mean it only uploaded the file?

The file transfer is fast, but the flashing will take some time (minutes). Then the router should reboot with the new firmware. If it transfers the file but does not flash it, that means that there is a problem in the file such as incorrect country code. Stock firmware must match the two letter code (EU, US, etc.) printed on the bottom label next to the model number.

Interesting... I did download the official US version of the firmware for my device, even checked the sticker on bottom it is v2 US of AC1750 - this is the link I used and I downloaded below file, renamed it to "ArcherC7v2_tp_recovery.bin"

Does it not transfer and flash using the tftpd executable at the same time? or are there more manual steps I need to do in order to instruct the file now that its uploaded to flash the device? the router shows on tftpd that it successfully uploaded file, but no activity seen on router lights or reboot occurred afterwards.

It will transfer the whole file to RAM first. Then it does some checks on it to see if the headers, model number, and country are as expected, and if OK it will then flash it.

I have tried many firmware files renaming each to ArcherC7v2_tp_recovery.bin first. They are all uploading per what I can see in TFTPd64 messages but no further activity is done even after waiting 10 minutes after each RAM upload.

Is there another tool or method I can see why its uploading but not proceeding further?

I even tried the original Lede firmwire file I used back in 2015.. before trying to flash to ddwrt directly and got myself into this issue.

is there another app which can show more data of whats going on while connected in this fashion with ethernet with switch inbetween?

Only via serial console access.