Tplink Archer c60 v3.0(us) Bricked

hey everyone
i was using OpenWRT for a long time yesterday i did force flash the stock firmware from tplink website then my router get bricked.

now the thing is my router is not detecting by tftp server I tried all the things found on internet but nothing worked.

really till now i have spent more than 5 hours to unbrick this router.

now i came to this forum to seek some help from experts.

im on windows 11 and already tried tftpd64 by juinion and also solarwind tftp.

also tried the cross and straight ethernet cable.

already turned off the firewall.

i turned on the router by holding the reset button for 5sec nothing shows up in tftp server. is the wrong interface.

1 Like

bro already tried so many times on but didnt worked

Then perhaps you should have written it, bro.

1 Like

i select and whenever i turned on the router by holding the reset button it automatically switch to

You may need a switch between them, so that your Ethernet connection does not drop when the device is powered on/internal switch resets.

You'll have to change it to the correct one.

but on ethernet adapter, it shows unidentified network continuously

  • I'm not sure if you're agreeing or...?
  • Looked at the traffic with Wireshark?

this is what wireshark shows when i turn on my router
sorry bro im completely noob to this thing

can you please "You may need a switch between them" explain i didnt get this point

You my need this between the TP-Link and Dell:

Ohh I have to buy one I don’t have this ethernet switch.

thanks bro
today i bought the ethernet switch and now my router is detecting by tftp and tftp sent the firmware to router but on router nothing happened it stays on just the power light on

Use " only one direct " cable between computer & router

tftp64 is automatic with tp_recovery.bin in tftp64 folder

Is you problem solved?


Are you saying the Wiki is incorrect?

Extract : Archer C60(US)

Edit : file name is tp_recovery.bin

thanks man.
i was flashing the eu firmware in us router thats why it wasnt booting

i flashed the us firmware it booted successfully.

ethernet switch solved my problem.

1 Like

If the tftp succeeded completely is already a good sign, meaning that the bootloader is still mostly intact and both requests the (push-button) tftp transfer and accepts it, not flashing the image can have two reasons (well, one, caused by different circumstances):

  • the bootloader not recognizing the uploaded image as valid
    • be it because of the wrong (and/or region-coded) image being uploaded
      • use the right image, done
    • or because the ubootenv settings telling the bootloader what h/w IDs and region codes to accept have been clobbered somehow
      • this is harder to fix, as you will need at least serial console access to read/ write u-bootenv variables (if the installed system can't boot anymore)
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.