Device disconnecting every few seconds

Hello, I'm having an issue with two Android devices. One is a tablet, running Lineage OS 14.

My Router is a TP-Link Archer C6 v2 (EU), running on OpenWRT since 2019 and up to 2021.02. The issue hasn't changed despite the firmware updates.

Now, every time I go into System Settings from the Android tablet, and I click ok "Connect" to the WiFi Network, I get this in OpenWrt's logfile:

Fri Oct 22 23:30:00 2021 hostapd: wlan1: STA b0:df:3a:88:e9:d4 IEEE 802.11: authenticated
Fri Oct 22 23:30:00 2021 hostapd: wlan1: STA b0:df:3a:88:e9:d4 IEEE 802.11: associated (aid 2)
Fri Oct 22 23:30:00 2021 daemon.notice hostapd: wlan1: AP-STA-CONNECTED b0:df:3a:88:e9:d4
Fri Oct 22 23:30:00 2021 hostapd: wlan1: STA b0:df:3a:88:e9:d4 WPA: pairwise key handshake completed (RSN)
Fri Oct 22 23:30:40 2021 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED b0:df:3a:88:e9:d4
Fri Oct 22 23:30:40 2021 hostapd: wlan1: STA b0:df:3a:88:e9:d4 IEEE 802.11: disassociated
Fri Oct 22 23:30:40 2021 hostapd: wlan1: STA b0:df:3a:88:e9:d4 IEEE 802.11: disassociated
Fri Oct 22 23:30:41 2021 hostapd: wlan1: STA b0:df:3a:88:e9:d4 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

And the tablet is kicked out of the network after about 30-45 seconds. it stays offline until I go into settings and re-connect again.

I have already tried adding

        option disassoc_low_ack '0'
        option skip_inactivity_poll '1'

to /etc/config/wireless's wifi-iface, but it made no difference.

Also, I'm having another issue where an Android TV gets disconnected after a few minutes after it goes in standby mode, which didn't happen before switcing to OpenWRT from the stock router firmware. Again, I have to manually go into the TV's settings and click "connect to WiFi" before it goes back online.

Any suggestions?

Thank you so much!

Did you enable 802.11r fast transition? For me that caused issued like that.

1 Like

Hey, thanks for the quick reply! I just checked but no, unfortunately fast transition is not enabled, so I guess the cause must be something else...

I just recently solved this issue by putting the device on its own 2.4 Ghz guest network.

It had the same issue running on a 5 Ghz guest network with two other devices.

The other devices had no issues.

Running an Archer C7 v2 with 19.07.8

Seems to show up quite a bit on TP-Link devices.


It seems there are lots of problems reported on this forum with such devices.

I take it that you have set the country code and tried experimenting with different channel widths?

You could also try latest snapshot to see if that helps.

The RT3200 is WiFi 6 and only £80 on Amazon now. Its WiFi is 100% stable for me (and many other users), it supports 160Mhz width on 5Ghz, has fast processor and lots of ram. Just thought I'd point that out! It was also ultra stress tested with many client devices and it survived that. I will try to find the post on that.

You're starting to look like a shill for Belkin.

Has nothing to do with the OP's question.

You're such a grumpy guy. Just trying to be helpful.

Just stay on topic.


You too Jim. Cheers.

So back to topic - @mind-overflow did you try country code / latest snapshot as I suggested? It seems WiFi on your particular device may not be very well supported on OpenWrt.

Hey everyone! Thanks for all the helpful messages.

@Lynx thanks for the suggestion, but that router costs 3x the Archer C6 that I have and atm I do not need to upgrade. I will totally consider that make in the future however, if it has good compatibility with OpenWRT :slight_smile: . Even though, before buying this router, I specifically searched for it on OpenWRT's website/forum and didn't found particular issues. Guess I was a bit unlucky.

Anyway, @OldNavyGuy , I did what you said and it actually works! I created another 2.4GHz-only network and both the tablet and the Android TV do not lose connection anymore. And now the question is - do we know why this happens? This is a good workaround; isn't it possible to fix the main issue since we know where to look?

Also, yes; I tried experimenting with different channels, channel widths, country codes (both my country's, the default and the global ones)... Without any difference. The only thing that made a difference was a separate network.

Thanks again! This does not feel definitive, but at least it works :smiley:

1 Like

Don't generalize based on the manufacturer, the individual model (often down to the hardware revision) matters when it comes to supportability.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.