Belkin RT3200/Linksys E8450 WiFi AX discussion

Hello you are a wan gigabit ? Can you test sqm with pièce of cake and fq codel with simplest qos please :ok_hand:
Thanks

I have too belkin rt3200 but not fiber

And post youre result of the dslreports

I dont have gigabit internet service, I checked by downloading from a local server on my network through the test router.

2 Likes

I am wondering wether the use of proper antennas could increase the reach of the router?
The router works very good, but 5g signal is only usable in the same room of my apartment ...

compared to Xiaomi R3P (mt7615) and Tplink C2600 (Ath10k) the speed is much better but range is much less.

It was an auction for a single device.

That seems lower than I would have expected - my CPU usage hasn't peaked past 20% regardless of network throughput (on LAN + WAN).

Edit: At 300Mbit on WAN with CAKE, I'm seeing ~35% usage on core 1 and <5% on core 2. I'm guessing this is because this doesn't scale linearly?

I am using SQM without any offloading. 600Mbit is pretty good.

I measured the idle power usage to be 5w as well, which is pretty good.

2 Likes

You can't buy the perfect router, because it doesn't exi.s.t... :point_down:t6:

2 Likes

I've noticed this too, wifi speed (5ghz) drops off very quickly with distance. Could be that the antennas are just not very good.

Funny you should say that - I just tore this thing down today to see whether there are opportunities for upgrades.

I don't know much about antennas but they look like cheap laptop ones. I think there's a potential pandemic weekend project here!

Now I just need to work out what connector that is - looks like MHF4 or maybe U.FL?

2 Likes

It's U.FL. The limited range may well be also a driver-related problem, I think @aparcar tried swapping the antennas and didn't see a big improvement afair.

2 Likes

I'll take your word for it on the connection type :+1:

Without going too off topic, my goal is to reduce short range, lie of sight, jitter (for VR streaming). No idea if an upgraded antenna would help but a fun side project either way!

On a unrelated note - it looks like HE160 is working on the latest snapshot! Takes a while to start transmitting after changing htmode so may have been working in earlier releases also.

Link speeds are as expected (1.2Gbit - 2Gbit+) with the only issue being signal and noise detection not working.

$ iw dev wlan1 station dump | grep signal:
signal:         17 [-48, -56, 17, 17] dBm
signal:         17 [-50, -62, 17, 17] dBm
signal:         17 [-44, -46, 17, 17] dBm
signal:         17 [-45, -47, 17, 17] dBm
signal:         17 [-57, -54, 17, 17] dBm

1 Like

In the terms of wifi coverage, the logic say's that bigger or more antennas means better coverage. Also many manufactures home wifi routers are looking like hedgehogs, but in same time their mesh devices and access points doesn't have external antennas at all. Seems, that manufactures are pushing users to use mesh systems, as I have lately tested Huawei AX3 and Asus RT-AX55 wifi6 routers, but despite their big antennas, the coverage was very bad, in the area, where TP-Link C80 (4 external antennas) and Mikrotik cAP (small internal antennas) had full bars, Huawei and Asus lost signal completely.

So I guess, that with bad hardware, external antennas won't help much, if at all?

1 Like

Hello, im new to openwrt, i just bought the e8450 as it says on the device page thats its a supported wifi ax router.
I do understand that its a work in progress and certain risks are involed in flashing aftermarket firmware.
I folloiwed the easy install instructions and compiled my own firmware using the script.. very easy and worked fine, but wifi ax wasnt working so i decided a day or so later to update via auc. the first couple of updates worked fine but one totaly bricked the device, I did try recovery mode but it seemed to have no affect. short of taking it apart and flashing a new firmware directly i didnt know what to do, so i just got replacment router as its was only a few days old.
With the new router i just used the pre generated images, but needed to chance another sysupgrade as my internet is ipv4 over ipv6 so i needed an extra package that required the lastest snapshot kernel to install all went well but ipv6 paassthrough seems to be broken in the current build im using but worked previously ,so id like to upgrade in a day or so to see if its fixed.

Sorry for the long post, my question is does sysupgrade update uboot? ive seen a patch or 2 in the last couple of days that adresses a partion being erased perhaps that was my issue.

Is recovery mode broken on this device in any builds? and is it possible to update the recovery partiton to one that works to avoid a difficult recovery in the furture?

1 Like

OpenWrt does not update bootloaders, nor do official OpenWrt images contain bootloader code. And sysupgrade certainly doesn't do that either.

1 Like

check this that first intstall recovery install firmware upgrade then always ubi sysupgrade.itb

https://forum.openwrt.org/t/how-to-update-kernel-ubi-image-rt3200-belkin/93033/4

1 Like

auc should request the correct image (ie. -ubi variant). It more sounds like the sysupgrade broke UBI somehow, which is very odd (and hence recovery image would also gets corrupted). I'm using auc myself on that device almost daily for more than a month now and didn't encounter that problem. However, I've heard a similar story from another user before.
In any case, recovery using TFTP method should still work

  1. Configure your PC to have IP address 192.168.1.254/24 on it's Ethernet interface and connect it to any of the LAN ports of the E8450.

  2. run TFTP server on your PC and provide openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb

  3. Hold down the RESET button while power on the device.

  4. Once recovery came up, use it to flash openwrt-mediatek-mt7622-linksys_e8450-squashfs-sysupgrade.bin

5 Likes

yes i'm use now only this image update

1 Like

On a general note: Please do not return devices bricked by experimental firmware to stores. This will encourage vendors to lock down things more to prevent this kind of damage. If the idea that "secure-boot leads to less RMA cases" becomes popular, we are all doomed (or at least or lives will become notably harder).
As exceptional bricks or devices with actual bad-blocks are very interesting for development (in order to prevent this thing from happening in the future), please contact me, I happily pay you a new device for you sending the bricked one to me :wink:

16 Likes

Thankyou for the reply and the tftp recovery procedure, I do feel bad about returning the router now sorry that was my bad, other people in the house needed internet fast.
It was also and expensive mistake for me if it was unrecoverable, I live in Japan and have never paid more than 40 bucks for a router, I paid 120 bucks for this one.
It does seem like a good value router tho given the internal specs.

I did try to look up recovery options but the debrick guide only had generic instructions and not device specific. I use Linux and I'm still learning, I did install a tftp server but got a little lost on how to provide the file and didn't know the IP address that the router looks for if it had a tftp client.

Thankyou so much for the tftp recovery how-to perhaps that would be good to add those instructions to the device page.

1 Like

Just a quick note about when auc bricked my device.
I ran auc from my phone over WiFi using the web interface. Perhaps the image got corrupted while uploading from the phone browser. Just a guess

1 Like