DDNS setup problem. Getting error myddns_ipv4: Service section disabled! - TERMINATE

I am trying to setup ddns with duckdns.org. So I installed ddns-scripts and make the configuration file, after that I have done the following things

sh
. /usr/lib/ddns/dynamic_dns_functions.sh # note the leading period
start_daemon_for_all_ddns_sections "wan"
exit
/usr/lib/ddns/dynamic_dns_updater.sh duckdns

and I am getting an error with-->

**Mon Aug 27 02:21:27 2018 user.warn ddns-scripts[7783]: duckdns: Updating IP at DDNS provider failed - starting retry 6/0
Mon Aug 27 02:21:29 2018 user.err ddns-scripts[7783]: duckdns: No or private or invalid IP '10.12.42.37' given! Please check your configuration
Mon Aug 27 02:21:30 2018 user.err ddns-scripts[7783]: duckdns: No update send to DDNS Provider
Mon Aug 27 02:24:17 2018 user.notice ddns-scripts[24385]: myddns_ipv4: PID '24385' started at 2018-08-27 02:24
Mon Aug 27 02:24:23 2018 user.warn ddns-scripts[24385]: myddns_ipv4: Service section disabled! - TERMINATE
Mon Aug 27 02:24:23 2018 user.warn ddns-scripts[24385]: myddns_ipv4: PID '24385' exit WITH ERROR '1' at 2018-08-27 02:24
Mon Aug 27 02:27:34 2018 user.notice ddns-scripts[25817]: myddns_ipv6: PID '25817' started at 2018-08-27 02:27
Mon Aug 27 02:27:34 2018 user.notice ddns-scripts[25816]: myddns_ipv4: PID '25816' started at 2018-08-27 02:27
Mon Aug 27 02:27:44 2018 user.warn ddns-scripts[25817]: myddns_ipv6: Service section disabled! - TERMINATE
Mon Aug 27 02:27:45 2018 user.warn ddns-scripts[25817]: myddns_ipv6: PID '25817' exit WITH ERROR '1' at 2018-08-27 02:27
Mon Aug 27 02:27:46 2018 user.warn ddns-scripts[25816]: myddns_ipv4: Service section disabled! - TERMINATE
Mon Aug 27 02:27:46 2018 user.warn ddns-scripts[25816]: myddns_ipv4: PID '25816' exit WITH ERROR '1' at 2018-08-27 02:27**

I have no idea how to troubleshoot this problem please help me.

I'm somewhat lost...a default config file is created upon installation. You would edit the file at /etc/config/ddns

I have no clue what this is. You do not run the files directly. OpenWrt uses a Unified Command Interface (UCI). This is also exposed in the LuCI web GUI if you install luci-app-ddns.

See:

https://openwrt.org/docs/guide-user/services/ddns/duckdns
https://openwrt.org/docs/guide-user/base-system/uci

https://openwrt.org/docs/guide-user/base-system/ddns
https://openwrt.org/docs/guide-user/services/ddns/client
https://openwrt.org/docs/guide-user/services/ddns/client-tomerge

I have no space left in my device to install a new package. So is there any way to clean it?

and I have a doubt. This line

_ option update_url 'http://www.duckdns.org/update?domains=[USERNAME]&token=[PASSWORD]&ip=[IP]'_
there is IP thing it's fetching my local ip 10.12.42.37 is there any way to deal with this like--->
        option ip_source       "interface"
        option ip_interface    "eth0.1"
        option ip_source       "web"
        option ip_url          "http://ipv4.wtfismyip.com/text"

Please format your posts using the </> button.

  • Is your WAN IP 10.12.42.37?

If so, using a DDNS alone will not get you inbound services.

You can use a HTTP URL to get the WAN IP.

This should work.

Hello all,

I am having a similar error output:

225419       : ************ ************** ************** **************
 225419  note : PID '19046' started at 2022-01-25 22:54
 225419       : ddns version  : 2.8.2-12
 225419       : uci configuration:
ddns.myddns_ipv4.domain='ddns.net'
ddns.myddns_ipv4.interface='wan'
ddns.myddns_ipv4.ip_network='wan'
ddns.myddns_ipv4.ip_source='network'
ddns.myddns_ipv4.lookup_host='jair'
ddns.myddns_ipv4.password='***PW***'
ddns.myddns_ipv4.service_name='noip.com'
ddns.myddns_ipv4.username='jair'
ddns.myddns_ipv4=service
 225419       : verbose mode  : 0 - run normal, NO console output
 225419  WARN : Service section disabled! - TERMINATE
 225419  WARN : PID '19046' exit WITH ERROR '1' at 2022-01-25 22:54

I am not sure what should I put in the configuration file to enable the service?

My dynamic dns server provider is no-ip.com or noip.com based on the OpenWRT documentation: https://openwrt.org/docs/guide-user/services/ddns/client seems like I should use either no-ip.com or noip.com

And my current interfaces are labeled as such:

Any advise will be greatly appreciated.

Sincerely,

fwiw, I don't use no-ip any more because their free accounts require you to log in once a month to keep it active.

Have you installed the 'additional' package specifically for no-ip?
It is called either:

ddns-scripts-noip - I think this is the new package name.
ddns-scripts_no-ip_com - old package name.

fwiw, you could check DDNS is woking with duckdns.org, which is free?
https://forum.openwrt.org/t/i-want-to-set-ddns-using-duck-dns/108560

Hello @bill888 ,

Thank you for the suggestions, I re-installed OpenWRT and I believe those packages highlighted are the ones I need for OpenWRT and service noip.com to function.

If that is not accurate please let me know.

Thanks in advance for any help,

I am wondering if all I need is to add this line marked below:

# /etc/config/ddns
config 'service' 'myddns'
	option 'service_name'	'example.org'
	option 'enabled'	'1' <<<<<< Maybe all I need is this?
	option 'domain'		'yourhost.example.org'
	option 'username'	'your_username'
	option 'password'	'your_password'
	option 'interface'	'wan'
	option 'ip_source'	'network'
	option 'ip_network'	'wan'

Yes, the option 'enabled' '1' is required to activate it.

It can be managed using LuCI if you have installed luci-app-ddns package
https://openwrt.org/docs/guide-user/services/ddns/client#web_interface_instructions

1 Like

Hello @bill888 ,

That helped! and it seems to be working at least for IPv4, so it is a bit of progress.

config service 'myddns_ipv4'
	option enabled '1'
	option lookup_host 'myhost.ddns.net'
	option use_ipv6 '0'
	option service_name 'no-ip.com'
	option domain 'myhost.ddns.net'
	option username 'myusername'
	option password '***pw***'
	option ip_source 'network'
	option ip_network 'wan'
	option interface 'wan'
	option use_syslog '2'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'

NOTE: I replaced some sensitive information with examples.

And in Luci:

This is good to resolve for now. I need to get IPv6 working on my upstream interface, then I will try to configure IPv6 for high availability and backward compatibility between IPv4 and IPv6.

Thank you so very much!

This works on 21.02.1:

config service 'xxx'                           
        option enabled '1'                     
        option domain 'xxx.ddns.net'
        option username 'yyyyyyyyy'                  
        option password 'SeCrEtPaSsWoRd'           
        option ip_source 'network'           
        option interface 'wan'                      
        option ip_network 'wan'                
        option use_syslog '2'                
        option use_logfile '1'                      
        option service_name 'no-ip.com'             
        option lookup_host 'xxx.ddns.net'

Hope this helps.

1 Like

Hello @lleachii ,

Right that is the exact configuration Luci creates after installing the package @bill888 recommended.

So far, so good all, thank you very much @bill888 again!

IPv6 is next!

IPv6 and no-ip is still… braindead, e.g. no way (I know of) to set AAAA records only (as necessary on cgNAT+IPv6).

Technically, IPv6 was desgined to use a static IP per service by DDNS...as an IPv6 address also relates to the service/server.

Nontheless, they offer DDNS for AAAA, see: https://www.noip.com/blog/2019/11/03/ip-now-offers-ipv6-dynamic-dns/

...but for IPv6, you'd have to run the client on the server.

There are still plenty of consumer ISPs out there that will assign dynamic IPv6 prefixes, guaranteed to change after each new dialup (or every 24h) - so ddns is sadly also useful for IPv6 (e.g. wireguard endpoint).

no-ip offers AAAA records for about a year now, but whatever I've tried, I haven't found any way to set AAAA records only - instead no-ip also sets A records at the same time (which is utterly useless and even harmful with cgNAT for IPv4).

I've sorted this by not using no-ip, but it's still unsolved for no-ip.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.