Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Quick update: popped the latest Lede snapshot on my WRT32X

  • set a password
  • changed the LAN NIC to
  • turned off DHCP on LAN (I run my own DHCP and DNS on a server on the LAN)
  • connected cable modem to WAN and confirmed ISP DHCP lease
  • brought up a 2.4GHz radio with WPA2/PSK

All my clients immediately connected to the wifi and Internet connectivity appeared to be fine, but slowly I noticed the same problems return. The Amazon Echos stopped playing radio and became unresponsive. Stations seemed to be disconnecting "due to inactivity" very quickly.

I'm going to try and reset it to defaults at some point over the weekend and run it with to see if that's any better. FWIW, I put the old Airport Extreme back in and everything started working fine again.


Ensure you are following IETF for IPv4 address ranges for private networks or you will likely run into issues.


I admit to being new to OpenWrt, but I've used DD-WRT for a long time and recently decided to switch, so I have some familiarity with custom firmware on my Linksys WRT1900ACS. I just installed your build and have everything working except for a VPN tunnel. Before I start that project, have you included a package so that I can do policy based routing and only send the machines I want through the tunnel and everything else through the WAN? If not, is vpn-policy-based-routing on github (https://github.com/stangri/openwrt_packages/tree/master/vpn-policy-routing/files) a good choice?


It doesn't appear to be a part of the repo yet. However! Please take a look at the following discussion --

@WiteWulf this is very disheartening. Now I'm wondering if there is a widespread latency problem with the WRT3200ACM / WRT32X in OpenWrt 18.06 and Master. Your latency results much worse than even the R7800 used to have. Could you give us an overview of how you're running that test?

The R7800 was almost this bad for a while, but through patches and kernel 4.14 was mostly fixed:

DSA is possible for the WRT series as the kernel has it enabled for the Turris Omnia.

Requires a custom build with the default network config reworked. I can whip up a patch if interested.

Do note WAN to LAN traffic will get limited to ~500mbps. Part of the problem with having only 1 CPU port enabled.

1 Like

Hi Phinn, it's using a tool called Smokeping. It's running from a server at my workplace that's on the JANET network (very high capacity, low latency academic/research network). We monitor links to a few peer academic sites, commercial service providers and other members of staff's home equipment. It's interesting to watch changes propagate through the local Virgin Media cable network as we all live relatively nearby but on different UBRs and cards.

Same here!! I missed you guys :wink:

I'm really interested in what do you consider to be the benefit of having adBlock over even a static blacklist in DnsCrypt ... let's say you build it once today in a linux machine and import it into your router. The only downside I see is that the adBlock one would update the blacklist with new blocked domains/urls . I recognize that is a problem, but in my day to day experience, having a year old blacklist would block 99.9% of the unwanted traffic anyway

Please feel free to PM me and I can send you my 1.5MB (raw) blacklist.

1 Like

The "jumbled buttons" is a known issue of the DarkMatter theme for the last couple of builds. @davidc502 is aware of the problem, but it's with the Luci folks to solve, as the darkmatter repo has not been even touched in the last 6 months. Use the "Material" one instead, it's exactly the same but grey and not black :slight_smile:

I have sent an email to pr@apollo.open-resource.org requesting assistance to fix the fairly popular DarkMatter theme.

It is unknown if the group is even active anymore.

EDIT I see in the download stats that nearly every day people are downloading the DarkMatter theme.

Build: r7210

Does "Enabling upnp functionality" from LuCi, need any other action ? It seems to have broken the internet connection from the lan.

Ok, I am getting a bit confused here. I have 2 machine wired to the router, and the one I am currently on doesn't want to connect to the router, but has now internet connection. The other one is happily connecting to the router, but without internet connection. Mind that I have not changed the default lan settings and I am only trying to get my Plex server to get accessible from outside.

I have tried to set static route, but that broke the internet connection. I have tried upnp, but the result seems to be equally unsatisfying. :expressionless:

Thanks David. It's a great theme, although personally, I typically disable Web interface when not needed... BUT, that doesn't mean I still don't like to be wow'd when I do need to do web gui stuff:)

Why doesn't LEDE team just adopt it as primary, it blows dd-wrt theme out of the water (or any router theme for that matter)

I removed it completely from my build, it's really not needed anymore is it? And isn't it a security vulnerability?

Security vulnerability?!?!

I guess that @cantenna is refering to UPnP having a bad rep for allowing ports throught without much control, as opposed to static routes+port forwarding.

1 Like

Still having latency and disconnect issues here. I tried putting the stock Linkys firmware back on the device to see how I fared and things still weren't great. Here's another screen grab of my smokeping test over the last couple of days. The high jitter and latency to the left is with the stock linksys firmware (and is pretty much identical to the performance I was seeing with Lede 18.06 snapshot), the smooth line to the right is with my Airport Extreme connected:

Smokeping tests gives you an indication of latency, jitter an packet loss by pinging your device 20 times every 5 minutes and displaying this using the black->grey part for ping times and the coloured plots for packet loss. The server running the test is on a 20Gb/s connection at my work place. I appreciate there's a lot more going on under the hood on an openwrt box than on an Airport Extreme, but I'd expect ICMP to be prioritised and it not to be a huge burden on the system as it's only receiving 56 bytes every 300s :thinking:

While running the linksys firmware (which, incidentally, identifies itself as the bleeding edge "Designated Driver" openwrt build, for those that didn't know) I also ran into problems again with my Amazon Echo disconnecting and refusing to reconnect to either the 2.4GHz or 5GHz radios. I couldn't even see the device attempting to connect in the logs. I appreciate this isn't a forum for Linksys firmware support but thought I'd mention it as part of my overall woes (it's good to share, apparently :grin:).

FYI, during this testing I was still attempting to run with DHCP and DNS provided by my linux server on the LAN and the router LAN NIC changed from to

To "disable" dhcp on the WRT32X I changed the DHCP range to two addresses and created fake reservations for them (which is the same way I disable DHCP on my Airport Extreme).

On Tuesday I'll have more time to devote to this so will attempt to go back to a Lede snapshot, properly shutdown my LAN DHCP and DNS and run everything on the default range and see if that works any better. It's not a solution for me, but should help track the problems.


@WiteWulf -
how about using your apple airport as the wireless acces point, and the wrt32x iwth lede as your gateway?
then you could isolate the issue to the wireless part of the wrt32x, and retain the advantages of lede for management and routing.

i have used this solution in challenging wireless environements because airports have great radios; (i place them in their create/extend network modes for may main access points that span a large spatieal area with lots of radio obstacles and no good wired pathway)

This seems like a huge find and reminiscent of the R7800 latency issues that were fixed in the thread I linked above. Your settings seem unconventional, but this is something that should be investigated. You should post a bug report to OpenWrt and post on Linksys' forums for support too, as this wouldn't be davidc502 build specific. Clearly the WRT series has a long way to go.

The irony here is that the WRT32X is actually advertised to reduce latency provided you set priorities and have Killer NIC (who actually has these cards I have no idea most people use the one built into their motherboards).

Interesting report ... From just looking at this, and your advanced knowledge and refined wording as an indication of a professionalism and knowledge of what you're doing here ... it just looks that the OLD Airport is just a better router to do ICMP than the WRT :slight_smile:

Indeed, this a 4th gen box (same form factor as an iMac) and it's been performing admirably for me for the past 7 or 8 years. It's a move to a bigger house that it can't quite cover, a desire for better firewall and IPv6 handling and upgraded broadband (we're on 220Mb/s now which the Airport doesn't seem to be able to saturate) that's prompted an upgrade.