Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

It is rather ironic, isn't it! I didn't buy the device for it's "killer" features, but as a cheap way to get the WRT3200ACM hardware (which I believe this is almost identical to internally). I didn't, however, expect my ping times to be so negatively affected, though. Apparently the "killer" stuff is basically just a QoS script in the box reacting to DSCP packet markings from the drivers on the "killer" branded NICs. I'm sure the client side of things could be easily hacked together with some wiresharking of a "real" killer NIC :rofl:

Afaik the hardware is 100% identical to the WRT3200ACM... Just a different flash chip ?
Btw, i never had any ping time problems with my WRT3200ACM but i'm still using build 7093 but i've noticed that the Wifi pingtimes are always 1-2ms higher compared to my DIR-860L and other Wifi hardware, but stable. I think that could be a typical marvel thing...

As far as my understanding, the wrt32x is the exact same hardware as version 2 of the 3200acm, just adding dfferent case color and the killer software on top. Both are said to have new proprietary closed source wifi driver parts that confirm to legislatory needs of untamperability (preventing manipulation of wifi sending power)

v1 of 3200acm was said to be sold until ~mid 2017, having fully opensourced drivers and is said to have different flash chip and according to the device pages, it seems to, it has little bit smaller firmware partition layout.

I own the 32x as well since a few days, got a cheap deal, but have not yet found the time to put Openwrt on it, needing it while still busy configuring v18.06rc1 on my 860l-b1.

May I ask for a short scenario description of your wrt32x ping problem, are you pinging from a Wifi client to an Internet server?

It's working well for me; in fact I added the vpn-policy-routing package and it's also worked well.

However, I'd like to use DNSCrypt-Proxy to send DNS requests over HTTPS to cloudflare. Unfortunately, cloudflare isn't offered as a Resolver despite being on the server list at https://dnscrypt.info/public-servers/ I've "Refresh List" in the General Options but cloudflare still isn't there. Any thoughts on how I can address this?


Sure, I'm pinging from an internet server to the WAN interface on the wrt32x. As I mentioned earlier, I'm using a tool called smokeping which sends 20 pings every 5 minutes and shows the maximum, minimum and average values with the black/grey plot and any packet loss as the coloured plot. The server running the test is part of the monitoring infrastructure at my work place and is used to chart ping times to a number of partner institutions, service providers and staff's home equipment.

Oops, actually ignore my last message. I found https://davidc502sis.dynamic-dns.net/dnscrypt/ and realized I had to install dnscrypt-proxy 2. Now I have DNS-over-HTTPS with cloudflare. However there is no GUI in Luci for it. How do I install that?

Yeah, currently there isn't a app specifically for dnscrypt-proxy Version 2. Unknown if someone is currently working on one, though I've heard there are others using the Version 1 app to manage Version 2's configuration file.

BTW -- I'm glad to hear that vpn-policy-routing is working.

Are you fully saturating the wrt32x WAN port with incoming or outgoing traffic while the high pings appear?

Dear Dave,
Hello for your r7210 Build I was finally able to get it up and running. The problem was evidently due to my flashing r7210 from Linksys Stock. As I had described when I set static IP on Lan other than ( default router address ) I would lose internet connection all together.
As many of the areas were greyed out or non-existent in Luci ( firewall zones, dropbear, network bridged interfaces and more ) I figured that something was awry with config files. I believe that is /etc/config/system and all the other associated files of that type and nature.
So I followed this guide : https://wiki.openwrt.org/doc/howto/generic.backup after installing r7093 with minimal configuration. Go to bottom of page for specific instructions. Look for Backup OpenWrt configuration
and then for when you are on r7210 - Restore OpenWrt configuration
Minimal settings included Network / wireless settings / dropbear change port / - domain - I left out anything beyond that.
I took the backup while on r7093 from web gui - Luci .Next, I went back to Linksys stock and then I installed r7210. To be sure everything went smoothly when restoring backup - I installed tar. opkg update / opkg install tar.
Then I restored backup and everything worked as desired and expected. From there I finished configuring r7210 on my WRT1900ACS. By the way Dave - in the header you list WRT1900ac Version 1 and 2 twice.
You do not mention that you also support the WRT1900ACS Version 1 and 2.
I just bring that to your attention so that 1900ACS folks will be able to use your great OpenWrt / Lede firmware.
For others who may have had similar issues with r7210 - this is one method to work around that. Hopefully, Dave you consider my feedback as being useful in your future builds.
Thanks for all you do for the entire community now and always.
In Peace and God's Grace,


@Kherby yes the WRT3200ACM and WRT32X are nearly identical for hardware. Basically just a different case and different web UI. Now that they are both supported by OpenWrt if you run that there is really no functional difference.

This possible latency issue is worrisome though. Hope he gets to the bottom of it, going to start running my own tests. I have a feeling there is a deeper issue here with this platform, perhaps even with Linksys firmware. People barely talk about performance on OpenWrt, just features I don't need, what I care about is performance.

Good info just in case we run into this again -- Thanks

" in the header you list WRT1900ac Version 1 and 2 twice." Sorry, what are you referring to here? URL?

1 Like

No, that's with the WAN connection idling or, at worst, with a 320kb/s radio stream running in the background.

Ping times do get noticeably worse when I'm saturating the WAN link as I'm on a Virgin Media cable modem connection. For some reason Virgin don't provide the recommended minimum 10% of upstream as downstream. My downstream is 220Mb/s and I only get 12.7Mb/s up, which can lead to very poor performance when the downstream is saturated.

1 Like

About you external drive question.
I use external HDD all the time, so yes, it have automount (i'm also mount one of the partitions as a swap as well).
The speed and response are WAY better then use eSATA, in compare with USB3 connection. low-level give all HDD apeed (106mb/s in my case), and Samba gives up to 90MB/s on read. Well, i wish to try to use SSD one time to see the real limit.
I use combined eSATA/USB power cable (it's supported by port), so i recommend to buy it.

1 Like

Are you running the Super Hub 3 by any chance?


Yes I am! In modem mode, obviously. I'm aware of the issues some users have with these devices in router/AP mode, but as you can see, the issues only appear to manifest when the WRT32X is in use, not with the Airport.

Is there some weird interaction between the linksys hardware and the modem? :thinking:

Done and done:

1 Like


Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds
Community Builds, Projects & Packages

This thread is dedicated thread for davidc502 builds. Please ask questions related to the builds here. However, keep in mind, if your question is not answered to your satisfaction in this thread, feel free to post your question in the "Installing and Using Lead" forum as there is usually a much larger audience of experts who can help.

Current images built and distributed.

WRT1200ac Version 1 and 2
WRT1900ac Version 1 and 2
WRT1900ac Version 1 and 2
WRT3200acm Version 1
WRT32X Version 1

Website: https://davidc502sis.dynamic-dns.net/ 79

I feel the focus of these builds are for beginners to intermediate users as they provide some of the more popular applications found without being too bogged down. If you have an idea of an improvement, let me know as your thoughts are always welcome.

If you have a question, but don't want to post it in this thread, send me a private message, and I'll respond as soon as I can.

Best Regards,


1 Like

Thank you! I have corrected the 1st post in this thread.

Best Regards,

I don't know anything specific regarding the WRT32X and the SH3. I just wasn't aware you know about the issue with it even in modem mode with erratic pings even directly pinging the modem locally.

Sorry staying off topic one more post. This may close the loop on this latency issue. Are the links below the possible cause of @WiteWulf issue and not the WRT32X?