Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#21

Running some good old WAN speed tests on r7210 - and its still maxing out the Gb connection nicely :slight_smile:


#22

That's fair enough. :slight_smile: I have just started using a router with your build and I was pocking around. Hence the noobsih question. :wink:


#23

This build ( r7210 ) seems buggy - no offense meant or intended - Interfaces > Lan Advanced > Bridged to Interfaces is Greyed Out as with dropbear - so are firewall settings - I am just reporting

Dear Dave Hello and I hope that you have been well.
On r7210 - when I set a static IP Address on the router - the internet connection dies - the router will not resolve internet addresses. However, I am just offering feedback. I really do appreciate all your hard work and assistance. I know that it is a labor of love but I know it isn't easy either.
The last few build have been rock solid. I only tested r7210 on a pair of WRT3200ACM routers.
Also how does one go about setting up wireless on the latest build?
Any feedback regarding these issues will be appreciated. Again - thanks Dave Sincerely

Peace,

directnupe

PS - I just tried r7210 and my WRT1200AC V1 and the same issue persisted. When I set new static IP address on Lan the router become where it refused internet connections. I do not know if anyone else is experiencing this as well. If there is a fix - I am all ears. Again - I am just reporting my experience.


#24

Hi all,
Glad to see this thread back.
Im using Lede SNAPSHOT, r5917-36f1978a70 on my wrt3200ac and tried to install luarocks but I receive a dependence error related to unzip:
Can I solve this conflict without reinstall a new rom version (I read I could use ---force-overwrite with opkg but Im afraid to break things).

Thanks

Collected errors:

  • check_data_file_clashes: Package unzip wants to install file /usr/bin/unzip
    But that file is already provided by package * busybox
  • opkg_install_cmd: Cannot install package luarocks.

#26

The reason is simple: to offload some of en/decrypt operations to hardware crypto engine, e.g. OpenVPN


#27

Fixed it with a settings reinstall via a backup I had saved.


#28

Awesome!, so just do those few things you mentioned in your previous post and bobs your uncle? Thanks man!! Do you have any other tips ?:smirk:


#29

Does the hardware support it? If so, just so I can make this distinction in the future, how did you find out/where did you look to discover that?

Thanks in advance!


#30

I will take a look at enabling these, and test. Seems as though I've played around with this before and it did nothing... It's been a while, so probably worth looking at again.

Thanks,


#31

Of course it does, see Marvell ARMADA 38x Technical Product Brief
The driver (mv_cesa) is already included in Linux kernel


#32

I seem to remember davidc502 builds have automount for storage. Can anyone comment on USB 3.0 storage with the WRT3200ACM / WRT32X? Would eSATA be preferred? Performance tests show extremely fast in reviews (around 100MB/s rw) on OEM firmware faster than many NAS boxes. I'm in the process of setting up a drive for the network with davidc502 build. Any notes or tips on the setup? Thanks.


#33

Very cool. I enabled those in my own build and flashed a little bit ago and have not had any issues so far.


#34

CONFIG_OPENSSL_ENGINE_CRYPTO=y
CONFIG_OPENSSL_HARDWARE_SUPPORT=y

I just checked, and both are already selected "y".


#36

@directnupe - Like you, I experienced the same issue when I upgraded my firmware last week. I ended up having to revert back to my last flash of Lede SNAPSHOT r6868-dc629d9cf5 / LuCI Master (git-18.129.69108-658b6d7) .

When this happened to me, I experienced the exact same problem you have described when trying to set my LAN network to any subnet other than 192.168.1.1. The router became very unstable and the only way I could get it back was to power cycle the router which would then allow me to return to the default 192.168.1.1 address.

I also noticed that when I visited the startup page, the interface appeared to be jumbled with buttons stacked on top of each other instead of being horizontal.

I am sure David is working on a fix for it.

~Tala~


#37

Hi David,
Thanks for the awesome custom firmware for Linksys wrt1200 routers. Much appreciate your work. Any chance you could integrate into itptables geop-ip block features. I would like to block nasty countries hitting the router. Hehehe.

Meanwhile keep up the great work.

Jason


#38

I have removed adblock and left all the work to the dnscrypt blacklist... easier and faster. You can compile a list of blacklisted sites that includes the ads.* sites by using the dnscrypt tools indicated in the openwrt dnscrypt guide.


#39

Hi folks, just chiming in with a "me too" on this one. Over the last few days I've tried to drop in a WRT32X running Davidc502's latest build (7210) as replacement for an ageing Airport Extreme. My LAN is all configured on 10.0.0.0/24 and so I reconfigured openwrt to have 10.0.0.1 on it's LAN interface. I had a lot of problems, which I'll outline below, and eventually switched back to the Airport Extreme (we have a lot of IoT devices and pressure was mounting from my other half and son! :slight_smile: ). Everything is running smoothly again now.

FYI, I ran the WRT32X with the stock firmware for a few days before installing OpenWrt and that worked perfectly on 10.0.0.0/24

Issues experienced:

  • Amazon Echo and Dots constantly disconnecting (red ring) and unable to playback radio streams for more than 2 or 3 minutes at a time
  • Logitech Harmony Hubs unable to connect to Internet (although connected to WiFi)
  • I think devices with IPv6 are routing out to the Internet okay, but IPv4 only devices aren't (need to investigate further)
  • looking at router logs, many stations frequently disassociating due to inactivity timeouts, after only seconds connected (notably a Macbook Pro and iPad connected to the 5GHz radio)
  • some DHCP clients not completing lease requests (seeing discover and offer, but no request or ack)
  • unable to change country code for radios from FR to GB
  • ping times, jitter and latency where pretty poor on lede, smokeping chart below makes it obvious where I reverted back to my airport extreme. Avg ping time decreased by around 15ms from 40ms to 25ms:
    https://www.osx.ninja/wrt32x_pings.jpg

I'm keen to get the WRT32X working properly with Lede so will continue to monitor this thread and see if there are any developments. I'm also happy to provide further configuration detail and carry out any testing or submit logs if anyone's interested in digging into it. I'm a "network professional" (CCNA, CCNA Voice) so consider myself reasonably clueful).


#40

@WiteWulf -
do the same symptoms occur with the latest snapshot lede builds?
it's easy to go back and forth from standard lede to davidc builds by flashing frrom gui.
the davidc builds use dnsrypt proxy, so you have to remove that rdns forwarding on the dns/dhcp general setup page.
or you might try removing dnscrypt redirection on davidc build to check that.

latest lede snapshot: sysupgrade image for wrt32x is at:
http://downloads.openwrt.org/releases/18.06-SNAPSHOT/targets/mvebu/cortexa9/openwrt-18.06-snapshot-r7079-2ac5800-mvebu-cortexa9-linksys-wrt32x-squashfs-sysupgrade.bin

most snapshots have worked very well for me for the last number of weeks.
my lan is 192.168.1.x, but i've experienced some dns lookup issues on the last two davidc builds that i cant put my finger on yet.

the advacned reboot / alternate image inot working. flashing from the gui always goes to the other partition.


#41

Thanks George, I wasn't aware I could install the lede snapshots once a davidc image was installed (I thought davidc's where the only ones that currently worked on the WRT32X due to different flash layout).

I'm playing catch-up here: not used openwrt since using it on a real wrt54gl back in the day!

I'll give the snapshot image a go over the weekend if I get chance. Thanks again for the advice :ok_hand:


#42

Hi Mariano, thanks for the reply to my post. It’s so good to have a home to go to for help again!

I actually did briefly look into using the method you described but it appeared to be lacking the comprehensiveness of the Adblock package that David ships with his custom build.

I was also reluctant to use this method as I am not sure how to configure the Python script side of things on my router, and from memory there did not appear to be any half decent instructions on how to do so either. I am still relatively new to the firmware so I am still getting used to things.

~Tala~