Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Thanks for reporting back... I've been a little concerned that the issue might be creeping back into the v1 series, but so far the responses have been good.

Thanks again and enjoy.


The theme is coming along nicely and I really appreciate your hard work on it. The new branding in the upper left hand corner looks good. The color really goes well with the rest of the theme too which is a bonus!

By the way, I've done a little research into the LuCi hanging issues. On this last build I tried to switch libustream-mbedssl with libustream-mbedtls, but the make menuconfig refused to cooperate and it is due to a duplicate tls module that is actually provided by both. After I compiled and sysupgraded the router I manually switched from mbedssl to mbedtls and it made absolutely zero difference in the LuCi hanging issue. Oh, almost forgot, I did add px5g-mbedtls to this latest build on the recommendation of a few people who say it should be required for LuCi to operate properly, but once again, made no difference. Anyhow, I'll keep chipping away at it, but those having the issue I've found hitting the "stop" button on the browser and then hitting refresh will take you to the last page. If you wait a few minutes the problem generally just goes away, so go figure that one as I'm stumped.

I have been also looking into the hanging issues, in uhttpd -> Advance Settings there is a check box for "!nable JSON-RPC Cross-Origin Resource Support" which is checked, i have unchecked it and restarted the uhttpd service which seems to lower the hanging but doesn't solve it completely. However what i have noticed is that its as if the CPU is peg'd doing something else and of course when i went to look at what that might be it behaves itself. However there is noting showing both in Kernel or System logs to help us either.

Right i have tried the following in uhttpd in the Advance Settings try setting the option "Maximum number of script requests" to 1, credit to @pradorocchi on pointing this one out.

It doesn’t matter if that is the solution or not because that was added to master and then reverted due to adverse effects elsewhere.

Right, can you please provide your /etc/config/wireless file (making sure you remove PSK keys and SSID's) Also profile the Kernel Log and System Log.

I am using DavidC's firmware on my WRT32x without issues on 5GHZ, the only thing i can think of is your using the 160mhz option which is known to have issues with certain devices. I will give you an example of /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option country 'GB'
	option legacy_rates '0'
	option channel '48'
	option htmode 'VHT80'
	option __toggle 'Enable'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr 'Redacted'
	option ssid 'Redacted'
	option encryption 'psk2+ccmp'
	option key 'Redacted'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11n'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option legacy_rates '1'
	option channel '10'
	option htmode 'HT40'
	option country 'GB'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr 'Redacted'
	option ssid 'Redacted'
	option encryption 'psk2'
	option key 'Redacted'

Hi. I am use OpenWrt 18.06.2 on Linksys WRT32X.
On the other partition - Linksys stock firmware. I would like to save it.
If I switch from OpenWrt to your firmware, then this action will erase the partition with the Linksys stock firmware?
So, in order to store stock firmware on one of the partitions, do I always need to follow the firmware upgrade procedure from stock firmware?
And is there a difference in this case between a ".img" upgrade and a ".bin" upgrade?

@lajkasir it's also nice to have an output for this command:

cat /dev/mtd3 | grep cert_

It will reveal what country you router really for. And you CAN'T use other country codes, except listed there.

I’m on OpenWrt right now. But I tried 160mhz it didn’t work and I also tried 80mhz, it also didnt work!

I tried
160mhz - 100 and 120 channel
80mhz - 36,40,44.

Only 2.4 ghz works.

Tried this on wrt3200 and wrt32x same issue. Only diffrence I notice between these two is country code . FR on wrt3200 and DE on wrt32x.

See Solution here: Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds - The difference between the two files are as follows:

.img - you are on Linksys OEM Firware partition and wish to install OpenWrt - this is why the .img file has factory attached to its' name

.bin - OpenWrt is currently installed on your router ( and current partition ) and you wish to upgrade /downgrade / re-install OpenWRT - this is why the bin file has sysupgrade attached to its' name

If you want to save your OpenWrt 18.06.2 configuration and packages there are scripts for that will allow you to accomplish this. I do not do this, but by Googling or asking others in this thread you can find out how.

Not really useful for those with:

root@WRT1900ACS:~# cat /dev/mtd3 | grep cert_

The EU regdomain doesn't exist. mwlwifi makes anything with the EU regdomain equal to FR. For some reason, OpenWrt sets it to DE.

In the pull request I linked, there is a patch for the WRT3200ACM (maybe even WRT32X) that solves the region mapping grief that occurs. I believe @lantis1008 uses it to legally operate their US EEPROM-coded device in Australian territory. [The patch only targets those with the Avastar 8964 AC Wave-2 chips.]

1 Like

It'd be really great if you could comply with his request and SSH into your router via puTTY or terminal and run: cat /etc/config/wireless (remember to redact macaddr and key!). Failing that, you can download a backup of your entire router configuration (via LuCI->System->Backup) and paste the contents of /etc/config/wireless (please don't upload the whole .tar.gz as that might contain sensitive informations/passwords).

Given that we've established your router was from Sweden (a country falling under ETSI regulations - and most likely country code 0x30 - EU), setting the country code to FR for both of them should have been enough. A lot of people here have a configuration that's working fine. But for us to help you, we need more information.

I did for a while, until I realised that because the wrt32x actually loads the AU (and a few other) powertables from the filesystem in the OEM firmware (that’s right, they’re not hardcoded or built into EEPROM), and mwlwifi hasn’t been built to handle that scenario, my device just works...

I should clarify that I used this patch for my US wrt3200acm, but my AU wrt32x has no need for it (as per above explanation)

That's just mad cheeky :laughing:

I've read way too much into mwlwifi's commit history and it seems like such a disaster in the very beginning. You, BrainSlayer, nbd/Felix Fietkau, and the guys from McDebian seemed to have contributed a lot in fixing it up to the mostly decent state it is in now.

Now in 2019, we've got this mess where Linksys got sold to Belkin, which subsequently got sold to Foxconn AND Marvell selling off their entire wireless division/business unit to NXP...

1 Like

A few questions.
can I switch from ddwrt to this on a wrt32x via the gui?
can I set up a repeater by making the 5g radio a client then adding a VAP with the same SSID?
If I have entware on an opt partition, does it take priority over the built in opkg command?

I just upgraded and noticed something I don't think I've seen before (though I could have just missed it). On the Overview tab, under networking I have a section called "IPv4 Upstream" with the following values:

**Protocol:**  DHCP client
**DNS 1:**
**Expires:**  23h 44m 25s
**Connected:**  0h 15m 35s

Does anyone know what this is? Is it necessary? Thanks!

It is just normal information about how the router is connected. Is it necessary to show these stats? Probably not, but doesn't hurt anything. It is good info to see at a glance.


My question is not about that.
I would like to save Linksys WRT32X firmware on the other partition always.
But this means that in order to update OpenWrt I have to switch every time to the partition with Linksys stock firmware.
Can this be somehow avoided?

1 Like

If you want to have a safety net at all times, you have to jump through the hoops.

1 Like

all of these routers that Dave supports have a rotating round robin installation process ( you will overwrite the other partition with each flash - this also applies if you do sysupgrade or install new firmware while on OpenWRT )

Blame Belkin Linksys for this reality - the short and long answer to your question is - NO!
you can not save the Linksys Partition if you do any additional installations as Linkys OEM will then will be overwritten- It is what it is Maybe you do not like the answer - but it was already answered plain as day