Daisy chained AP lost after dumb AP setup

So this are the ports on my device:
image

I added this one - by default only eth0.1 (represents LAN0 port) was present in the lan bridge and I added eth0.2 (represent LAN1 port)

I also added this one.

Does this vlan settings matter? I turned vlan off under switch in the luci interface:

image

I don't know if it will work if you disable vlans altogether. If you feel lucky try it, worst case you'll reset the device.
But leaving eth0.1 only and vlan1 in switch is totally fine.

1 Like

How did you know? :laughing: At least I have device in my hands...
So again I will reset it now because it isn't reacting on any lan ports now and I didn't configure a wifi...

So just to get it right for my next try:

To get both of the lan port into the local lan bridge I will just delete the by default present wan and wan6 interfaces (eth0.2) and then it will work? Isn't there missing one last thing I need to configure (to be "equal" to eth0.1)?

You need to assign port 4 to vlan1 as well.

I don't really get that.

I just deleted wan+wan6 (eth0.2) now and everything else (apart the IP) is "default" openwrt setting after the factory reset:

package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd30:844d:6f77::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.4.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 0t'

I prefer to have everything set up over luci actually, is there something I need/can do here?

And couldn't I bridge the interface here without "messing" with the vlan's?

Unchecking the 'enable VLAN functionality' will make the switch operate unmanaged. All the ports will be switched together and all are untagged. Which would work for your application but you'll need to change the CPU connection to the lan network from eth0.1 to eth0.

A better approach is to move the secondary external port (4) untagged into VLAN1 and remove it from VLAN2. The same as running the switch unmanaged, LAN packets on the cable will be hardware switched to the second AP. VLAN2 can still exist but with only a CPU port it can't switch anything. This does make it easier to change back to a VLAN based setup later.

What you did first (put eth0.1 and eth0.2 in the software lan bridge) also works, but packets being passed through to the second AP must be handled by the CPU, so there is a slight performance decrease.

2 Likes

Delete vlan2. WAN untagged on vlan1

2 Likes

Thank's for this explanation @mk24! It really made me understand how things work internally! This was a missing piece and will definitely help me a lot the next decades :slight_smile:

:white_check_mark: and works :tada:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Not quite yet :wink:

So a big thank's to @trendy and @mk24! I have my setup up now up and running for 5 days.

I still have a problem with resolving host names when I'm connected to the access points. I actually have setup the dumb ap's a little different than described. I don't use a static IP and DNS, gateway but just use the DHCP client option - shouldn't be this the same in the end one's the ap's get there leases?

Also I wonder what is the best setting to have the clients roam nicely between the available access points (all have the same ssid). Any suggestions here?

In a network using dumb APs, the user's endpoint device (laptop, phone, etc) should get its DHCP configuration directly from the main router, including the DNS server IP. When an endpoint connects to a dumb AP,. the AP bridges the DHCP request and reply to/from the main router without any interpretation.

It is important that the DHCP servers in the dumb APs are disabled, because they will get into a race with the main router and provide incorrect configuration to endpoints.

The gateway and DNS settings in the AP affect only how the AP itself accesses the Internet, for example to set the real time and to install updates. This can be automatically configured by running the LAN in DHCP client mode.

2 Likes

The clients work on the dump APs and DHCP (from the main router) also works. Problems are actually only local host names.

Most obvious is when I use a phone with a app that relies on a local server in my network. When using the local IP it works, when using the local host name it doesn't work when I connected over the dump APs. If I connected over my main AP (also router which is the DHCP server) the local host names get resolved without problems :thinking:

Check the phone status and confirm that the main router is the DNS server.

1 Like

So I'm back again after 2 weeks fighting to improve my network. :stuck_out_tongue:

The DNS server settings were always set right from the upstream DHCP server on my main router.

But what did imrpove things actually were when I turned off my main routers wifi and a second repeater. So the wifi setup is now only made by the CPE210 on the pole, one facing to a building up, the other one down from over the roof into the building.

Like this more or less (just to get an idea where the units facing to):

Still I'm experiencing problems when streaming (even low resolution) video over wifi even with good signal.

Other thing which is still problematic is that I have a week signal on the lower part of the right building. I wonder what's best to overcome this. Sadly I don't have ethernet available there. Maybe I try a repeater in WDS mode at a location in the house with good signal to cover the inside better? :thinking:

Another thing I spotted was the the maximum transmit power. It is set to default resulting in (only?) 199mW and 23 dBm power. Is this good/correct?
image

Do some speed tests and video views with a wired connection to see what kind of performance you're getting from the ISP. Running sqm on the main router is always a good idea, if you can determine the ISP speed and find it consistent.

How many users of this network? As you expand coverage it's likely to get more usage.

I have no experience with the CPE210 so can't say what performance it should have. Realize that the typical phone or laptop's transmitter is 14 to 17 dBm, so a lot of extra power on the AP end isn't going to be the full solution.

2 Likes