Daisy chained AP lost after dumb AP setup

Hey there... once again I write my post because it was eaten by not working daisy chained setup :confounded:

What I have: Two cpe210 I want to use as AP only (alias dumb AP) with a wired backhaul to my main router (which does DHCP).

What I have installed so far (hardware wise):

[Router](lan-port)~~~~~poe-injector~~~~~(wan-port)[cpe1](lan-port)~~~~~(wan-port)[cpe1]

This was the initial state logic wise:

[Router](192.168.0.1), AP
[cpe1](192.168.1.1), AP Test 1
[cpe1](192.168.2.1), AP Test 2

All working (each on it's own DHCP server) for itself, all good at this very moment.

My plan was then to first get cpe1 working as dumb AP, for this I mapped the wan-port to the lan bridge and disabled then wan&wan6 interface. Then I followed the steps in the wiki.

I tried a coupe of times but the setting for the lan interface always got reset (static ip, gateway+dns on 0.1 and disabled dhcp were not saved). Now, the very last time I tried it looks it was not reverted - but it also doesn't work. I can't even access the web ui (the AP Test 1 is still present and I can connect) anymore and the cpe1 is actually adverting the gateway and dns from cpe (192.168.2.1).

I'm not sure what went wrong and how to fix this mess. I would appreciate any help, specially if it would involve not to touch the devices itself (fixed on a pole :tokyo_tower: couple of meters high in the rain :sweat_drops: and only accessible with a old, wet wooden ladder at this moment :expressionless:)

DumbAPs are not able to route, hence you need to revise the IP addresses to be all in the same subnet.
Router 0.1, cpe1 0.2, cpe2 0.3

3 Likes

I (think :stuck_out_tongue: ) I understand that: The inital setup was that the cpe's have there own dhcp server etc.

The setting I tried to "feed" the cpe1 (to act him like a dumb AP) was:

static IP: 192.168.0.4
gateway: 192.168.0.1
dns: 192.168.0.1
ignore DHCP, disable ipv6

This got reverted 3 or 4 times (the disabled startup of firewall, dnsmasq and odhcpd was kept) till I'm in this "soft bricked" kind of mode now. I can't access the web ui nor the ssh from cpe1 anymore.

I can access the openwrt web ui from cpe2 when I'm connected to the cpe1 wifi (AP Test 1) which is now serving gateway and dns from the cpe2 (192.168.2.1)...

Something went clearly wrong and I'm not sure how I can fix this wireless :thinking:

When you change the LAN IP and hit the Apply the device loses connectivity to the browser. That is why the countdown goes to zero and changes are reverted. You can force apply the changes, after the first failure, or use uci commands, or directly edit the configuration files

2 Likes

Good to know for the future.

For now I need to get access back to my device. Is there by chance any hard coded (fallback IP) available in openwrt the device could react on?

The bad thing about resetting it (should be possible using the poe injector if I understand) is that I need to climb up and getting the device dismounted because it is connected via it's wan-port to my local network. The second cpe(2) actually is connected to the lan jack of the cpe1 but as soon I reset it poe passthrough will be disabled and therfor cpe2 will not be powered anymore...

It's a big mess...

Would be so nice if openwrt could not only be reset but also forced to open a wifi ap..

IPv6 is always present, as link local at least, or ULA.

3 Likes

Yes what @trendy said, disconnect the cable from the rest of your network and use wireshark to determine the IPv6 addresses of the two APs.

1 Like

I only could disconnect the cable between the router and the first (not accessible) cpe1. The interconnection between cpe1 and cpe1 is still present, it's needed to power the second unit (and I also would need to climb to disconnect it). Still it's possible to access the cpe2 using it's wifi ap.

After some search I where able to find a dhpcv6 lease on the cpe2 which I think could belong to the cpe1. Sadly I was not able to ping/traceroute/ssh... it successfully.

I also changed the wan interface on the cpe2 to a static one and set the gateway to 192.168.1.1 as it is connected to the cpe1 and this was it's former IP. No luck here too...

If you have more ideas to recover the device - without resetting/physically accessing it - I'm happy to hear them :+1:

You'll have better luck with ip neigh show

1 Like

gives this result:

192.168.2.1 dev wlp1s0 lladdr 18:d6:c7:xx:xx:xx REACHABLE
fe80::1ad6:c7ff:fe36:b56 dev wlp1s0 lladdr 18:d6:c7:xx:xx:xx router STALE

no matter I'm connected to cpe1 or cpe2 (which both of the ip's belong to as they have the same mac).

Means that - despite I still can connect to the cpe1 wifi ap - there is no way to recover it without resetting it?

Did you try to ssh to the ipv6 link local?

1 Like

I tried, but not sure if something is wrong with my command? Never established a ssh connection to a ipv6 actually :thinking:

ssh root@fe80::1ad6:c7ff:fe36:b56
ssh: connect to host fe80::1ad6:c7ff:fe36:b56 port 22: Invalid argument

Try it with

or change the interface to the appropriate one.

1 Like

This works finally and I can connect. But as I suspected even I am connected to the access point of cpe1 (AP Test 1) the ipv6 address belongs to the over ethernet connected cpe2.

So despite the cpe1 is still spawning a access point there is nothing else left (web ui, ssh..) to configure it I think. :frowning:

I am out of ideas. Looks like you annihilated it beyond repair. Factory reset and follow the dumbAP guide.

on my way, just took down the APs from the pole and I'm still alive :raised_hands:

This is what was I did before. I will do it again, but this time on ground level :laughing:

1 Like

Could you give me just a little hint for the initial lan-port config, default looks like this:

image

I actually need to have both of the lan ports in the lan bridge (so no wan port at all) to be able to daisy chain them. I tried now a couple of ways but the configuration never succeeded.

Most obvious was to just add the eth0.2 interface to the lan bridge (br-lan) but I think it conflicts with the present wan interfaces. I also deleted them on one try and on another I added the wan interfaces to the lan firewall group. No luck for me, always reverts the settings and I'm back on the default setup. :thinking:

You can delete the wan and wan6 interfaces. Also the wan firewall zone.
Post the uci export network to take a look how it is organized.

I think the vlan switch did interfere. I now just disabled vlan functionality and deleted the wan+wan6 interface.

Here is my uci export network output:

package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8f:3f8e:1c7f::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0 eth0.1 eth0.2'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 4'
	option vid '2'

Am I good to try the Dumb Ap setup guide again? :grin:

Delete eth0.2 from lan ifname.
eth0 was already there, or did you add it?

Delete all this vlan2 section

Add port 4 in vlan 1.