D-Link-DGS-1210-28P: install OpenWrt from OEM web UI

Hi all
Trying to get a D-Link-DGS-1210-28P (version F1) moved across to OpenWRT
d-link system

-its lying about in my garage and I have a project that needs many ports so I thought-why not?

I've looked at



but the upgrade via the UI keeps on failing-just comes up with a message saying the firmware failed (it looks similar to one you would get if you tried to up any router that supports OpenWRT-but your using a firmware on the target device that was for another manufactuer). I've did this countless times with no joy.

d-link error

Has anybody managed to get this device flashed through the GUI?-happy to crack it open and do it serial wise but before I do that, reaching out to the community.


OpenWrt Installation is currently not available for web gui. See the reference git commit and

Your post duplicated with this:

Thanks for the confirmation-unfortunatley, whilst trying to get the JTAG method done, I blew up the power supply on the board! So have ordered another one off Ebay-well, its a DGS-1210-16 time time, so it should be the same upgrade instructions....

Meanwhile, I'm trying the JTAG method on a DGS-1210-10P but for some reason (and tried 2 USB to serial TTL devices), I can see the output but any keystrokes from my Mac (tried it on a Windows machine as well) are not being recognised by the switch (specifically the ESC key when trying to stop autoboot)-I'm going to try perservering but will probably need to wait for Mr Courier to arrive :slight_smile:

I can get into the switch with the normal GUI but no serial keystrokes-ah well.

You could try replicating the factory image implementation for the DG-1210-28:

As I understand, factory images should follow the same structure for the whole series, but best to check before potentially bricking your device.

28P and 28 are the same devices, just with a bigger PSU and PoE board plugged in.

1 Like

The only thing that might be device specific, is the CAMEO_BOARD_VERSION variable, but I suppose the 28's factory image could be tried on a 28P without any issues then.

I have all 3 devices (DSG-1210-28, DGS-1210-28P and DGS-1210-28MP) the main board has no differences. The 28P and 28MP just have bigger PSU and PoE board plugged ina as robimarko noted.

Cheers guys-unfortunatley, I cant get any keystokes recognised on the DGS-1210-10 model, so will need to wait until the "new" switch arrives-and then see how it goes (before I blew up the -24, the same USB to serial adaptor worked fine, so not sure what is going on there).

"New" DGS-1210-16 has arrived but same problem as before-it wont recognise the ESC button to stop the bootloader :frowning:

Its a G1 version-tried ecery combination but not joy-it just continues to boot-any idea why ESC wouldn't be recognised (using MacBook and SecureCRT V9.2.3)

U-Boot 2011.12.( (Jan 03 2018 - 11:05:15)

Board: RTL838x CPU:500MHz LXB:200MHz MEM:300MHz
DRAM:  128 MB
SPI-F: 1x32 MB
Loading 1024B env. variables from offset 0x80000
Board Model = DGS-1210-16-G1 Cameo_bdinfo_get_BoardID [293] 
Switch Model: RTL8382M_8218B_INTPHY_8214FC_DEMO (Port Count: 20)
Switch Chip: RTL8382
#### RTL8218B config - MAC ID = 0 ####
Now External 8218B
#### RTL8218B config - MAC ID = 8 ####
Now Internal PHY
**** RTL8214FC config - MAC ID = 24 ****
Now External 8214FC
et:   Net Initialization Skipped
Hit Esc key to stop autoboot:  1 

Loading Runtime Image ...


Can you enter characters at a later point, once the switch has fully booted up?
Control sequences (such as [ESC]) can be a bit special, so trying alternative terminal emulators (e.g. GNU screen et al) might be worth trying, if you have an x86 system at your disposal, you might also try a linux live CD or Windows.

1 Like

Top man!!
Using Windows 10 and Mobaxterm , I managed to load 21.02.3 and all working :slight_smile:

Only other problem is with 8MB flash, there's not much room left to put much on (and no USB slot)-but heh-ho-its been all good fun so far-thanks to the community


This is a switch, not a router. Therefore you shouldn't be putting much on it. The processor isn't up to doing much anyway.

1 Like

Thanks-so a lot of effort for not much return but the main aim was to turn all the LAN ports into WAN ports, which is does, so all good. And it was a chance to improve my soldering skills :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.