[DGS-1210-28] Installation via Web UI fails

I bought a DGS-1210-28 since according to the TOH it is supported. After verifying that I got a supported HW version (F2) I opened the package and performed the installation steps written in the commit message. Unfortunately, it doesn't work. The web UI shows an error message ("Check the firmware file") after the upload of the file is completed.
I tried both the snapshots and the release builds.
After that, I tried flashing OpenWRT again on all other publicly available FW images, but I keep getting the same error.

Does anyone of you has any suggestion what to do before opening the case?

tried ssh and sysupgrade, as written in the commit ?

To which commit are you referring? In the commit message I know of is nothing written about ssh.

I just checked out the ssh connection. Unfortunately it doesn't provide a busybox shell. This is just some vendor-specific CLI that is documented in the manual (see link in my first post). There is no sysupgrade available.

sysupgrade implies ssh.

Unfortunately using TFTP it's also not working:

DGS-1210-28> download firmware_fromTFTP sysupgrade.bin
 Connecting to server................... Done.
 Download firmware...................... Done.  Do not power off!

% Image Updated Failed [INTERNAL ERROR]


you might be able to find something useful in Support for RTL838x based managed switches

1265 posts.. So see you next week I guess? :smiley:

you sure you used the correct image, that -------------^ is not what the commit tells you to use.

I tried both the sysupgrade and the initramfs. Unfortunately this is not the TFTP of the bootloader but from the D-LINK fw upgrade utility. So it seems to fail like the upgrade method via the Web UI.
The only other thing I could do would be soldering a pin header to the board, but I would like to avoid that because of the warranty sticker.


Hi @slh ,
thanks for linking the corresponding commit message again. Would you care to elaborate?

The referenced commit message has the installation steps (tfpboot an initramfs image from serial console, sysupgrade from there), it's not as nice as having the ability from flash from the webinterface - but it's a proven alternative.

Thank you for pointing this out again :+1:

Hi @slh and @frollic,
I successfully installed OpenWRT using the TFTP method.
I figured out that the commit message is wrong. Installation is currently not possible via the OEM web interface. The switch needs to be opened and you need to attach to the unpopulated serial interface in order to enable TFTP boot.
See: Support for RTL838x based managed switches - #1279 by exponentialverteilt
Thank you for your help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.