Connecting to a Wi-Fi with mschapv2 protection

I have a school Internet connection to which we connect using a username and password. I bought a router and installed the firmware to connect to it, since the connection from the laptop catches poorly.

I can't find the ability to connect to the network using a username and password. At first, it asks for WPA passphrase, but there you need both a username and password

I tried to connect using a random password, and then change the protocol to pppoe in the interface settings.

But this did not change anything and there was no Internet either. Help me, what can I do?

mschapv2 means 802.1x and a radius server, which is quite common on business networks for login authentication.
But I have no good answer how to get a router to login to a radius server.

I tried to connect using a random password, and then change the protocol to pppoe in the interface settings.

But I guarantee this will not work and the IT department will see this random password attempts in the logs.

Haven’t you got a username and password to begin with as a student?

Everything is there and they do not look after it and I do not think that any punishment can follow. I need this in order for the router to catch Wi-Fi and transmit it to me, since my laptop catches very poorly. In general, work as a signal amplifier

Temporarily connect the router to the Internet by other means, such as a smartphone hotspot. Remove the wpad-basic-wolfssl software package and install wpad-wolfssl.

Then reboot the router. Go to the wifi page for your client, security tab, and set up WPA Enterprise (WPA2, not WPA2-PSK). The wan or wwan network should remain as DHCP Client.

Yes, I connected to the phone temporarily. You can read a little more, I just recently began to understand at least a little.

This is the network that I need to connect to, but it only ask me to enter a password (WPA passphrase with out login)

I need to be able to log in using a username and password, as an example in Windows

(login client

What will it give me?

If i have "Unable to execute opkg remove command: PermissionError: Exec permission denied" What can i do?

Update the package list first. If that still doesn't work on web gui, use the CLI.

What router model and what OpenWrt version are you using?

Tp-Link C7 AC1750 V5. Updated. Version 21

It is all what i have

I downloaded it as you said, but I don't have just WPA2

Sorry, use WPA2-EAP.

1 Like

"The authentication type is not applicable to the selected EAP"
Now I have such a problem

What can i do? I didnt find solve

Choose PEAP for EAP-Method (as you have) and EAP-MSCHAPv2 for Authentication. This is the only method supported by Windows so nearly all campus systems use it.

1 Like

Still, for some reason, it does not find it, although all the data is correct. Maybe I need to do something else?

Also, what about this, do I need to enter something there?

Where are you seeing that? WPA passphrase is not one of the parameters for EAP, it should not appear on the screen.

1 Like