Configuring WireGuard VPN[solved]

Installed Wireguard and luci-app-wireguard. Seems OK. However, the next step is:

Creating a Wireguard interface

To create a new Wireguard interface go to Network > Interfaces > Add new interface… and select “Wireguard VPN” from the “Protocol of the new interface” dropdown menu.

However, I do not see "Wireguard VPN" as one of my choices. Did I forget a step?

What version of OpenWrt are you using, and on what device? Did you see any errors or warnings during the installation process?

OpenWrt 19.07 on a Netgear r7800, and no I did not see any errors.
Got some info about installation in this post.

try installing again, via ssh.

opkg update
opkg install wireguard luci-app-wireguard

The output should indicate that the packages are already installed on root. But if it says anything else, hopefully it will manage to complete the installation this time around. Make note of any output and update the thread with anything of interest.

EDIT: in my experience thus far, installing via CLI, just the two packages I referenced are sufficient to install all related dependencies. But you could also install everything explicitly as @lleachii suggested in that post.

1 Like

OK, re-did and got:

root@OpenWrt:~# opkg install wireguard luci-app-wireguard
Package wireguard (1.0.20200506-1) installed in root is up to date.
Package luci-app-wireguard (git-20.136.49537-fb2f363-1) installed in root is up to date.

However, there is still no VPN choice in the Interfaces > Add new > Protocol dropdown

Da! Needed to reboot, now Wireguard VPN shows up in Interfaces > New > Protocol

Add luci-proto-wireguard?


After installing those packages you must reboot your device to see wireguard and able to create wg interface

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.