Wireguard dependancy hell?[solved]

I want to install Wireguard on OpenWRT 19.07 router (Netgear 7800). The docs say install "wireguard" and luci-app-wireguard. However, each shows many uninstalled dependancies. So I tried to install those first, but they also had dependancies. I've been using debian based linux distros for years and apt mostly handles those. Not sure how to proceed...I don't want to mess things up. thx.

opkg update
opkg install kmod-udptunnel4 kmod-udptunnel6 kmod-wireguard wireguard-tools wireguard luci-proto-wireguard luci-app-wireguard

I've only installed from cli with the following packages: luci-proto-wireguard luci-app-wireguard wireguard kmod-wireguard wireguard-tools and it worked for me.

With those any dependencies have been installed as required. I haven't paid attention of there is actually any dependencies though.

@ lleachii OK, used ssh and that seems to work w/o errors. Did I make a mistake to try to do this from the Luci > Software interface?

So now WG should be fully installed and I can start configuration?

LuCI calls opkg which installs the dependencies automatically.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.