Configuring tagged and untagged vlan with DSA

Hi all,

I'm trying to setup a configuration with a TP-Link Archer C6V3 (snapshot release).
I already read the related docs:

And after two days of trying I'm stuck, everything works as expected unless I try to use the bridge-vlan.
My goal is to have the wan port untagged bridged to a tagged vlan on lan2 port.
Here my configuration:

[...]

config device
	option name 'br0'
	option type 'bridge'
	list ports 'wan'
	list ports 'lan2'

config bridge-vlan
	option device 'br0'
	config vlan '10'
	list ports 'wan:u*'
	list ports 'lan2:t*'

config interface 'wan'
	option device 'br0.10'
	option proto 'dhcp'

config interface 'wan6'
	option device 'br0.10'
	option proto 'dhcpv6'

[...]

the brctl shows:

# brctl show
bridge name	bridge id		STP enabled	interfaces
br0		7fff.3460f929ffa2	no		    lan2
                                        wan

The wan led is on and the lan led is off.
If I set wan interface on device 'wan' the port start working correctly, so the problem seems to be related to the bridge-vlan.

After the network restart I can see all the expected interfaces with "ifconfig" command, but the br0.10 has 0 RX Bytes, instead the "wan" interface has traffic both RX and TX. So the port is phisically receiving traffic but something is broken with the binding with the bridge.

Thank you for your help

You shouldn't need the asterisk on the tagged port AFAIK.

Hi,

I found the error, it was:

	config vlan '10'

and it should be:

	option vlan '10'

two days lost for such a silly error...

@Borromini thank you for your answer, actually I didn't understand the asterisk meaning. I read about the EGRESS and INGRESS tagging. But what happens without it?

1 Like

Asterisk means default VLAN. See:

Great, I got it.

And I see that if I set more vlan as "default" some interface doesn't work.
Thank you.

Default VLAN is where incoming untagged packets will go (also called pvid). It is only an issue if you are trying to mix tagged and untagged on the same port.

On a fully trunked cable (all of its VLANs are tagged), you would want any stray untagged packets to be discarded. Full trunking is the recommended practice.

1 Like

Is it possible with this new configuration method to rename interfaces?

I mean that I was used to call my bridges br-something instead of brX.Y and I like to see a significant name with ip addr/ifconfig or use it with iptables.

I have this problem configuring several interface on the tagged vlans:
br0.1, br0.2, br0.3.... instead of: br-wan, br-office, br-guest ecc...

Is there a way to rename the interface with a custom label?

You can, I renamed my tagged WAN interface 'fiber' e.g.:

config device                                                            
        option name 'p8'                                                 
                                                                         
config device                                                            
        option type '8021q'                                              
        option ifname 'p8'                                               
        option vid '10'                                                  
        option name 'fiber'

config interface 'wan'
	option proto 'pppoe'
	option username '..........'
	option password '..............'
	option ipv6 '1'
	option device 'fiber'

config interface 'wan6'
	option proto 'dhcpv6'
	option device '@wan'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.