Configure OpenWrt as an access point with pfsense


Can any of the experts in this forum please help me how to set up openwrt as an access point?

I have the following connection:

Netgear modem -> Pfsense -> WRT32x Openwrt

Pfsense is configured and working just fine. It's IP is and netmask is

On the WRT32x side i made the following changes on the LAN Interface:
I turned off DHCP


I also disabled IP6.


I kept IP4 and netmask and gateway and DNS to default


I also disabled the following from System - > startup
firewall, dnsmasq and odhcpd

Then I restarted WRT32x and connected a cable from on of the pfsense ports to one of the Ethernet ports on the wrt32x ( not the WAN port).

The internet is working on the clients but I am unable to access LUCI web interface on the wrt32x even when I plug a cable directly from a PC to the wrt32x.

Are the changes I made correct? or did I mess up something?

I tried to look for wrt32x in the list of connected clients on pfsense DHCP Lease to see if it was assigned a different IP but it was not listed there.

I also attempted to change the LAN Interface settings on wrt32x to the following but the moment I apply the settings I would lose connection to the router and to the internet.


I would appreciate your help
Thanks in advance

you need the WRT32X to have an ip address in your subnet, so the second config you show is correct. once you set that up, you should then restart the networking on your computer.

I have the same setup. Follow the guide at

Thanks @dlakelan and @farr4744

I will try what you guys suggested but I have a couple of questions:

  1. @dlakelan when you say restart networking on my computer, do you mean restart the networking service or just simply restart the computer?

  2. Since I currently cannot access LUCI interface on WRT32X because I kept IP4 and netmask and gateway and DNS to default ( please see the picture of the first configuration which I uploaded in my first post). So WRT32X IP is and the Pfsense IP is and WRT32X is already connected to Pfsense and I have internet access but not access to Luci on WRT32x.

Do you have any suggestions on how to access WRT32X and change the IP from to and also update the gateway and dns on WRT32x to be

I tried to disconnect WRT32x and connected it directly to my computer but I still could not access Luci.

Thanks again for your help guys

BTW, you won't see a static address appear in a list of DHCP leases.

If you connected the OpenWrt via LAN-to-LAN port, you need to address it as 192.168.11.x. You'll also need to set a gateway if you want AP to access the Internet to get time, etc.

You also wont see LuCI by plugging directly in until you properly address the computer to the OpenWrt. This is because you turned off DHCP.

1 Like

Connect directly to your PC and set a static IP of (or anything in the 192.168.1.X subnet) in the computer. Then access the router at and change the LAN IP DNS and gateway. Click "save and apply" and then don't touch anything until you get the "configuration has been rolled back" screen. Click the red "Apply unchecked anyway" button. Now you can connect the 32X back to your main network, set the PC to DHCP, and it should all be working in the 192.168.11 network.

Generally I set up dumb APs as DHCP Clients so they will get a usable IP automatically, of course you have to connect to a working main router to access them at all then.


Thanks @lleachii and @mk24
@lleachii You are correct about the DHCP leases. I do see OpenWRT listed on the DHCP leases page on the Pfsense.

@mk24 I will try what you suggested and I will let you know if I face any issues. I am assuming that once I have made the changes you mentioned and I connect Openwrt back to Pfsense I would be able to access Luci normally at 192.168.11.X without having to disconnect it from Pfsense and connecte it directly LAN to LAN to my computer. Is this correct?

You will get a DHCP lease if you plugged the pfsense network to the WAN port on OpenWrt. But you would not do that with a dumb AP. If you set the LAN to be a DHCP client then it will get a lease and likely you could access it by name such as 'wrt32x.lan'. Set the DHCP hostname on the LAN configuration page it is not the same as the general hostname from the system admin page.

Thanks @mk24
This resolved the issue. I just kept OpenWRT connected to Pfsense and I plugged a cable directly from my computer to one of the LAN ports on OpenWRT and then I manually changed the IP address of my computer to and I was able to access OpenWRT interface at I made the changes to LAN DNS and gateway and then changed the IP on my computer to DHCP Automatic and I disconnected and re-connected the cable on my computer to get a new IP from Pfsense. Thanks again!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.