Configuration issue raspberry Pi 3B

I reflashed, and I restart from scratch.

My router is still inside a larger but local network, so I don't need a WAN ?

I think I start understanding my mistakes. I still need ETH0 and ETH1 because they are two different interfaces.
I have LAN wich is DHCP and ETH0. Now I need another interface let's call it DEVICE with DHCP and ETH1 ?

In the scenario depicted above you can do the following:
LAN eth1 and DHCP if device runs DHCP server. Then you would have to switch off DHCP server on LAN port of Openwrt. If there is no other DHCP server, you need to assign static IP.
WAN eth0 and DHCP or PPPoE, depends on the provider. Allow port 22 on WAN interface in firewall section.

1 Like

My mistakes came from the WAN. On the diagram "internet" isn't the provider connection, it's another LAN.
This is what I have and I can communicate with the device. I will try to drop the connections and If it works the problem will be solved :slight_smile:
Screenshot_20190411_160152

Your configuration still doesn't make sense. You have eth1 as interface DEVICE and also included in LAN interface.

OK, from the beginning:

  • You have internet connection, coming from a router right?
  • You want to connect the Pi to the router via an Ethernet cable?
  • You want to connect the Pi to another device by cable
  • And you want also to access the Pi by WiFi, right?

If you want the Pi network to be separate from the bigger network, then make one of the eth as WAN, and connect it to the bigger network. Bridge the other eth with the WiFi.

Else, if you want the Pi network to be part of the bigger network, then make one bridged interface of both eth0 an eth1, plus the WiFi.

It's essential to make sure that you have proper configuration as base case before you get into "what if" scenarios.

Yes.

Yes, to obviously get Internet.

Yes using the USB interface and so USB-ethernet adapter (Already working).

No I access to the PI because my computer is connected to the same local network (via WIFI). I don't need WiFi on the Pi because I use a wire connection for internet.

So you have this scenario:

  +------------+
  |            |
  |  Device    |
  +------------+
           +                +------+
           | USB            |      |
  +--------v---+            | PC   |
  |            |            |      |
  | Raspberry  |            +------+
  +------------+               +
            +                  |
            |Ethernet          |Wifi
            |                  |
            |                  +
            |   +-------------------+
            |   |                   |
            +-->|   Router          |
                +-------------------+
                       +
                       v
                    Internet

Does the device need to get IP settings from the Router or can it take them from Raspberry?

  1. If it takes settings from Router, then you need to bridge eth0 and eth1 as one interface. But iptables will not work well on a bridged interface. Take a look here.
  2. If it acquires settings from Raspberry keep the 2 interfaces but you need to remove the bridge and assign one in LAN firewall zone (to the device) and the the other to WAN firewall zone (to the Router). Don't forget to enable NAT, the default Openwrt configuration works fine in this setup.
1 Like

I don't know if from where it takes the settings matters. I'll try to get it acquiring the setting from the RPi.

EDIT : I made the changes, DEVICE to the LAN firewall and the other one to the WAN but now I can't access it anymore. Looks like I have to reflash again

(Nice diagram btw, how did you make it ?)

Did you allow SSH from WAN zone in firewall?

http://www.asciidraw.com/#Draw

2 Likes

Oh, I thought you were a die-hard keyboard and console guy!

2 Likes

At the university, behind the fat monitor of a Solaris.
Those were the days ...

2 Likes

I have allowed SSH but not for the WAN zone in firewall otherwise I still use a monitor and keyboard with the Pi.

New day, new start.
I will try to go step-by-step.

This is what I have :

I now need another interface to get the USB working with ethernet right ?

Yes add the USB, assign it under Interface name Device. If necessary provide DHCP to the device. Assign the Device interface under LAN firewall zone.
Then change the restrictions of the WAN firewall zone into ACCEPT for INPUT and FORWARD.
Move LAN interface into WAN zone of firewall. Add a forwarding rule from WAN to LAN.
Post here the configs if it doesn't work.

1 Like

What do you mean ?

This is my configuration :

From this configuration the USB-Ethernet doesn't work anymore. Should I bridge the LAN interface to it ?
I can imagine that it will pose a problem for the IPTABLES working.

image
You need to allow the reverse direction too if you want to reach the device from the WAN firewall zone. Also create some port forwarding for IPv4 for the same.

No.
Login by ssh and provide us the following:
cat /etc/config/network; cat /etc/config/firewall; cat /etc/config/wireless ; cat /etc/config/dhcp ; ip -4 addr ; ip -4 ro ; ip -4 ru
Paste in Preformated text.

It this correct ?

I did it, what is it for ?

Still get USB-ETHERNET not working

Why? Wouldn't it be all easier to just have both on-board LAN and USB LAN as br-lan interface?

If you have both interfaces in bridge, the iptable rules won't work properly, you'll need ebtables.

No, go to LAN and allow traffic from WAN. Delete the NEWZONE.

Paste the output here, in preformatted text. (Ctrl+Shift+c)

1 Like

Done :

OUTPUT :

root@OpenWrt:~# cat /etc/config/network; cat /etc/config/firewall; cat /etc/config/wireless ; c
at /etc/config/dhcp ; ip -4 addr ; ip -4 ro ; ip -4 ru

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda2:f5b2:9a1a::/48'

config interface 'lan'
        option type 'bridge'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option proto 'dhcp'
        option ifname 'eth0'

config interface 'device'
        option proto 'dhcp'
        option ifname 'eth1'


config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'device'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config forwarding
        option dest 'lan'
        option src 'wan'

config forwarding
        option dest 'wan'
        option src 'lan'


config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'lan'


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.178.45/24 brd 192.168.178.255 scope global br-lan
       valid_lft forever preferred_lft forever
default via 192.168.178.1 dev br-lan  src 192.168.178.45 
192.168.178.0/24 dev br-lan scope link  src 192.168.178.45 
0:      from all lookup local 
32766:  from all lookup main 
32767:  from all lookup default 

The USB-Ethernet still not working, is this normal ?

Careful here, you are providing DHCP back to the ISP router. You want to ignore this interface.

ifconfig -a ; dmesg | grep -i eth ; dmesg | grep -i usb; lsmod

OUTPUT :

root@OpenWrt:~# ifconfig -a ; dmesg | grep -i eth ; dmesg | grep -i usb; lsmod
br-lan    Link encap:Ethernet  HWaddr XXXXXXXXXXBE  
          inet addr:192.168.178.45  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: fda2:f5b2:9a1a::1/60 Scope:Global
          inet6 addr: fe80::ba27:ebff:fe53:bebe/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:310062 errors:0 dropped:6290 overruns:0 frame:0
          TX packets:60908 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:48202911 (45.9 MiB)  TX bytes:12483474 (11.9 MiB)

eth0      Link encap:Ethernet  HWaddr XXXXXXXXXX:BE  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:314593 errors:0 dropped:0 overruns:0 frame:0
          TX packets:61995 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:48655894 (46.4 MiB)  TX bytes:13239038 (12.6 MiB)

eth1      Link encap:Ethernet  HWaddr XXXXXXXXX:44  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2831 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8000 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:633055 (618.2 KiB)  TX bytes:2208797 (2.1 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:12772 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12772 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:1465502 (1.3 MiB)  TX bytes:1465502 (1.3 MiB)

wlan0     Link encap:Ethernet  HWaddr XXXXXXXXX:EB  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

[    2.785203] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:53:be:be
[   11.443037] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   11.457325] br-lan: port 1(eth0) entered blocking state
[   11.468053] br-lan: port 1(eth0) entered disabled state
[   11.478845] device eth0 entered promiscuous mode
[   29.330632] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC1E1
[   29.351722] br-lan: port 1(eth0) entered blocking state
[   29.366366] br-lan: port 1(eth0) entered forwarding state
[   68.919522] br-lan: port 1(eth0) entered disabled state
[   68.941264] device eth0 left promiscuous mode
[   68.954651] br-lan: port 1(eth0) entered disabled state
[   68.969968] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   68.989384] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   70.852662] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   70.865963] br-lan: port 1(eth0) entered blocking state
[   70.875480] br-lan: port 1(eth0) entered disabled state
[   70.885058] device eth0 entered promiscuous mode
[   70.894980] br-lan: port 1(eth0) entered blocking state
[   70.904459] br-lan: port 1(eth0) entered forwarding state
[   71.925903] br-lan: port 1(eth0) entered disabled state
[   72.423452] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC1E1
[   72.442547] br-lan: port 1(eth0) entered blocking state
[   72.455176] br-lan: port 1(eth0) entered forwarding state
[  484.288393] r8152 1-1.2:1.0 eth1: v1.08.9
[  886.334741] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[  886.369896] r8152 1-1.2:1.0 eth1: carrier on
[  886.380722] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 3064.353470] br-lan: port 2(eth1) entered blocking state
[ 3064.365051] br-lan: port 2(eth1) entered disabled state
[ 3064.376766] device eth1 entered promiscuous mode
[ 3064.387566] br-lan: port 2(eth1) entered blocking state
[ 3064.398872] br-lan: port 2(eth1) entered forwarding state
[ 3064.410900] r8152 1-1.2:1.0 eth1: Promiscuous mode enabled
[ 3173.868814] device eth1 left promiscuous mode
[ 3173.879366] br-lan: port 2(eth1) entered disabled state
[ 3174.089175] r8152 1-1.2:1.0 eth1: carrier on
[ 3174.169412] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3174.228658] r8152 1-1.2:1.0 eth1: carrier on
[ 3174.309449] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3174.368706] r8152 1-1.2:1.0 eth1: carrier on
[ 3174.449456] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3174.508973] r8152 1-1.2:1.0 eth1: carrier on
[ 3174.589420] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3174.648906] r8152 1-1.2:1.0 eth1: carrier on
[ 3174.729427] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3174.788911] r8152 1-1.2:1.0 eth1: carrier on
[ 3174.869452] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3174.928853] r8152 1-1.2:1.0 eth1: carrier on
[ 3175.009454] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3175.068612] r8152 1-1.2:1.0 eth1: carrier on
[ 3175.149465] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3175.208520] r8152 1-1.2:1.0 eth1: carrier on
[ 3175.289493] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3175.348748] r8152 1-1.2:1.0 eth1: carrier on
[ 3175.429418] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3175.488658] r8152 1-1.2:1.0 eth1: carrier on
[ 3202.915963] br-lan: port 2(eth1) entered blocking state
[ 3202.927823] br-lan: port 2(eth1) entered disabled state
[ 3202.939878] device eth1 entered promiscuous mode
[ 3202.951067] br-lan: port 2(eth1) entered blocking state
[ 3202.962732] br-lan: port 2(eth1) entered forwarding state
[ 3202.974847] r8152 1-1.2:1.0 eth1: Promiscuous mode enabled
[ 3234.757243] device eth1 left promiscuous mode
[ 3234.768252] br-lan: port 2(eth1) entered disabled state
[ 3234.939811] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3234.999597] r8152 1-1.2:1.0 eth1: carrier on
[ 3235.080393] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3235.138956] r8152 1-1.2:1.0 eth1: carrier on
[ 3235.229885] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3235.290507] r8152 1-1.2:1.0 eth1: carrier on
[ 3235.359858] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3235.420917] r8152 1-1.2:1.0 eth1: carrier on
[ 3235.489949] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 3235.548879] r8152 1-1.2:1.0 eth1: carrier on
[    0.143321] usbcore: registered new interface driver usbfs
[    0.143419] usbcore: registered new interface driver hub
[    0.143512] usbcore: registered new device driver usb
[    0.879072] usbcore: registered new interface driver lan78xx
[    0.885041] usbcore: registered new interface driver smsc95xx
[    1.403249] dwc_otg 3f980000.usb: DWC OTG Controller
[    1.408445] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number 1
[    1.416116] dwc_otg 3f980000.usb: irq 15, io mem 0x00000000
[    1.443225] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.457048] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.457059] usb usb1: Product: DWC OTG Controller
[    1.457066] usb usb1: Manufacturer: Linux 4.9.152 dwc_otg_hcd
[    1.457073] usb usb1: SerialNumber: 3f980000.usb
[    1.457724] hub 1-0:1.0: USB hub found
[    1.458544] usbcore: registered new interface driver uas
[    1.458652] usbcore: registered new interface driver usb-storage
[    1.881284] usb 1-1: new high-speed USB device number 2 using dwc_otg
[    2.141619] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
[    2.152167] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.163995] hub 1-1:1.0: USB hub found
[    2.511235] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[    2.651518] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[    2.665696] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.785203] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:53:be:be
[    3.231250] usb 1-1.3: new full-speed USB device number 4 using dwc_otg
[    3.383140] usb 1-1.3: New USB device found, idVendor=24ae, idProduct=2010
[    3.397797] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.412878] usb 1-1.3: Product: Rapoo 2.4G Wireless Device
[    3.426142] usb 1-1.3: Manufacturer: RAPOO
[    7.415102] input: RAPOO Rapoo 2.4G Wireless Device as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/0003:24AE:2010.0001/input/input0
[    7.432998] hid-generic 0003:24AE:2010.0001: input,hidraw0: USB HID v1.10 Mouse [RAPOO Rapoo 2.4G Wireless Device] on usb-3f980000.usb-1.3/input0
[    7.456450] input: RAPOO Rapoo 2.4G Wireless Device as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.1/0003:24AE:2010.0002/input/input1
[    7.541488] hid-generic 0003:24AE:2010.0002: input,hiddev0,hidraw1: USB HID v1.10 Device [RAPOO Rapoo 2.4G Wireless Device] on usb-3f980000.usb-1.3/input1
[    7.563348] input: RAPOO Rapoo 2.4G Wireless Device as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.2/0003:24AE:2010.0003/input/input2
[    7.641383] hid-generic 0003:24AE:2010.0003: input,hidraw2: USB HID v1.10 Keyboard [RAPOO Rapoo 2.4G Wireless Device] on usb-3f980000.usb-1.3/input2
[    7.659388] usbcore: registered new interface driver usbhid
[    7.669401] usbhid: USB HID core driver
[    8.005330] usbcore: registered new interface driver brcmfmac
[  176.022498] usb 1-1.5: new high-speed USB device number 5 using dwc_otg
[  176.164111] usb 1-1.5: New USB device found, idVendor=0bda, idProduct=8152
[  176.178051] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  176.192174] usb 1-1.5: Product: USB 10/100 LAN
[  176.203453] usb 1-1.5: Manufacturer: Realtek
[  176.214605] usb 1-1.5: SerialNumber: A0CEC81F658F
[  306.541414] usb 1-1.5: USB disconnect, device number 5
[  325.959119] usbcore: registered new interface driver rtl8150
[  333.089219] usbcore: registered new interface driver r8152
[  483.735967] usb 1-1.2: new high-speed USB device number 6 using dwc_otg
[  483.877562] usb 1-1.2: New USB device found, idVendor=0bda, idProduct=8152
[  483.896227] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  483.915371] usb 1-1.2: Product: USB 10/100 LAN
[  483.931578] usb 1-1.2: Manufacturer: Realtek
[  483.947533] usb 1-1.2: SerialNumber: A0CEC81F6444
[  484.065992] usb 1-1.2: reset high-speed USB device number 6 using dwc_otg
brcmfmac              157224  0 
brcmutil                4992  1 brcmfmac
cfg80211              211664  1 brcmfmac
compat                  4864  2 brcmfmac,cfg80211
crc_ccitt               1152  1 ppp_async
evdev                  10752  0 
fat                    44088  1 vfat
hid                    84632  2 usbhid,hid_generic
hid_generic              896  0 
ip_tables               9828  4 iptable_nat,iptable_mangle,iptable_filter
ip6_tables              9496 24 ip6table_mangle,ip6table_filter
ip6t_REJECT             1152  2 
ip6table_filter          896  1 
ip6table_mangle         1152  1 
ipt_MASQUERADE           896  1 
ipt_REJECT              1024  2 
iptable_filter          1024  1 
iptable_mangle          1152  1 
iptable_nat             1152  1 
nf_conntrack           58948  9 nf_conntrack_ipv6,xt_state,xt_conntrack,xt_CT,nf_nat_masquerade_ipv4,nf_conntrack_ipv4,nf_nat_ipv4,nf_nat,nf_conntrack_rtcache
nf_conntrack_ipv4       5888 11 
nf_conntrack_ipv6       6144  6 
nf_conntrack_rtcache    2688  0 
nf_defrag_ipv4          1024  1 nf_conntrack_ipv4
nf_defrag_ipv6          4616  1 nf_conntrack_ipv6
nf_log_common           2560  2 nf_log_ipv4,nf_log_ipv6
nf_log_ipv4             3328  0 
nf_log_ipv6             3328  0 
nf_nat                  9738  4 xt_nat,nf_nat_redirect,nf_nat_masquerade_ipv4,nf_nat_ipv4
nf_nat_ipv4             3586  1 iptable_nat
nf_nat_masquerade_ipv4    1540  1 ipt_MASQUERADE
nf_nat_redirect         1024  1 xt_REDIRECT
nf_reject_ipv4          2048  1 ipt_REJECT
nf_reject_ipv6          2304  1 ip6t_REJECT
nls_cp437               5632  1 
nls_iso8859_1           4096  1 
nls_utf8                1024  0 
ppp_async               6532  0 
ppp_generic            21664  3 pppoe,ppp_async,pppox
pppoe                   8448  0 
pppox                   1440  1 pppoe
r8152                  28288  0 
rtl8150                 7808  0 
slhc                    4096  1 ppp_generic
snd                    43320  8 snd_compress,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_rawmidi,snd_seq_device,snd_hwdep
snd_compress            6912  0 
snd_hwdep               4872  0 
snd_mixer_oss          12672  1 snd_pcm_oss
snd_pcm                59792  2 snd_pcm_dmaengine,snd_pcm_oss
snd_pcm_dmaengine       2432  0 
snd_pcm_oss            31008  0 
snd_rawmidi            15264  0 
snd_seq_device          2440  1 snd_rawmidi
snd_timer              15416  1 snd_pcm
soundcore               3984  1 snd
usbhid                 22824  0 
vfat                    7424  1 
x_tables               11784 23 ipt_REJECT,ipt_MASQUERADE,xt_time,xt_tcpudp,xt_state,xt_nat,xt_multiport,xt_mark,xt_mac,xt_limit,xt_conntrack,xt_comment,xt_TCPMSS,xt_REDIRECT,xt_LOG,xt_CT,iptable_mangle,iptable_filter,ip_tables,ip6t_REJECT,ip6table_mangle,ip6table_filter,ip6_tables
xt_CT                   2816  0 
xt_LOG                  1024  0 
xt_REDIRECT              896  0 
xt_TCPMSS               2688  2 
xt_comment               768123 
xt_conntrack            2304 16 
xt_limit                1284 20 
xt_mac                   896  0 
xt_mark                  896  0 
xt_multiport            1408  0 
xt_nat                  1536  0 
xt_state                 896  0 
xt_tcpudp               2048 10 
xt_time                 1664  0